aboutsummaryrefslogtreecommitdiff
path: root/graphics/c-a-i-r
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-16 01:07:34 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-16 01:07:34 +0000
commitacddf8cee482b1e1dcb390043c9c89921c7ea633 (patch)
treeca54fb2030db8b048f85b70d4c6c1f8481e9c3ea /graphics/c-a-i-r
parenta6994d914788c95279cab392579b4be8d0bd6535 (diff)
downloadports-acddf8cee482b1e1dcb390043c9c89921c7ea633.tar.gz
ports-acddf8cee482b1e1dcb390043c9c89921c7ea633.zip
Notes
Diffstat (limited to 'graphics/c-a-i-r')
-rw-r--r--graphics/c-a-i-r/Makefile6
-rw-r--r--graphics/c-a-i-r/distinfo6
-rw-r--r--graphics/c-a-i-r/files/patch-CAIR.cpp50
3 files changed, 22 insertions, 40 deletions
diff --git a/graphics/c-a-i-r/Makefile b/graphics/c-a-i-r/Makefile
index 6c8925b661f0..2192bb1aa65b 100644
--- a/graphics/c-a-i-r/Makefile
+++ b/graphics/c-a-i-r/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= c-a-i-r
-PORTVERSION= 2.17
+PORTVERSION= 2.19
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/CAIR%20v${PORTVERSION}
-DISTNAME= CAIR_MT_v2.17
+DISTNAME= CAIR_v${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= Content Aware Image Resizer is an implementation of seam carving
@@ -22,6 +22,6 @@ WRKSRC= ${WRKDIR}
PLIST_FILES= bin/cair
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/cair ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cair ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/graphics/c-a-i-r/distinfo b/graphics/c-a-i-r/distinfo
index f6ad34880c1e..c42ccf710bee 100644
--- a/graphics/c-a-i-r/distinfo
+++ b/graphics/c-a-i-r/distinfo
@@ -1,3 +1,3 @@
-MD5 (CAIR_MT_v2.17.zip) = 0bf903c4550d44a3467f676d41c05a41
-SHA256 (CAIR_MT_v2.17.zip) = 85178eaba17a14e86bd5f81e345a393397db20569b79350fed6c146c89fdc188
-SIZE (CAIR_MT_v2.17.zip) = 217913
+MD5 (CAIR_v2.19.zip) = 28a9dc0dd1e9f7cb9218bb7e0d380a1d
+SHA256 (CAIR_v2.19.zip) = 41fe2f3d28de657648a543c0af98cfc646ed33b6ebef4158a3874f1bf6ff2853
+SIZE (CAIR_v2.19.zip) = 212614
diff --git a/graphics/c-a-i-r/files/patch-CAIR.cpp b/graphics/c-a-i-r/files/patch-CAIR.cpp
index 25429035936d..9292b9dbe1bc 100644
--- a/graphics/c-a-i-r/files/patch-CAIR.cpp
+++ b/graphics/c-a-i-r/files/patch-CAIR.cpp
@@ -1,56 +1,38 @@
---- CAIR.cpp.orig 2008-10-19 19:15:39.000000000 +0800
-+++ CAIR.cpp 2008-10-19 19:17:24.000000000 +0800
-@@ -252,7 +252,7 @@
+--- CAIR.cpp.orig 2010-03-16 08:51:06.000000000 +0800
++++ CAIR.cpp 2010-03-16 08:55:11.000000000 +0800
+@@ -276,7 +276,7 @@
//Our thread function for the Grayscale
void * Gray_Quadrant( void * id )
{
-- int num = (int)id;
-+ long int num = (long int)id;
+- int num = *((int *)id);
++ long int num = *((long int *)id);
while( true )
{
-@@ -417,7 +417,7 @@
- //This is multi-threaded to 4 threads, spliting the image into 4 strips
+@@ -437,7 +437,7 @@
+ //The thread function, splitting the image into strips
void * Edge_Quadrant( void * id )
{
-- int num = (int)id;
-+ long int num = (long int)id;
+- int num = *((int *)id);
++ long int num = *((long int *)id);
while( true )
{
-@@ -612,7 +612,7 @@
- //=========================================================================================================//
- void * Energy_Left( void * id )
- {
-- int num = (int)id;
-+ long int num = (long int)id;
- int energy = 0;// current calculated enery
- int min_x = 0, max_x = 0;
-
-@@ -727,7 +727,7 @@
- //=========================================================================================================//
- void * Energy_Right( void * id )
- {
-- int num = (int)id;
-+ long int num = (long int)id;
- int energy = 0;// current calculated enery
- int min_x = 0, max_x = 0;
-
-@@ -938,7 +938,7 @@
- //This works like Remove_Quadrant, stripes across the image.
+@@ -744,7 +744,7 @@
+ //This works like Remove_Quadrant, strips across the image.
void * Add_Quadrant( void * id )
{
-- int num = (int)id;
-+ long int num = (long int)id;
+- int num = *((int *)id);
++ long int num = *((long int *)id);
Thread_Params add_area;
while( true )
-@@ -1245,7 +1245,7 @@
+@@ -907,7 +907,7 @@
//the areas are not quadrants, rather, more like strips, but I keep the name convention
void * Remove_Quadrant( void * id )
{
-- int num = (int)id;
-+ long int num = (long int)id;
+- int num = *((int *)id);
++ long int num = *((long int *)id);
Thread_Params remove_area;
while( true )