aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-10 04:21:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-10 04:21:03 +0000
commit0031918568445102da0a49bcddd432104cdb1734 (patch)
treeebb656e610991ebc1776ccda74c320b381d97bf2 /graphics/cairo/Makefile
parentc9a1b1ee04924ae7a0f30f9b9e41fa22093fcff6 (diff)
downloadports-0031918568445102da0a49bcddd432104cdb1734.tar.gz
ports-0031918568445102da0a49bcddd432104cdb1734.zip
Notes
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 27d89aec0957..2c6325997f2e 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cairo
-PORTVERSION= 0.1.23
+PORTVERSION= 0.2.0
CATEGORIES= graphics
MASTER_SITES= http://www.cairographics.org/snapshots/
@@ -25,9 +25,6 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CLFAGS}" \
LDFLAGS="${PTHREAD_LDFLAGS}"
-# glitz is out of sync with cairo
-CONFIGURE_ARGS= --disable-gl
-
PLIST_FILES= include/cairo-features.h \
include/cairo.h \
lib/libcairo.a \
@@ -35,4 +32,13 @@ PLIST_FILES= include/cairo-features.h \
lib/libcairo.so.1 \
libdata/pkgconfig/cairo.pc
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
+ ${WRKSRC}/src/*.*
+.endif
+
+.include <bsd.port.post.mk>
+