aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-10-19 16:02:22 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-10-19 16:02:22 +0000
commit73e672e2451432c92d4459fea5c6ff11e5de999d (patch)
tree8cf09731eb8cb5e5de0b7e746eb69c488c90234e /graphics/cairo/Makefile
parentc3afa705b2d6e87b7a9180093e1313878c7a6bef (diff)
downloadports-73e672e2451432c92d4459fea5c6ff11e5de999d.tar.gz
ports-73e672e2451432c92d4459fea5c6ff11e5de999d.zip
Notes
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 7a9eeb3730ad..ce601fe7a4b9 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cairo
PORTVERSION= 1.6.4
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH?= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -42,7 +42,8 @@ USE_XORG+= xrender
PLIST_SUB+= X11=""
.endif
-OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
+OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off \
+ XCB "Enable XCB (X C-language Binding) Support" On
.include <bsd.port.pre.mk>
@@ -55,6 +56,16 @@ CONFIGURE_ARGS+= --disable-glitz
PLIST_SUB+= GLITZ="@comment "
.endif
+.ifdef(WITH_XCB)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+CONFIGURE_ARGS+= --enable-xcb
+PLIST_SUB+= XCB=""
+.else
+CONFIGURE_ARGS+= --disable-xcb
+PLIST_SUB+= XCB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/test/Makefile.in