aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-25 22:23:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-25 22:23:32 +0000
commit97db28fb1b2913ab12a67871cbba7dde7e971a1a (patch)
tree0729a2ab905f1d361ff0136cd22d91661d321b9e /graphics/cairo
parenta48caf676af8e156daa493a4f447f36ff7fc2a82 (diff)
downloadports-97db28fb1b2913ab12a67871cbba7dde7e971a1a.tar.gz
ports-97db28fb1b2913ab12a67871cbba7dde7e971a1a.zip
Notes
Diffstat (limited to 'graphics/cairo')
-rw-r--r--graphics/cairo/Makefile2
-rw-r--r--graphics/cairo/files/patch-src_cairo-clip.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 511c425010c9..11b727629a91 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cairo
PORTVERSION= 1.8.6
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
diff --git a/graphics/cairo/files/patch-src_cairo-clip.c b/graphics/cairo/files/patch-src_cairo-clip.c
new file mode 100644
index 000000000000..43e7742aebd0
--- /dev/null
+++ b/graphics/cairo/files/patch-src_cairo-clip.c
@@ -0,0 +1,11 @@
+--- src/cairo-clip.c.orig 2009-02-25 17:18:08.000000000 -0500
++++ src/cairo-clip.c 2009-02-25 17:18:26.000000000 -0500
+@@ -423,7 +423,7 @@ _cairo_clip_intersect_mask (cairo_clip_t
+ cairo_box_t extents;
+ cairo_rectangle_int_t surface_rect, target_rect;
+ cairo_surface_t *surface = NULL;
+- cairo_status_t status;
++ cairo_status_t status = CAIRO_STATUS_SUCCESS;
+
+ if (clip->all_clipped)
+ return CAIRO_STATUS_SUCCESS;