aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairomm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /graphics/cairomm
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'graphics/cairomm')
-rw-r--r--graphics/cairomm/Makefile8
-rw-r--r--graphics/cairomm/distinfo6
-rw-r--r--graphics/cairomm/files/patch-cairomm_enums.h11
-rw-r--r--graphics/cairomm/pkg-plist62
4 files changed, 77 insertions, 10 deletions
diff --git a/graphics/cairomm/Makefile b/graphics/cairomm/Makefile
index 535bf371d198..d69e32e0544f 100644
--- a/graphics/cairomm/Makefile
+++ b/graphics/cairomm/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/cairomm/Makefile,v 1.4 2006/09/06 22:06:40 marcus Exp $
+# $MCom: ports/graphics/cairomm/Makefile,v 1.7 2008/03/21 21:48:49 kwm Exp $
#
PORTNAME= cairomm
-PORTVERSION= 1.2.4
+PORTVERSION= 1.4.8
PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -18,10 +18,10 @@ COMMENT= C++ interface to cairo
LIB_DEPENDS= xml\\+\\+-2.6:${PORTSDIR}/textproc/libxml++26 \
cairo.2:${PORTSDIR}/graphics/cairo
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget ltverhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
AUTOMAKE="${TRUE}" AUTOCONF="${TRUE}" DOXYGEN="${TRUE}"
diff --git a/graphics/cairomm/distinfo b/graphics/cairomm/distinfo
index f4bbd93b800e..1d91365fa1b5 100644
--- a/graphics/cairomm/distinfo
+++ b/graphics/cairomm/distinfo
@@ -1,3 +1,3 @@
-MD5 (cairomm-1.2.4.tar.gz) = 5d862facfbd0098c9bae618b61f7c8e6
-SHA256 (cairomm-1.2.4.tar.gz) = a137ccd4a6cde6c9e9553966534702d2e7f6f44c755dfe128d9fb26ed2697fe7
-SIZE (cairomm-1.2.4.tar.gz) = 580871
+MD5 (cairomm-1.4.8.tar.gz) = 2b2025b3555fa1665d92cf9f9be1a4d3
+SHA256 (cairomm-1.4.8.tar.gz) = 795a1c1f5aab72752cbce8d2c0502279ac999351726a5369bec737af0c834e92
+SIZE (cairomm-1.4.8.tar.gz) = 786851
diff --git a/graphics/cairomm/files/patch-cairomm_enums.h b/graphics/cairomm/files/patch-cairomm_enums.h
new file mode 100644
index 000000000000..4d0d6ed988d0
--- /dev/null
+++ b/graphics/cairomm/files/patch-cairomm_enums.h
@@ -0,0 +1,11 @@
+--- cairomm/enums.h.orig 2008-03-21 22:42:50.000000000 +0100
++++ cairomm/enums.h 2008-03-21 22:43:38.000000000 +0100
+@@ -192,7 +192,7 @@ typedef enum
+ FONT_TYPE_TOY = CAIRO_FONT_TYPE_TOY,
+ FONT_TYPE_FT = CAIRO_FONT_TYPE_FT,
+ FONT_TYPE_WIN32 = CAIRO_FONT_TYPE_WIN32,
+- FONT_TYPE_ATSUI = CAIRO_FONT_TYPE_ATSUI
++ FONT_TYPE_QUARTZ = CAIRO_FONT_TYPE_QUARTZ
+ } FontType;
+
+ } // namespace Cairo
diff --git a/graphics/cairomm/pkg-plist b/graphics/cairomm/pkg-plist
index eadc7382880c..37c9b105cf3e 100644
--- a/graphics/cairomm/pkg-plist
+++ b/graphics/cairomm/pkg-plist
@@ -1,4 +1,5 @@
include/cairomm-1.0/cairomm/cairomm.h
+include/cairomm-1.0/cairomm/cairommconfig.h
include/cairomm-1.0/cairomm/context.h
include/cairomm-1.0/cairomm/enums.h
include/cairomm-1.0/cairomm/exception.h
@@ -6,6 +7,7 @@ include/cairomm-1.0/cairomm/fontface.h
include/cairomm-1.0/cairomm/fontoptions.h
include/cairomm-1.0/cairomm/path.h
include/cairomm-1.0/cairomm/pattern.h
+include/cairomm-1.0/cairomm/quartz_surface.h
include/cairomm-1.0/cairomm/refptr.h
include/cairomm-1.0/cairomm/scaledfont.h
include/cairomm-1.0/cairomm/surface.h
@@ -20,6 +22,8 @@ share/doc/libcairomm-1.0/reference/html/annotated.html
share/doc/libcairomm-1.0/reference/html/cairomm.css
share/doc/libcairomm-1.0/reference/html/cairomm_8h-source.html
share/doc/libcairomm-1.0/reference/html/cairomm_8h.html
+share/doc/libcairomm-1.0/reference/html/cairommconfig_8h-source.html
+share/doc/libcairomm-1.0/reference/html/cairommconfig_8h.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1Context-members.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1Context.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1FontFace-members.html
@@ -63,6 +67,11 @@ share/doc/libcairomm-1.0/reference/html/classCairo_1_1PsSurface.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1PsSurface__inherit__graph.map
share/doc/libcairomm-1.0/reference/html/classCairo_1_1PsSurface__inherit__graph.md5
share/doc/libcairomm-1.0/reference/html/classCairo_1_1PsSurface__inherit__graph.png
+share/doc/libcairomm-1.0/reference/html/classCairo_1_1QuartzSurface-members.html
+share/doc/libcairomm-1.0/reference/html/classCairo_1_1QuartzSurface.html
+share/doc/libcairomm-1.0/reference/html/classCairo_1_1QuartzSurface__inherit__graph.map
+share/doc/libcairomm-1.0/reference/html/classCairo_1_1QuartzSurface__inherit__graph.md5
+share/doc/libcairomm-1.0/reference/html/classCairo_1_1QuartzSurface__inherit__graph.png
share/doc/libcairomm-1.0/reference/html/classCairo_1_1RadialGradient-members.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1RadialGradient.html
share/doc/libcairomm-1.0/reference/html/classCairo_1_1RadialGradient__inherit__graph.map
@@ -128,13 +137,53 @@ share/doc/libcairomm-1.0/reference/html/fontface_8h.html
share/doc/libcairomm-1.0/reference/html/fontoptions_8h-source.html
share/doc/libcairomm-1.0/reference/html/fontoptions_8h.html
share/doc/libcairomm-1.0/reference/html/functions.html
+share/doc/libcairomm-1.0/reference/html/functions_0x62.html
+share/doc/libcairomm-1.0/reference/html/functions_0x63.html
+share/doc/libcairomm-1.0/reference/html/functions_0x64.html
+share/doc/libcairomm-1.0/reference/html/functions_0x65.html
+share/doc/libcairomm-1.0/reference/html/functions_0x66.html
+share/doc/libcairomm-1.0/reference/html/functions_0x67.html
+share/doc/libcairomm-1.0/reference/html/functions_0x68.html
+share/doc/libcairomm-1.0/reference/html/functions_0x69.html
+share/doc/libcairomm-1.0/reference/html/functions_0x6c.html
+share/doc/libcairomm-1.0/reference/html/functions_0x6d.html
+share/doc/libcairomm-1.0/reference/html/functions_0x6f.html
+share/doc/libcairomm-1.0/reference/html/functions_0x70.html
+share/doc/libcairomm-1.0/reference/html/functions_0x71.html
+share/doc/libcairomm-1.0/reference/html/functions_0x72.html
+share/doc/libcairomm-1.0/reference/html/functions_0x73.html
+share/doc/libcairomm-1.0/reference/html/functions_0x74.html
+share/doc/libcairomm-1.0/reference/html/functions_0x75.html
+share/doc/libcairomm-1.0/reference/html/functions_0x76.html
+share/doc/libcairomm-1.0/reference/html/functions_0x77.html
+share/doc/libcairomm-1.0/reference/html/functions_0x78.html
+share/doc/libcairomm-1.0/reference/html/functions_0x7e.html
share/doc/libcairomm-1.0/reference/html/functions_func.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x62.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x63.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x64.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x65.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x66.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x67.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x68.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x69.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x6c.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x6d.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x6f.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x70.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x71.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x72.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x73.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x74.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x75.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x76.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x77.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x78.html
+share/doc/libcairomm-1.0/reference/html/functions_func_0x7e.html
share/doc/libcairomm-1.0/reference/html/functions_type.html
share/doc/libcairomm-1.0/reference/html/functions_vars.html
share/doc/libcairomm-1.0/reference/html/globals.html
-share/doc/libcairomm-1.0/reference/html/globals_enum.html
-share/doc/libcairomm-1.0/reference/html/globals_eval.html
-share/doc/libcairomm-1.0/reference/html/globals_type.html
+share/doc/libcairomm-1.0/reference/html/globals_defs.html
share/doc/libcairomm-1.0/reference/html/graph_legend.dot
share/doc/libcairomm-1.0/reference/html/graph_legend.html
share/doc/libcairomm-1.0/reference/html/graph_legend.png
@@ -167,6 +216,9 @@ share/doc/libcairomm-1.0/reference/html/inherit__graph__7.png
share/doc/libcairomm-1.0/reference/html/inherit__graph__8.map
share/doc/libcairomm-1.0/reference/html/inherit__graph__8.md5
share/doc/libcairomm-1.0/reference/html/inherit__graph__8.png
+share/doc/libcairomm-1.0/reference/html/inherit__graph__9.map
+share/doc/libcairomm-1.0/reference/html/inherit__graph__9.md5
+share/doc/libcairomm-1.0/reference/html/inherit__graph__9.png
share/doc/libcairomm-1.0/reference/html/inherits.html
share/doc/libcairomm-1.0/reference/html/namespaceCairo.html
share/doc/libcairomm-1.0/reference/html/namespacemembers.html
@@ -179,10 +231,14 @@ share/doc/libcairomm-1.0/reference/html/path_8h-source.html
share/doc/libcairomm-1.0/reference/html/path_8h.html
share/doc/libcairomm-1.0/reference/html/pattern_8h-source.html
share/doc/libcairomm-1.0/reference/html/pattern_8h.html
+share/doc/libcairomm-1.0/reference/html/quartz__surface_8h-source.html
+share/doc/libcairomm-1.0/reference/html/quartz__surface_8h.html
share/doc/libcairomm-1.0/reference/html/refptr_8h-source.html
share/doc/libcairomm-1.0/reference/html/refptr_8h.html
share/doc/libcairomm-1.0/reference/html/scaledfont_8h-source.html
share/doc/libcairomm-1.0/reference/html/scaledfont_8h.html
+share/doc/libcairomm-1.0/reference/html/structCairo_1_1ColorStop-members.html
+share/doc/libcairomm-1.0/reference/html/structCairo_1_1ColorStop.html
share/doc/libcairomm-1.0/reference/html/surface_8h-source.html
share/doc/libcairomm-1.0/reference/html/surface_8h.html
share/doc/libcairomm-1.0/reference/html/tabs.css