aboutsummaryrefslogtreecommitdiff
path: root/graphics/cal3d-devel
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-13 03:02:22 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-13 03:02:22 +0000
commit9b7b267cf9a68d0fefa7575bc6dfcf87bb7ffef0 (patch)
tree10432d61efee436b3c0e465b6fc873cef1419cdc /graphics/cal3d-devel
parentdbdbfba7c76ee09dc823dffc134367400d70f771 (diff)
downloadports-9b7b267cf9a68d0fefa7575bc6dfcf87bb7ffef0.tar.gz
ports-9b7b267cf9a68d0fefa7575bc6dfcf87bb7ffef0.zip
Notes
Diffstat (limited to 'graphics/cal3d-devel')
-rw-r--r--graphics/cal3d-devel/Makefile30
-rw-r--r--graphics/cal3d-devel/distinfo5
-rw-r--r--graphics/cal3d-devel/files/patch-src_cal3d_buffersource.h2
-rw-r--r--graphics/cal3d-devel/files/patch-src_cal3d_loader.h2
-rw-r--r--graphics/cal3d-devel/files/patch-src_cal3d_streamsource.h2
-rw-r--r--graphics/cal3d-devel/pkg-plist6
6 files changed, 29 insertions, 18 deletions
diff --git a/graphics/cal3d-devel/Makefile b/graphics/cal3d-devel/Makefile
index 970af8772517..e203abf65215 100644
--- a/graphics/cal3d-devel/Makefile
+++ b/graphics/cal3d-devel/Makefile
@@ -6,29 +6,39 @@
#
PORTNAME= cal3d
-PORTVERSION= 0.10.0
+DISTVERSION= ${CAL3DVER}_pre20050823
CATEGORIES= graphics devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}-full-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-${DISTVERSION}
-MAINTAINER= sw@gegenunendlich.de
-COMMENT= Skeletal based 3d character animation library written in C++
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Skeletal based 3d character animation library written in C++ (devel)
+
+CAL3DVER= 0.11.0
+
+CONFLICTS= cal3d-[0-9]*
USE_BZIP2= yes
USE_GNOME= pkgconfig
+USE_GCC= 3.2+
USE_AUTOMAKE_VER= 19
AUTOMAKE_ARGS= "--add-missing"
USE_AUTOHEADER_VER= 259
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS+= --disable-static
-
-.include <bsd.port.pre.mk>
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-static
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CXX}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
pre-configure:
cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal
cd ${WRKSRC} && ${AUTOHEADER}
cd ${WRKSRC} && ${LIBTOOLIZE} --automake --force
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/cal3d-devel/distinfo b/graphics/cal3d-devel/distinfo
index a286b37a92c9..65971b34f4e1 100644
--- a/graphics/cal3d-devel/distinfo
+++ b/graphics/cal3d-devel/distinfo
@@ -1,2 +1,3 @@
-MD5 (cal3d-full-0.10.0.tar.bz2) = 47b3b72c6adcf5351f0884639d606d05
-SIZE (cal3d-full-0.10.0.tar.bz2) = 2995348
+MD5 (cal3d-0.11.0_pre20050823.tar.bz2) = da196ac6a41e34c2166cf894f7085bf0
+SHA256 (cal3d-0.11.0_pre20050823.tar.bz2) = 05c48360149be601e851b909bbbd80da0abfe77fc7828b262b80c08494844041
+SIZE (cal3d-0.11.0_pre20050823.tar.bz2) = 8138576
diff --git a/graphics/cal3d-devel/files/patch-src_cal3d_buffersource.h b/graphics/cal3d-devel/files/patch-src_cal3d_buffersource.h
index 6cc393fdf3ed..08caf95b630a 100644
--- a/graphics/cal3d-devel/files/patch-src_cal3d_buffersource.h
+++ b/graphics/cal3d-devel/files/patch-src_cal3d_buffersource.h
@@ -5,7 +5,7 @@
#include "cal3d/global.h"
#include "cal3d/datasource.h"
-#include <istream>
-+#include <istream.h>
++#include <iostream>
/**
* CalBufferSource class.
diff --git a/graphics/cal3d-devel/files/patch-src_cal3d_loader.h b/graphics/cal3d-devel/files/patch-src_cal3d_loader.h
index 8121123c1431..4d27c42155b4 100644
--- a/graphics/cal3d-devel/files/patch-src_cal3d_loader.h
+++ b/graphics/cal3d-devel/files/patch-src_cal3d_loader.h
@@ -5,7 +5,7 @@
#include <string>
-#include <istream>
-+#include <istream.h>
++#include <iostream>
#include "cal3d/global.h"
#include "cal3d/datasource.h"
diff --git a/graphics/cal3d-devel/files/patch-src_cal3d_streamsource.h b/graphics/cal3d-devel/files/patch-src_cal3d_streamsource.h
index b2125b55736f..25f82c923133 100644
--- a/graphics/cal3d-devel/files/patch-src_cal3d_streamsource.h
+++ b/graphics/cal3d-devel/files/patch-src_cal3d_streamsource.h
@@ -5,7 +5,7 @@
#include "cal3d/global.h"
#include "cal3d/datasource.h"
-#include <istream>
-+#include <istream.h>
++#include <iostream>
/**
* CalStreamSource class.
diff --git a/graphics/cal3d-devel/pkg-plist b/graphics/cal3d-devel/pkg-plist
index 079d377287ae..5138ae9d9ab6 100644
--- a/graphics/cal3d-devel/pkg-plist
+++ b/graphics/cal3d-devel/pkg-plist
@@ -8,7 +8,6 @@ include/cal3d/cal3d.h
include/cal3d/cal3d_wrapper.h
include/cal3d/coreanimation.h
include/cal3d/corebone.h
-include/cal3d/corekeyframe.h
include/cal3d/corematerial.h
include/cal3d/coremesh.h
include/cal3d/coremodel.h
@@ -16,7 +15,6 @@ include/cal3d/coremorphanimation.h
include/cal3d/coreskeleton.h
include/cal3d/coresubmesh.h
include/cal3d/coresubmorphtarget.h
-include/cal3d/coretrack.h
include/cal3d/datasource.h
include/cal3d/error.h
include/cal3d/global.h
@@ -30,6 +28,8 @@ include/cal3d/morphtargetmixer.h
include/cal3d/physique.h
include/cal3d/platform.h
include/cal3d/quaternion.h
+include/cal3d/refcounted.h
+include/cal3d/refptr.h
include/cal3d/renderer.h
include/cal3d/resource.h
include/cal3d/saver.h
@@ -37,8 +37,8 @@ include/cal3d/skeleton.h
include/cal3d/springsystem.h
include/cal3d/streamsource.h
include/cal3d/submesh.h
-include/cal3d/tinystr.h
include/cal3d/tinyxml.h
+include/cal3d/transform.h
include/cal3d/vector.h
@dirrm include/cal3d
lib/libcal3d.so