aboutsummaryrefslogtreecommitdiff
path: root/graphics/cal3d/files
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-13 08:33:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-13 08:33:57 +0000
commite2ca6bea49eef37b38c7d98b702dd449492b4b8e (patch)
tree2f117f6da1ebdb7dc6b8cfdccf8fa7a8fcfa5212 /graphics/cal3d/files
parent08f99179049da9f52c9b96d09f3b0a0e62551a43 (diff)
Notes
Diffstat (limited to 'graphics/cal3d/files')
-rw-r--r--graphics/cal3d/files/patch-Makefile.am12
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_Makefile.am12
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_buffersource.h11
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_loader.h11
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_streamsource.h11
5 files changed, 57 insertions, 0 deletions
diff --git a/graphics/cal3d/files/patch-Makefile.am b/graphics/cal3d/files/patch-Makefile.am
new file mode 100644
index 000000000000..a018a42f5cd7
--- /dev/null
+++ b/graphics/cal3d/files/patch-Makefile.am
@@ -0,0 +1,12 @@
+--- Makefile.am.orig Mon Jul 12 19:40:09 2004
++++ Makefile.am Mon Jul 12 19:41:07 2004
+@@ -16,7 +16,8 @@
+
+ SUBDIRS = src docs
+
+-pkgconfigdir = $(libdir)/pkgconfig
++#pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = cal3d.pc
+
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_Makefile.am b/graphics/cal3d/files/patch-src_cal3d_Makefile.am
new file mode 100644
index 000000000000..af0cd89babb1
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_Makefile.am
@@ -0,0 +1,12 @@
+--- src/cal3d/Makefile.am.orig Mon Jul 12 17:34:29 2004
++++ src/cal3d/Makefile.am Mon Jul 12 17:35:04 2004
+@@ -13,7 +13,8 @@
+ INCLUDES = $(all_includes) -I$(top_srcdir)/src
+
+ all_libraries = @all_libraries@
+-LDFLAGS = @LDFLAGS@
++#LDFLAGS = @LDFLAGS@
++AM_LDFLAGS = @AM_LDFLAGS@
+
+ EXTRA_DIST = cal3d.rc cal3d.dsp SConscript
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_buffersource.h b/graphics/cal3d/files/patch-src_cal3d_buffersource.h
new file mode 100644
index 000000000000..6cc393fdf3ed
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_buffersource.h
@@ -0,0 +1,11 @@
+--- src/cal3d/buffersource.h.orig Tue Jul 13 10:03:53 2004
++++ src/cal3d/buffersource.h Tue Jul 13 10:04:11 2004
+@@ -17,7 +17,7 @@
+
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+-#include <istream>
++#include <istream.h>
+
+ /**
+ * CalBufferSource class.
diff --git a/graphics/cal3d/files/patch-src_cal3d_loader.h b/graphics/cal3d/files/patch-src_cal3d_loader.h
new file mode 100644
index 000000000000..8121123c1431
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_loader.h
@@ -0,0 +1,11 @@
+--- src/cal3d/loader.h.orig Tue Jul 13 10:04:57 2004
++++ src/cal3d/loader.h Tue Jul 13 10:05:09 2004
+@@ -17,7 +17,7 @@
+
+
+ #include <string>
+-#include <istream>
++#include <istream.h>
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_streamsource.h b/graphics/cal3d/files/patch-src_cal3d_streamsource.h
new file mode 100644
index 000000000000..b2125b55736f
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_streamsource.h
@@ -0,0 +1,11 @@
+--- src/cal3d/streamsource.h.orig Tue Jul 13 10:05:35 2004
++++ src/cal3d/streamsource.h Tue Jul 13 10:05:47 2004
+@@ -17,7 +17,7 @@
+
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+-#include <istream>
++#include <istream.h>
+
+ /**
+ * CalStreamSource class.