aboutsummaryrefslogtreecommitdiff
path: root/graphics/camediaplay/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-25 06:30:33 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-25 06:30:33 +0000
commit3387f20d268572c6c9d62fae07e0e97692795aac (patch)
tree402cb76c8269c409b7dbe8282339c0da5285755f /graphics/camediaplay/Makefile
parent9c2c94df0dcfcf7089dd7f4561f66a3c796e670b (diff)
downloadports-3387f20d268572c6c9d62fae07e0e97692795aac.tar.gz
ports-3387f20d268572c6c9d62fae07e0e97692795aac.zip
Notes
Diffstat (limited to 'graphics/camediaplay/Makefile')
-rw-r--r--graphics/camediaplay/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/graphics/camediaplay/Makefile b/graphics/camediaplay/Makefile
index c9bd8f0694ed..0e86fb9e511f 100644
--- a/graphics/camediaplay/Makefile
+++ b/graphics/camediaplay/Makefile
@@ -7,24 +7,28 @@
PORTNAME= camediaplay
PORTVERSION= 20010211
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.itojun.org/pub/digi-cam/C-400L/unix/ \
+MASTER_SITES= ftp://ftp.itojun.org/pub/digi-cam/C-400L/unix/ \
ftp://ftp.digipri.co.jp/pub/free-software/Olympus/C-400L/unix/
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/camediaplay/build
-HAS_CONFIGURE= yes
-MAN1= camediaplay.1
+WRKSRC= ${WRKDIR}/${PORTNAME}/build
-DOC= README.english README.japanese PROTOCOL
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= OPTFLAG=""
+MAN1= camediaplay.1
+
+post-patch:
+ @${PERL} -pi -e "s|<sys/dir.h>|<dirent.h>|g" ${WRKSRC}/../src/*.c
post-install:
- ${MKDIR} ${PREFIX}/share/doc/camediaplay
- for i in ${DOC}; do \
- ${INSTALL_DATA} ${WRKSRC}/../$$i \
- ${PREFIX}/share/doc/camediaplay; \
- done
- ${SED} -e 's@\/usr\/local@${PREFIX}@' < ${PKGMESSAGE}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/camediaplay
+.for file in PROTOCOL README.english README.japanese
+ ${INSTALL_DATA} ${WRKSRC}/../${file} ${PREFIX}/share/doc/camediaplay
+.endfor
+.endif
.include <bsd.port.mk>