aboutsummaryrefslogtreecommitdiff
path: root/graphics/camera/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-08 02:33:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-08 02:33:18 +0000
commit432cef3aa3027798fe3d9dbeb0ef644bc66d9c4a (patch)
tree9bdc5e8845d349f3eecbc732d596bd62dd79ebda /graphics/camera/Makefile
parent4248570691f7b4006d53e400da78a0554c2b7c70 (diff)
downloadports-432cef3aa3027798fe3d9dbeb0ef644bc66d9c4a.tar.gz
ports-432cef3aa3027798fe3d9dbeb0ef644bc66d9c4a.zip
Notes
Diffstat (limited to 'graphics/camera/Makefile')
-rw-r--r--graphics/camera/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/camera/Makefile b/graphics/camera/Makefile
index 7f576349bfd4..fc750c7dc399 100644
--- a/graphics/camera/Makefile
+++ b/graphics/camera/Makefile
@@ -3,20 +3,21 @@
PORTNAME= camera
PORTVERSION= 0.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics gnustep
MASTER_SITES= http://download.gna.org/gsimageapps/ \
- ${MASTER_SITE_GNUSTEP_CH}
+ GNUSTEP_CH
DISTNAME= Camera-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNUstep application for digital still cameras
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/Documentation/COPYING
LIB_DEPENDS= libgphoto2_port.so:${PORTSDIR}/graphics/libgphoto2
-USES= tar:bzip2
+USES= tar:bzip2
USE_GNUSTEP= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
@@ -28,4 +29,7 @@ post-patch:
${REINPLACE_CMD} 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Camera.app/Camera
+
.include <bsd.port.mk>