aboutsummaryrefslogtreecommitdiff
path: root/graphics/cegui/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:30:09 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:30:09 +0000
commit57d3e544f480a10c5c9f7e3faa70fd8b62e61a36 (patch)
tree74fd13e368215fa139eea53dd69d7a493ad44ee2 /graphics/cegui/Makefile
parentc0074c48ed5582adb12a836a43029d44a4148aeb (diff)
Notes
Diffstat (limited to 'graphics/cegui/Makefile')
-rw-r--r--graphics/cegui/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
new file mode 100644
index 000000000000..984ab9073f9d
--- /dev/null
+++ b/graphics/cegui/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: cegui
+# Date created: 03 Oct 2005
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cegui
+PORTVERSION= 0.4.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=crayzedsgui
+DISTNAME= ${PORTNAME}_mk2-${PORTVERSION}
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A library providing windowing and widgets for graphics APIs
+
+LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_mk2
+USE_REINPLACE= YES
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= YES
+INSTALLS_SHLIB= YES
+USE_GCC= 3.4
+USE_BZIP2= YES
+USE_X_PREFIX= YES
+USE_GNOME= gnomehack
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|"-lxerces-c.*"|"-L${LOCALBASE}/lib -lxerces-c ${PTHREAD_LIBS} $$LIBS"|g; \
+ s|"-lILU.*"|"-lm -L${LOCALBASE}/lib -lILU -lIL $$LIBS"|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|DevIL_CFLAGS=.*|DevIL_CFLAGS="-DUSE_DEVIL_LIBRARY -I${LOCALBASE}/include"|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| Samples$$||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/include/CEGUIDataContainer.h
+ @${REINPLACE_CMD} -e 's|__linux__)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/include/CEGUIFactoryModule.h \
+ ${WRKSRC}/src/CEGUIFactoryModule.cpp
+ @${REINPLACE_CMD} -e 's|(linux)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/Samples/common/src/CEGuiSample.cpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README COPYING AUTHORS ChangeLog TODO
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>