aboutsummaryrefslogtreecommitdiff
path: root/graphics/cegui
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-28 13:46:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-28 13:46:02 +0000
commite0057d4bcdacd21d7bd9bcf54560a29bfe8c3be7 (patch)
tree945546bb011c880f20fa4f5484d5440c1871333f /graphics/cegui
parentf14001c2bea2c308a4d110bdaa64626b0ab52925 (diff)
downloadports-e0057d4bcdacd21d7bd9bcf54560a29bfe8c3be7.tar.gz
ports-e0057d4bcdacd21d7bd9bcf54560a29bfe8c3be7.zip
Notes
Diffstat (limited to 'graphics/cegui')
-rw-r--r--graphics/cegui/Makefile7
-rw-r--r--graphics/cegui/pkg-plist50
2 files changed, 34 insertions, 23 deletions
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 761ecdff10af..9c9c0dd01e98 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cegui
PORTVERSION= 0.7.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics devel
MASTER_SITES= SF/crayzedsgui/CEGUI%20Mk-2/0.7.5
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
@@ -24,7 +24,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.7.4:${PORTSDIR}/graphics/ogre3d
WRKSRC= ${WRKDIR}/${DISTNAME:S/2b/2/}
CONFIGURE_ARGS= --disable-toluacegui --disable-irrlicht-renderer \
--disable-corona --enable-devil --disable-freeimage --disable-silly \
- --disable-libxml --disable-xerces-c --disable-expat --disable-samples
+ --disable-libxml --disable-xerces-c --disable-expat --disable-samples \
+ --enable-null-renderer
CONFIGURE_ENV+= Lua_LIBS="-L${LUA_LIBDIR} -llua -lm" \
Lua_CFLAGS="-I${LUA_INCDIR}"
@@ -49,7 +50,7 @@ post-patch:
s|-lpthread|${PTHREAD_LIBS}|g; \
s|CEGUI_LUA_VER=..|CEGUI_LUA_VER=${USE_LUA:S/.//}|g; \
s|DevIL_CFLAGS=.*|DevIL_CFLAGS="-DUSE_DEVIL_LIBRARY -I${LOCALBASE}/include"|g; \
- s|-release $$cegui_lib_version_suffix|-release ${PORTVERSION:C/\.[0-9]$//g} -version-number ${PORTVERSION:C/^[0-9]\.[0-9]\.//g}|g' \
+ s|-release $$cegui_lib_version_suffix|& -version-number 0|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^SUBDIRS = tolua\+\+|SUBDIRS =|g' \
${WRKSRC}/cegui/include/ScriptingModules/LuaScriptModule/support/Makefile.in
diff --git a/graphics/cegui/pkg-plist b/graphics/cegui/pkg-plist
index 875dcb1f90eb..d16e82b7bd17 100644
--- a/graphics/cegui/pkg-plist
+++ b/graphics/cegui/pkg-plist
@@ -124,6 +124,11 @@ include/CEGUI/ImageCodecModules/STBImageCodec/CEGUISTBImageCodec.h
include/CEGUI/ImageCodecModules/STBImageCodec/CEGUISTBImageCodecModule.h
include/CEGUI/ImageCodecModules/TGAImageCodec/CEGUITGAImageCodec.h
include/CEGUI/ImageCodecModules/TGAImageCodec/CEGUITGAImageCodecModule.h
+include/CEGUI/RendererModules/Null/CEGUINullGeometryBuffer.h
+include/CEGUI/RendererModules/Null/CEGUINullRenderTarget.h
+include/CEGUI/RendererModules/Null/CEGUINullRenderer.h
+include/CEGUI/RendererModules/Null/CEGUINullTexture.h
+include/CEGUI/RendererModules/Null/CEGUINullTextureTarget.h
%%WITH_OGRE%%include/CEGUI/RendererModules/Ogre/CEGUIOgreGeometryBuffer.h
%%WITH_OGRE%%include/CEGUI/RendererModules/Ogre/CEGUIOgreImageCodec.h
%%WITH_OGRE%%include/CEGUI/RendererModules/Ogre/CEGUIOgreRenderTarget.h
@@ -280,44 +285,48 @@ include/CEGUI/falagard/CEGUIFalWidgetComponent.h
include/CEGUI/falagard/CEGUIFalWidgetLookFeel.h
include/CEGUI/falagard/CEGUIFalWidgetLookManager.h
include/CEGUI/falagard/CEGUIFalXMLEnumHelper.h
-lib/libCEGUIBase-0.7.so.5
-lib/libCEGUIBase-0.7.so
+lib/libCEGUIBase-0.7.5.so.0
+lib/libCEGUIBase-0.7.5.so
lib/libCEGUIBase.la
lib/libCEGUIBase.so
-lib/libCEGUIDevILImageCodec-0.7.so.5
-lib/libCEGUIDevILImageCodec-0.7.so
+lib/libCEGUIDevILImageCodec-0.7.5.so.0
+lib/libCEGUIDevILImageCodec-0.7.5.so
lib/libCEGUIDevILImageCodec.la
lib/libCEGUIDevILImageCodec.so
-lib/libCEGUIFalagardWRBase-0.7.so.5
-lib/libCEGUIFalagardWRBase-0.7.so
+lib/libCEGUIFalagardWRBase-0.7.5.so.0
+lib/libCEGUIFalagardWRBase-0.7.5.so
lib/libCEGUIFalagardWRBase.la
lib/libCEGUIFalagardWRBase.so
-lib/libCEGUILuaScriptModule-0.7.so.5
-lib/libCEGUILuaScriptModule-0.7.so
+lib/libCEGUILuaScriptModule-0.7.5.so.0
+lib/libCEGUILuaScriptModule-0.7.5.so
lib/libCEGUILuaScriptModule.la
lib/libCEGUILuaScriptModule.so
-%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.so.5
-%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.so
+lib/libCEGUINullRenderer-0.7.5.so.0
+lib/libCEGUINullRenderer-0.7.5.so
+lib/libCEGUINullRenderer.la
+lib/libCEGUINullRenderer.so
+%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.5.so.0
+%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.5.so
%%WITH_OGRE%%lib/libCEGUIOgreRenderer.la
%%WITH_OGRE%%lib/libCEGUIOgreRenderer.so
-lib/libCEGUIOpenGLRenderer-0.7.so.5
-lib/libCEGUIOpenGLRenderer-0.7.so
+lib/libCEGUIOpenGLRenderer-0.7.5.so.0
+lib/libCEGUIOpenGLRenderer-0.7.5.so
lib/libCEGUIOpenGLRenderer.la
lib/libCEGUIOpenGLRenderer.so
-lib/libCEGUISTBImageCodec-0.7.so.5
-lib/libCEGUISTBImageCodec-0.7.so
+lib/libCEGUISTBImageCodec-0.7.5.so.0
+lib/libCEGUISTBImageCodec-0.7.5.so
lib/libCEGUISTBImageCodec.la
lib/libCEGUISTBImageCodec.so
-lib/libCEGUITGAImageCodec-0.7.so.5
-lib/libCEGUITGAImageCodec-0.7.so
+lib/libCEGUITGAImageCodec-0.7.5.so.0
+lib/libCEGUITGAImageCodec-0.7.5.so
lib/libCEGUITGAImageCodec.la
lib/libCEGUITGAImageCodec.so
-lib/libCEGUITinyXMLParser-0.7.so.5
-lib/libCEGUITinyXMLParser-0.7.so
+lib/libCEGUITinyXMLParser-0.7.5.so.0
+lib/libCEGUITinyXMLParser-0.7.5.so
lib/libCEGUITinyXMLParser.la
lib/libCEGUITinyXMLParser.so
-@comment lib/libCEGUItoluapp-0.7.so.5
-@comment lib/libCEGUItoluapp-0.7.so
+@comment lib/libCEGUItoluapp-0.7.5.so.0
+@comment lib/libCEGUItoluapp-0.7.5.so
@comment lib/libCEGUItoluapp.la
@comment lib/libCEGUItoluapp.so
%%WITH_OGRE%%libdata/pkgconfig/CEGUI-OGRE.pc
@@ -389,6 +398,7 @@ share/CEGUI/xml_schemas/Imageset.xsd
@dirrm include/CEGUI/ImageCodecModules
%%WITH_OGRE%%@dirrm include/CEGUI/RendererModules/Ogre
@dirrm include/CEGUI/RendererModules/OpenGL
+@dirrm include/CEGUI/RendererModules/Null
@dirrm include/CEGUI/RendererModules
@comment @dirrm include/CEGUI/ScriptingModules/LuaScriptModule/support/tolua++
@dirrm include/CEGUI/ScriptingModules/LuaScriptModule/support