aboutsummaryrefslogtreecommitdiff
path: root/graphics/cenon/Makefile
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2017-08-21 13:26:28 +0000
committerDavid Chisnall <theraven@FreeBSD.org>2017-08-21 13:26:28 +0000
commit31e0b9f12cc7c944cfa44082f5ff6c94615f8d68 (patch)
tree1818a753b93ff1ef78365147f674b9e83bcf0048 /graphics/cenon/Makefile
parented4f9411de6026a3b60201af8fab0ba50db224cb (diff)
Notes
Diffstat (limited to 'graphics/cenon/Makefile')
-rw-r--r--graphics/cenon/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/graphics/cenon/Makefile b/graphics/cenon/Makefile
index a4a96f136be3..c0027134db23 100644
--- a/graphics/cenon/Makefile
+++ b/graphics/cenon/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cenon
-PORTVERSION= 4.0.2
-PORTREVISION= 3
+PORTVERSION= 4.0.3
CATEGORIES= graphics gnustep
MASTER_SITES= http://www.cenon.zone/download/source/
DISTNAME= Cenon-${MAINVERSION}
@@ -15,16 +14,20 @@ MAINTAINER= theraven@FreeBSD.org
COMMENT= Vector graphics tool for GNUstep
USES= tar:bzip2 gnustep
-USE_GNUSTEP= back build
+USE_GNUSTEP= gui base build
WRKSRC= ${WRKDIR}/Cenon
-MAINVERSION= 4.0.2
+MAINVERSION= 4.0.5
FULLVERSION= 4.0.0
CENON_LIB_DIR= ${GNUSTEP_SYSTEM_ROOT}/Library/Cenon
OPTIONS_DEFINE= FULL_LIBRARY
FULL_LIBRARY_DESC= Install complete Cenon Library
+# Work around the fact that GNUstep doesn't define a constant for a higher
+# version of AppKit that it supports.
+OBJCFLAGS+=-DNSAppKitVersionNumber10_8=1200
+
.include <bsd.port.options.mk>
DISTFILES+= CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX}
@@ -39,4 +42,8 @@ pre-install:
-C ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Library/ \
--exclude COPYING --exclude '._*'
+post-stage:
+ ${RM} ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Library/README
+ ${RM} ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Library/._README
+
.include <bsd.port.mk>