aboutsummaryrefslogtreecommitdiff
path: root/graphics/cenon/Makefile
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2015-09-19 10:33:34 +0000
committerDavid Chisnall <theraven@FreeBSD.org>2015-09-19 10:33:34 +0000
commit9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a (patch)
treeda5a3eeed8b9041e9805decaee1098282defef37 /graphics/cenon/Makefile
parent1ab0fd4963caeb7cec81a713c3a3af71edef6fec (diff)
downloadports-9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a.tar.gz
ports-9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a.zip
Notes
Diffstat (limited to 'graphics/cenon/Makefile')
-rw-r--r--graphics/cenon/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/cenon/Makefile b/graphics/cenon/Makefile
index 8f8f2dee8c30..c00b5f0222c1 100644
--- a/graphics/cenon/Makefile
+++ b/graphics/cenon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cenon
PORTVERSION= 4.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics gnustep
MASTER_SITES= http://www.vhf-group.com/vhf-interservice/download/source/
DISTNAME= Cenon-${MAINVERSION}
@@ -20,7 +20,7 @@ USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/Cenon
MAINVERSION= 4.0.2
FULLVERSION= 4.0.0
-CENON_LIB_DIR= ${GNUSTEP_LOCAL_ROOT}/Library/Cenon
+CENON_LIB_DIR= ${GNUSTEP_SYSTEM_ROOT}/Library/Cenon
OPTIONS_DEFINE= FULL_LIBRARY
FULL_LIBRARY_DESC= Install complete Cenon Library
@@ -29,10 +29,14 @@ FULL_LIBRARY_DESC= Install complete Cenon Library
DISTFILES+= CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX}
+post-patch:
+ ${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DOMAIN|#GNUSTEP_INSTALLATION_DOMAIN|' \
+ ${WRKSRC}/GNUmakefile
+
pre-install:
- ${MKDIR} ${STAGEDIR}${GNUSTEP_LOCAL_ROOT}/Library/
+ ${MKDIR} ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Library/
${TAR} -xyvf ${_DISTDIR}/CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX} \
- -C ${STAGEDIR}${GNUSTEP_LOCAL_ROOT}/Library/ \
+ -C ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Library/ \
--exclude COPYING --exclude '._*'
.include <bsd.port.mk>