aboutsummaryrefslogtreecommitdiff
path: root/graphics/cenon
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-15 17:03:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-15 17:03:36 +0000
commit667aa6fda7bdb88a38efe341ef2e81efc4262117 (patch)
tree08a8d84c9540a9ee0ee97a47cfe2407df63fc096 /graphics/cenon
parent30e01587818d1b1eb6b75bfbd168673ff6de00b6 (diff)
downloadports-667aa6fda7bdb88a38efe341ef2e81efc4262117.tar.gz
ports-667aa6fda7bdb88a38efe341ef2e81efc4262117.zip
Notes
Diffstat (limited to 'graphics/cenon')
-rw-r--r--graphics/cenon/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/cenon/Makefile b/graphics/cenon/Makefile
index 0f58de812ab4..3e175304a338 100644
--- a/graphics/cenon/Makefile
+++ b/graphics/cenon/Makefile
@@ -28,11 +28,12 @@ MAINVERSION= 3.9.5
FULLVERSION= 3.9.4
CENON_LIB_DIR= ${GNUSTEP_LOCAL_ROOT}/Library/Cenon
-OPTIONS= FULL_LIBRARY "Install complete Cenon Library" off
+OPTIONS_DEFINE= FULL_LIBRARY
+FULL_LIBRARY_DESC= Install complete Cenon Library
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FULL_LIBRARY) || make(makesum) || defined(FETCH_ALL)
+.if ${PORT_OPTIONS:MFULL_LIBRARY} || make(makesum) || defined(FETCH_ALL)
DISTFILES+= CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX}
PLIST_SUB+= FULL=""
PLIST_SUB+= LITE="@comment "
@@ -47,7 +48,7 @@ post-extract:
@${FIND} ${WRKSRC}/Library -name COPYING -delete
post-install:
-.if defined(WITH_FULL_LIBRARY)
+.if ${PORT_OPTIONS:MFULL_LIBRARY}
${TAR} xyvf ${_DISTDIR}/CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX} \
-C ${GNUSTEP_LOCAL_ROOT}/Library/ --exclude COPYING
@${CHOWN} -R root:wheel ${CENON_LIB_DIR}
@@ -58,4 +59,4 @@ post-install:
.endif
${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${CENON_LIB_DIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>