aboutsummaryrefslogtreecommitdiff
path: root/graphics/cfdg/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-26 17:55:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-26 17:55:18 +0000
commit5b0ed5f05f170d4dd974d48cd6eae607345ce063 (patch)
tree8ec6717d64908783afd241f032a045ce8c211a21 /graphics/cfdg/Makefile
parentddf9542c6149197f770d55bee5275a370ae362bf (diff)
downloadports-5b0ed5f05f170d4dd974d48cd6eae607345ce063.tar.gz
ports-5b0ed5f05f170d4dd974d48cd6eae607345ce063.zip
Notes
Diffstat (limited to 'graphics/cfdg/Makefile')
-rw-r--r--graphics/cfdg/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/cfdg/Makefile b/graphics/cfdg/Makefile
new file mode 100644
index 000000000000..0c6c412e7ed5
--- /dev/null
+++ b/graphics/cfdg/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cfdg
+# Date created: 2008-03-14
+# Whom: Anatoly Borodin <anatoly.borodin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfdg
+PORTVERSION= 2.1
+CATEGORIES= graphics math
+MASTER_SITES= http://www.contextfreeart.org/download/
+DISTNAME= ContextFreeSource${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anatoly.borodin@gmail.com
+COMMENT= Context Free Design Grammar compiler
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_BISON= build
+USE_GMAKE= yes
+
+NO_INSTALL_MANPAGES= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cfdg ${PREFIX}/bin
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/input/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>