aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-03-15 21:53:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-03-15 21:53:57 +0000
commite9ce392a0ae909506c03cccc29fc1079bdfb8378 (patch)
treea9066c7d5bdd06cf545cc712a025944d2f3399fd /graphics/cimg
parent60a92430b0c881edd37d7489ab1d7836b6bc70af (diff)
downloadports-e9ce392a0ae909506c03cccc29fc1079bdfb8378.tar.gz
ports-e9ce392a0ae909506c03cccc29fc1079bdfb8378.zip
Notes
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile6
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile33
-rw-r--r--graphics/cimg/pkg-plist68
4 files changed, 90 insertions, 21 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index a45440b30ecd..89b4ce49e1f8 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= cimg
-PORTVERSION= 1.0.7
-PORTREVISION= 3
+DISTVERSION= 1_08
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= CImg-${PORTVERSION:S/./_/:S/.//}
+DISTNAME= CImg-${DISTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= The C++ Template Image Processing Library
USE_ZIP= yes
+WRKSRC= ${WRKDIR}/CImg
BUILD_WRKSRC= ${WRKSRC}/examples
MAKE_ENV= CPPFLAGS="${CFLAGS} ${LAPACK_DEF} ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${LAPACK_LIB} ${PTHREAD_LIBS}" \
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index b357e80c7d51..b8e28b5e3251 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-MD5 (CImg-1_07.zip) = 004eccca2a6a768ea5f8f722ae79a614
-SIZE (CImg-1_07.zip) = 4147049
+MD5 (CImg-1_08.zip) = bd3b538ec895273ad336fde8171c7d3f
+SIZE (CImg-1_08.zip) = 6823695
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 8f6363895d3f..4e521803bc5e 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,28 +1,31 @@
---- examples/Makefile.orig Wed Oct 20 16:49:34 2004
-+++ examples/Makefile Wed Oct 20 21:16:24 2004
-@@ -7,14 +7,14 @@
+--- examples/Makefile.orig Tue Mar 15 16:20:14 2005
++++ examples/Makefile Tue Mar 15 22:23:09 2005
+@@ -7,16 +7,16 @@
# -----------------------------------------------------------------------------------
# Set correct variables and paths
--CC = g++ -O4 -Wall -ansi -ffast-math
--X11PATH = /usr/X11R6
-+CC = $(CXX)
-+#X11PATH = /usr/X11R6
- X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
+-CC = g++
+-X11PATH = /usr/X11R6
+-CFLAGS = -O2 -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include
++CC = $(CXX)
++#X11PATH = /usr/X11R6
++#CFLAGS = -O2 -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include
# Compilation rules
.cpp:
- @echo -e "\n** Compiling '$*'\n"
-- @$(CC) -o $* $< $(CFLAGS) $(X11FLAGS) $(LDFLAGS)
-+ @$(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -ffast-math $(X11FLAGS) $(LDFLAGS)
+ @echo
+ @echo "** Compiling '$*' with '`$(CC) -v 2>&1 | grep version`'"
+ @echo
+- $(CC) -o $* $< $(CFLAGS) $(LDFLAGS)
++ $(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include -lX11 -L$(X11PATH)/lib $(LDFLAGS)
linux:
- make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
+ make "LDFLAGS=-lpthread -lX11 -L$(X11PATH)/lib" all
solaris:
-@@ -37,6 +37,7 @@
+@@ -40,6 +40,7 @@
clean:
rm -f *.exe *~ \
+ Makefile.orig \
CImg_test \
- fade_images \
- inpainter \
+ fade_images \
+ greycstoration \
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index 12bd94994848..c6227dbe681f 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -17,6 +17,12 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/item_codesample.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/item_getting.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/item_intro.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/logoCNRS.gif
+%%PORTDOCS%%%%DOCSDIR%%/img/logoGREYC.gif
+%%PORTDOCS%%%%DOCSDIR%%/img/logoIMAGE.gif
+%%PORTDOCS%%%%DOCSDIR%%/img/logoINRIA.gif
+%%PORTDOCS%%%%DOCSDIR%%/img/logoODYSSEE.png
+%%PORTDOCS%%%%DOCSDIR%%/img/project-support.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/screenshots_item.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/ss_bubble.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/ss_bump.jpg
@@ -57,10 +63,66 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/tutorial.jpg
%%PORTDOCS%%%%DOCSDIR%%/index.shtml
%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/CImg_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/files.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_rela.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__displays.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__drawing.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__environment.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__files__io.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__loops.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__options.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__storage.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__structure.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespacecimg__library.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespacecimg__library_1_1cimg.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_func.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgArgumentException-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgArgumentException.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgArgumentException.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplay-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplay.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplayException-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplayException.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplayException.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgException-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgException.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgException.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgIOException-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgIOException.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgIOException.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgInstanceException-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgInstanceException.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgInstanceException.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgROI-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgROI.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgROI.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgStats-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgStats.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgl-members.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgl.html
%%PORTDOCS%%%%DOCSDIR%%/screenshots.shtml
%%PORTDOCS%%%%EXAMPLESDIR%%/CImg_test.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
%%PORTDOCS%%%%EXAMPLESDIR%%/fade_images.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/greycstoration.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/greycstoration_old.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/hough_transform.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/image_registration.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/img/background.jpg
@@ -88,6 +150,7 @@ include/CImg.h
%%PORTDOCS%%%%EXAMPLESDIR%%/img/head_face.raw
%%PORTDOCS%%%%EXAMPLESDIR%%/img/head_point.raw
%%PORTDOCS%%%%EXAMPLESDIR%%/img/heart.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/img/lena.pgm
%%PORTDOCS%%%%EXAMPLESDIR%%/img/light3d.ppm
%%PORTDOCS%%%%EXAMPLESDIR%%/img/logo.ppm
%%PORTDOCS%%%%EXAMPLESDIR%%/img/milla.ppm
@@ -97,8 +160,9 @@ include/CImg.h
%%PORTDOCS%%%%EXAMPLESDIR%%/img/sh1r.pgm
%%PORTDOCS%%%%EXAMPLESDIR%%/img/title.jpg
%%PORTDOCS%%%%EXAMPLESDIR%%/img/tomato.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/inpainter.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/img/trees.inr
%%PORTDOCS%%%%EXAMPLESDIR%%/inrcast.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/mcf_levelsets.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/odykill.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/pde_TschumperleDeriche2D.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/pde_TschumperleDeriche3D.cpp
@@ -107,6 +171,8 @@ include/CImg.h
%%PORTDOCS%%%%EXAMPLESDIR%%/render3d.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/tetris.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/wavelet_atrous.cpp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
%%PORTDOCS%%@dirrm %%DOCSDIR%%/img
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/img