aboutsummaryrefslogtreecommitdiff
path: root/graphics/cinepaint
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
commit9010280b855a8f663dc0899ba61ab950e6b515da (patch)
treeade0e2be591e771231576c7a69bfc8a5cf0bc252 /graphics/cinepaint
parent06a3e062ca8655d412fd71bf237d2cbcb5d17726 (diff)
downloadports-9010280b855a8f663dc0899ba61ab950e6b515da.tar.gz
ports-9010280b855a8f663dc0899ba61ab950e6b515da.zip
Notes
Diffstat (limited to 'graphics/cinepaint')
-rw-r--r--graphics/cinepaint/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 1e9e85c9651d..687ea4c5a644 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -35,14 +35,16 @@ PLIST_SUB= VER=${PORTVERSION}-1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1
-OPTIONS= OPENEXR "Use OpenEXR" on
+OPTIONS_DEFINE= OPENEXR
+OPTIONS_DEFAULT= OPENEXR
+OPENEXR_DESC= Use OpenEXR
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENEXR)
+.if ${PORT_OPTIONS:MOPENEXR}
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
@@ -71,4 +73,4 @@ post-patch:
${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; /^#include "FL/s|.h"$$|.H"|; \
s|fl_file_chooser.H|Fl_File_Chooser.H|g; s|#include <Fl|#include <FL|g; s|<FL/gl.H>|<FL/gl.h>|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>