aboutsummaryrefslogtreecommitdiff
path: root/graphics/clutter
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /graphics/clutter
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'graphics/clutter')
-rw-r--r--graphics/clutter/Makefile22
-rw-r--r--graphics/clutter/pkg-descr2
2 files changed, 15 insertions, 9 deletions
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index 8681562a5ff5..05b2660dad90 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: clutter
-# Date created: 2008-12-25
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/clutter/Makefile,v 1.34 2010/09/24 16:35:42 kwm Exp $
-#
PORTNAME= clutter
PORTVERSION= 1.4.0
@@ -16,15 +12,16 @@ MASTER_SITES= GNOME \
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
-LIB_DEPENDS= json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+LIB_DEPENDS= json-glib-1.0:${PORTSDIR}/devel/json-glib
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GMAKE= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_GNOME= gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_PKGCONFIG= build
USE_GL= gl
USE_XORG= glproto x11 xfixes xdamage xcomposite xi
USE_LDCONFIG= yes
@@ -33,4 +30,13 @@ CONFIGURE_ARGS= --with-x --enable-conformance=no
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/clutter/cally/*.c \
+ ${WRKSRC}/clutter/*.[ch] \
+ ${WRKSRC}/clutter/glx/*.c \
+ ${WRKSRC}/clutter/x11/*.h \
+ ${WRKSRC}/clutter/cogl/cogl/*.h \
+ ${WRKSRC}/clutter/json/*.c
+
.include <bsd.port.mk>
diff --git a/graphics/clutter/pkg-descr b/graphics/clutter/pkg-descr
index 593f4afbc1db..347482b0cf49 100644
--- a/graphics/clutter/pkg-descr
+++ b/graphics/clutter/pkg-descr
@@ -1,4 +1,4 @@
Clutter it an open source software library for creating fast, visually
rich and animated graphical user interfaces.
-WWW: http://clutter-project.org/
+WWW: https://live.gnome.org/Clutter