aboutsummaryrefslogtreecommitdiff
path: root/graphics/code-eli
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-03-20 18:39:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-03-20 18:39:34 +0000
commite6c9745c9d3bd3db3c0203ff63b8ec471a55a33f (patch)
treed86cebb25e2e1b157a8b9f335cea6abe84fa0a11 /graphics/code-eli
parent0e76a8f6df8e4634bf3f504b9ee77489babfb604 (diff)
Remove expired ports:
2018-03-19 graphics/code-eli: Broken for more than 6 months 2018-03-19 databases/pg_rman: Broken for more than 6 months 2018-03-19 devel/elixir-simple_bayes: Broken for more than 6 months 2018-03-19 devel/elixir-stemmer: Broken for more than 6 months 2018-03-19 benchmarks/expedite: Broken for more than 6 months 2018-03-19 textproc/p5-HTML-CTPP2: Broken for more than 6 months 2018-03-19 textproc/rubygem-compass-rails: Broken for more than 6 months
Notes
Notes: svn path=/head/; revision=465105
Diffstat (limited to 'graphics/code-eli')
-rw-r--r--graphics/code-eli/Makefile75
-rw-r--r--graphics/code-eli/distinfo2
-rw-r--r--graphics/code-eli/files/patch-cmake_ConfigureCompiler.cmake41
-rw-r--r--graphics/code-eli/pkg-descr7
-rw-r--r--graphics/code-eli/pkg-plist91
5 files changed, 0 insertions, 216 deletions
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
deleted file mode 100644
index d571fbaaa9d5..000000000000
--- a/graphics/code-eli/Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= code-eli
-PORTVERSION= 0.3.6
-PORTREVISION= 4
-CATEGORIES= graphics
-
-MAINTAINER= fernape@FreeBSD.org
-COMMENT= Library with functionalities for geometries
-
-LICENSE= EPL
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-
-BROKEN= Needs work to use math/eigen3 currently in ports
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2018-03-19
-
-USE_GITHUB= yes
-GH_PROJECT= Code-Eli
-GH_ACCOUNT= ddmarshall
-
-USES= cmake:outsource compiler:c++11-lib eigen:3
-PORTEXAMPLES= AirfoilFitExample VSPPodExample test
-ALL_TARGET= all
-
-# Some useful variables
-AIRFOIL_DIR= airfoil_fit
-VSPPOD_DIR= vsp_pod
-
-# Build options
-OPTIONS_DEFINE= DOXYGEN EXAMPLES
-EXAMPLES_LIB_DEPENDS= libcpptest.so:devel/cpptest
-DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:devel/doxygen
-DOXYGEN_ALL_TARGET= doc
-DOXYGEN_PORTDOCS= html latex
-
-BROKEN_armv6= fails to compile: undefined reference to cbrtl
-BROKEN_armv7= fails to compile: undefined reference to cbrtl
-BROKEN_powerpc64= fails to compile: there are no arguments to 'printf' that depend on a template parameter
-
-post-patch-EXAMPLES-off:
- ${REINPLACE_CMD} \
- -e 's/add_subdirectory(example)//g' \
- -e 's/find_package(CPPTest)//g' \
- ${WRKSRC}/CMakeLists.txt
-
-do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/eli
- ${INSTALL_DATA} ${BUILD_WRKSRC}/include/eli/code_eli.hpp \
- ${STAGEDIR}${PREFIX}/include/eli
- (cd ${WRKSRC}/include/eli && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/eli "*")
-
-do-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} \
- ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} \
- ${BUILD_WRKSRC}/example/${VSPPOD_DIR}/VSPPodExample \
- ${BUILD_WRKSRC}/example/${AIRFOIL_DIR}/AirfoilFitExample \
- ${STAGEDIR}${EXAMPLESDIR}
- ${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/VSPPodExample \
- ${STAGEDIR}${EXAMPLESDIR}/AirfoilFitExample
- (cd ${BUILD_WRKSRC}/${TEST_SUBDIR} && \
- ${COPYTREE_BIN} . ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} \
- "-name *Test -type f")
- ${FIND} ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} -name *Test | \
- ${XARGS} ${CHMOD} u+w
- ${FIND} ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} -name *Test | \
- ${XARGS} ${STRIP_CMD}
-
-do-install-DOXYGEN-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${BUILD_WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-
-.include <bsd.port.mk>
diff --git a/graphics/code-eli/distinfo b/graphics/code-eli/distinfo
deleted file mode 100644
index 51c53161c1f6..000000000000
--- a/graphics/code-eli/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ddmarshall-Code-Eli-0.3.6_GH0.tar.gz) = 2081ea221e33ca39f10def4fa46ce55af497a247f5c92f2a7d5d082fdaa94dff
-SIZE (ddmarshall-Code-Eli-0.3.6_GH0.tar.gz) = 262296
diff --git a/graphics/code-eli/files/patch-cmake_ConfigureCompiler.cmake b/graphics/code-eli/files/patch-cmake_ConfigureCompiler.cmake
deleted file mode 100644
index 047bb1184b90..000000000000
--- a/graphics/code-eli/files/patch-cmake_ConfigureCompiler.cmake
+++ /dev/null
@@ -1,41 +0,0 @@
---- cmake/ConfigureCompiler.cmake.orig 2014-08-17 07:02:14 UTC
-+++ cmake/ConfigureCompiler.cmake
-@@ -135,7 +135,7 @@ if(NOT CONFIGURE_COMPILER_INCLUDED)
- # set GNU Compiler Collection flags
- if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
- set(CONFIGURE_COMPILER_SET_C_COMPILER_FLAGS ON)
-- set(CMAKE_C_FLAGS "-pedantic -Wall -Wextra -fmessage-length=100 -std=c99"
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic -Wall -Wextra -fmessage-length=100 -std=c99"
- CACHE STRING "Flags used by the compiler during all build types." FORCE)
- set(CMAKE_C_FLAGS_DEBUG "-DDEBUG -O0 -g"
- CACHE STRING "Flags used by the compiler during debug builds." FORCE)
-@@ -152,9 +152,9 @@ if(NOT CONFIGURE_COMPILER_INCLUDED)
- if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
- set(CONFIGURE_COMPILER_SET_CXX_COMPILER_FLAGS ON)
- if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.7")
-- set(CMAKE_CXX_FLAGS "-std=c++0x")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
- else()
-- set(CMAKE_CXX_FLAGS "-std=c++11")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
- endif()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic -Wall -Wextra -Wno-long-long -fmessage-length=100"
- CACHE STRING "Flags used by the compiler during all build types." FORCE)
-@@ -189,7 +189,7 @@ if(NOT CONFIGURE_COMPILER_INCLUDED)
- set(CMAKE_XCODE_ATTRIBUTE_GCC_WARN_INHIBIT_ALL_WARNINGS "YES")
- set(CMAKE_XCODE_ATTRIBUTE_GCC_WARN_PEDANTIC "YES")
- else()
-- set(CMAKE_C_FLAGS "-pedantic -Wall -Wextra -fmessage-length=100 -std=c99"
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic -Wall -Wextra -fmessage-length=100 -std=c99"
- CACHE STRING "Flags used by the compiler during all build types." FORCE)
- endif()
- set(CMAKE_C_FLAGS_DEBUG "-DDEBUG -O0 -g"
-@@ -212,7 +212,7 @@ if(NOT CONFIGURE_COMPILER_INCLUDED)
- set(CMAKE_XCODE_ATTRIBUTE_GCC_WARN_INHIBIT_ALL_WARNINGS "YES")
- set(CMAKE_XCODE_ATTRIBUTE_GCC_WARN_PEDANTIC "YES")
- else()
-- set(CMAKE_CXX_FLAGS "-pedantic -Wall -Wextra -Wno-long-long -fmessage-length=100 -std=c++11 -stdlib=libc++"
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic -Wall -Wextra -Wno-long-long -fmessage-length=100 -std=c++11 -stdlib=libc++"
- CACHE STRING "Flags used by the compiler during all build types." FORCE)
- endif()
- set(CMAKE_CXX_FLAGS_DEBUG "-DDEBUG -O0 -g"
diff --git a/graphics/code-eli/pkg-descr b/graphics/code-eli/pkg-descr
deleted file mode 100644
index 58f45875647c..000000000000
--- a/graphics/code-eli/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This is a collection of C++ libraries that provides a variety of
-functionalities for geometries (bezier curves, splines, etc.).
-Eigen3 is needed for most of the components to work since all of
-the vector and matrix math is done using Eigen3. CPPTest is used
-to perform unit testing on the components.
-
-WWW: https://github.com/ddmarshall/Code-Eli
diff --git a/graphics/code-eli/pkg-plist b/graphics/code-eli/pkg-plist
deleted file mode 100644
index 4a2112c5a372..000000000000
--- a/graphics/code-eli/pkg-plist
+++ /dev/null
@@ -1,91 +0,0 @@
-include/eli/code_eli.hpp
-include/eli/constants.hpp
-include/eli/constants/math.hpp
-include/eli/geom.hpp
-include/eli/geom/curve.hpp
-include/eli/geom/curve/bezier.hpp
-include/eli/geom/curve/curvature.hpp
-include/eli/geom/curve/equivalent_curves.hpp
-include/eli/geom/curve/explicit_bezier.hpp
-include/eli/geom/curve/fit_container.hpp
-include/eli/geom/curve/length.hpp
-include/eli/geom/curve/piecewise.hpp
-include/eli/geom/curve/piecewise_circle_creator.hpp
-include/eli/geom/curve/piecewise_creator.hpp
-include/eli/geom/curve/piecewise_creator_base.hpp
-include/eli/geom/curve/piecewise_cubic_spline_creator.hpp
-include/eli/geom/curve/piecewise_four_digit_creator.hpp
-include/eli/geom/curve/piecewise_general_creator.hpp
-include/eli/geom/curve/piecewise_linear_creator.hpp
-include/eli/geom/curve/piecewise_point_creator.hpp
-include/eli/geom/curve/piecewise_polygon_creator.hpp
-include/eli/geom/curve/piecewise_superellipse_creator.hpp
-include/eli/geom/curve/pseudo.hpp
-include/eli/geom/curve/pseudo/four_digit.hpp
-include/eli/geom/curve/torsion.hpp
-include/eli/geom/general.hpp
-include/eli/geom/general/bounding_box.hpp
-include/eli/geom/general/continuity.hpp
-include/eli/geom/intersect.hpp
-include/eli/geom/intersect/minimum_distance.hpp
-include/eli/geom/intersect/minimum_distance_bounding_box.hpp
-include/eli/geom/intersect/minimum_distance_curve.hpp
-include/eli/geom/intersect/minimum_distance_line.hpp
-include/eli/geom/intersect/minimum_distance_plane.hpp
-include/eli/geom/intersect/minimum_distance_point.hpp
-include/eli/geom/intersect/minimum_distance_surface.hpp
-include/eli/geom/point.hpp
-include/eli/geom/point/distance.hpp
-include/eli/geom/surface.hpp
-include/eli/geom/surface/bezier.hpp
-include/eli/geom/surface/curvature.hpp
-include/eli/geom/surface/piecewise.hpp
-include/eli/geom/surface/piecewise_body_of_revolution_creator.hpp
-include/eli/geom/surface/piecewise_capped_surface_creator.hpp
-include/eli/geom/surface/piecewise_connection_data.hpp
-include/eli/geom/surface/piecewise_creator_base.hpp
-include/eli/geom/surface/piecewise_general_skinning_surface_creator.hpp
-include/eli/geom/utility/bezier.hpp
-include/eli/mutil.hpp
-include/eli/mutil/ad.hpp
-include/eli/mutil/ad/dual.hpp
-include/eli/mutil/ad/dual_functions.hpp
-include/eli/mutil/ad/dual_math.hpp
-include/eli/mutil/ad/dual_number.hpp
-include/eli/mutil/ad/dual_operators.hpp
-include/eli/mutil/ad/dual_traits.hpp
-include/eli/mutil/dm.hpp
-include/eli/mutil/dm/binomial_coefficient.hpp
-include/eli/mutil/dm/combination.hpp
-include/eli/mutil/dm/factorial.hpp
-include/eli/mutil/fd.hpp
-include/eli/mutil/fd/d1o1.hpp
-include/eli/mutil/fd/d1o2.hpp
-include/eli/mutil/fd/d1o3.hpp
-include/eli/mutil/fd/d2o1.hpp
-include/eli/mutil/fd/d2o2.hpp
-include/eli/mutil/nls.hpp
-include/eli/mutil/nls/bisection_method.hpp
-include/eli/mutil/nls/iterative_root_base.hpp
-include/eli/mutil/nls/iterative_system_root_base.hpp
-include/eli/mutil/nls/newton_raphson_constrained_method.hpp
-include/eli/mutil/nls/newton_raphson_constrained_system_method.hpp
-include/eli/mutil/nls/newton_raphson_method.hpp
-include/eli/mutil/nls/newton_raphson_system_method.hpp
-include/eli/mutil/nls/secant_method.hpp
-include/eli/mutil/opt.hpp
-include/eli/mutil/opt/least_squares.hpp
-include/eli/mutil/poly.hpp
-include/eli/mutil/poly/polynomial.hpp
-include/eli/mutil/poly/root/closed_form.hpp
-include/eli/mutil/poly/root/descartes_rule.hpp
-include/eli/mutil/poly/root/radius.hpp
-include/eli/mutil/poly/root/sign_changes.hpp
-include/eli/mutil/poly/root/sturm_count.hpp
-include/eli/mutil/quad.hpp
-include/eli/mutil/quad/simpson.hpp
-include/eli/mutil/quad/trapezoid.hpp
-include/eli/util.hpp
-include/eli/util/floating_point.hpp
-include/eli/util/tolerance.hpp
-include/eli/util/traits.hpp