aboutsummaryrefslogtreecommitdiff
path: root/graphics/comix/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-12-10 18:45:03 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-12-10 18:45:03 +0000
commit34c174c22aed6b545d377ceb3fbbaf6f81b37b40 (patch)
treef53f53f9aecc053fc664984569225d26ea5bca70 /graphics/comix/Makefile
parentf8b74345b5024b67ffea0c24326d2e0dd7e7985c (diff)
downloadports-34c174c22aed6b545d377ceb3fbbaf6f81b37b40.tar.gz
ports-34c174c22aed6b545d377ceb3fbbaf6f81b37b40.zip
Notes
Diffstat (limited to 'graphics/comix/Makefile')
-rw-r--r--graphics/comix/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/graphics/comix/Makefile b/graphics/comix/Makefile
new file mode 100644
index 000000000000..d77f1d14771f
--- /dev/null
+++ b/graphics/comix/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: comix
+# Date created: 26 November 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= comix
+PORTVERSION= 2.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A GTK2 comic book viewer for .cbz, .cbr and .cbt files
+
+RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar
+
+NO_BUILD= yes
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+DOCS= COPYING ChangeLog README
+MAN1= comix.1
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/comix.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|g ; s|1.gz|1|g' \
+ ${WRKSRC}/install.py
+
+do-install:
+ @(cd ${WRKSRC} ; \
+ ${PYTHON_CMD} install.py install --installdir ${PREFIX})
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>