aboutsummaryrefslogtreecommitdiff
path: root/graphics/comix/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-01-30 20:12:04 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-01-30 20:12:04 +0000
commitf8173df16e28f01b846276943ec558a35d3f9e6f (patch)
tree8d09ed518e42a0f84416947a894c239e787e6320 /graphics/comix/Makefile
parent6f09005a38f74978b079239f61ec10d0c6ff9c17 (diff)
downloadports-f8173df16e28f01b846276943ec558a35d3f9e6f.tar.gz
ports-f8173df16e28f01b846276943ec558a35d3f9e6f.zip
Notes
Diffstat (limited to 'graphics/comix/Makefile')
-rw-r--r--graphics/comix/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/comix/Makefile b/graphics/comix/Makefile
index ba73b7b439e5..7aa2fb44ee6d 100644
--- a/graphics/comix/Makefile
+++ b/graphics/comix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= comix
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
NO_BUILD= yes
-USE_GNOME= pygtk2
+USE_GNOME= desktopfileutils pygtk2
USE_PYTHON= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
@@ -27,7 +27,7 @@ DOCS= COPYING ChangeLog README
MAN1= comix.1
post-extract:
- @${GUNZIP_CMD} ${WRKSRC}/comix.1.gz
+ @${GUNZIP_CMD} ${WRKSRC}/${PORTNAME}.1.gz
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|g ; s|1.gz|1|g' \
@@ -36,9 +36,14 @@ post-patch:
do-install:
@(cd ${WRKSRC} ; \
${PYTHON_CMD} install.py install --installdir ${PREFIX})
+ @${MKDIR} ${PREFIX}/share/mime/packages/
+ @${INSTALL_DATA} ${WRKSRC}/mime/${PORTNAME}.xml \
+ ${PREFIX}/share/mime/packages/
-.ifndef (NOPORTDOCS)
post-install:
+ @-update-desktop-database
+ @-update-mime-database ${PREFIX}/share/mime
+.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}