aboutsummaryrefslogtreecommitdiff
path: root/graphics/commons-utilities/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-04 16:29:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-04 16:29:50 +0000
commit158517e1760dd0fbfe4ec485491205c0e40be05d (patch)
tree64abe67b5aaa0c5e4bfb539863eac8465be55cf7 /graphics/commons-utilities/Makefile
parentd14cf13d2ace35de10567edc614b2ffd8d37b3d6 (diff)
Notes
Diffstat (limited to 'graphics/commons-utilities/Makefile')
-rw-r--r--graphics/commons-utilities/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/graphics/commons-utilities/Makefile b/graphics/commons-utilities/Makefile
index 349847fbff79..35c19b589e6a 100644
--- a/graphics/commons-utilities/Makefile
+++ b/graphics/commons-utilities/Makefile
@@ -1,4 +1,4 @@
-# Created by: Dereckson <dereckson@gmail.com>
+# Created by: Sébastien Santoro <dereckson@gmail.com>
# $FreeBSD$
PORTNAME= commons-utilities
@@ -8,9 +8,11 @@ CATEGORIES= graphics
MASTER_SITES= http://devio.us/~dereckson/software/commons-utilities/
MAINTAINER= dereckson@gmail.com
-COMMENT= Wikimedia Commons / MediaWiki utilities for bulk uploading
+COMMENT= Wikimedia Commons (MediaWiki) utilities for bulk uploading
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LICENSE= GPLv3
+
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-Text-CSV_XS>=0:${PORTSDIR}/textproc/p5-Text-CSV_XS \
@@ -18,29 +20,18 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
${PYTHON_PKGNAMEPREFIX}mechanize>=0.2:${PORTSDIR}/www/py-mechanize \
exiv2:${PORTSDIR}/graphics/exiv2
-NO_BUILD= yes
USES= perl5
USE_PERL5= run
USE_PYTHON= yes
-
-LICENSE= GPLv3
+NO_BUILD= yes
PLIST_FILES= bin/commons-csv-creator bin/commons-upload
+PORTDOCS= README
-.if !defined(NOPORTDOCS)
-PLIST_DIRS= %%DOCSDIR%%
-PLIST_FILES+= %%DOCSDIR%%/README
-.endif
-
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/commons-csv-creator ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/commons-upload ${PREFIX}/bin
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/commons-csv-creator ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/commons-upload ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>