aboutsummaryrefslogtreecommitdiff
path: root/graphics/crystalentitylayer/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-09-16 21:09:24 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-09-16 21:09:24 +0000
commit1f1da023b322e30cbf2d8b32fa03bdf279ae3b1a (patch)
treedda7c54cc523d9306cf7249af4569638d97be81f /graphics/crystalentitylayer/Makefile
parente987917b44e8146179bef3e5d2287ced169e1afb (diff)
- Update to 1.0.2
Notes
Notes: svn path=/head/; revision=199578
Diffstat (limited to 'graphics/crystalentitylayer/Makefile')
-rw-r--r--graphics/crystalentitylayer/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/crystalentitylayer/Makefile b/graphics/crystalentitylayer/Makefile
index 6a7421f6614d..59b28f364340 100644
--- a/graphics/crystalentitylayer/Makefile
+++ b/graphics/crystalentitylayer/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= crystalentitylayer
-PORTVERSION= 0.99
-PORTREVISION= 5
+PORTVERSION= 1.0.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cel
-DISTNAME= cel-pseudo-stable-2006-01-27
+DISTNAME= cel-src-${PORTVERSION}
DIST_SUBDIR= crystalspace
MAINTAINER= acm@FreeBSD.org
@@ -28,12 +27,12 @@ GNU_CONFIGURE= yes
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
CONFIGURE_ARGS+= --with-cs-prefix=${LOCALBASE}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS} ${CXX}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
DOCSDIR= share/doc/cel-${PORTVERSION}
DATADIR= share/cel
PLIST_SUB+= DOCSDIR=${DOCSDIR} \
DATADIR=${DATADIR}
-WRKSRC= ${WRKDIR}/cel
JAM_CMD= ${LOCALBASE}/bin/jam
JAM_ARGS= -qa
@@ -72,7 +71,7 @@ CONFIGURE_ARGS+= --without-bfd
post-configure:
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 61d ${WRKSRC}/Jamfile
+ @${REINPLACE_CMD} -e 63d ${WRKSRC}/Jamfile
.endif
do-build: