aboutsummaryrefslogtreecommitdiff
path: root/graphics/cthumb/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 09:07:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 09:07:51 +0000
commit70bc129b56b7f38b7bfe7fca120d72bea71fd439 (patch)
treee369f29f4c1d8f47c0edef076f77912f0af22745 /graphics/cthumb/Makefile
parent505ecaca2e8149ebc6b38ad48a9ff3b5f97b9617 (diff)
Notes
Diffstat (limited to 'graphics/cthumb/Makefile')
-rw-r--r--graphics/cthumb/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/graphics/cthumb/Makefile b/graphics/cthumb/Makefile
new file mode 100644
index 000000000000..538dd1168c85
--- /dev/null
+++ b/graphics/cthumb/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: cthumb
+# Date created: 30 July 2001
+# Whom: dom@happygiraffe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= cthumb
+PORTVERSION= 3.4
+CATEGORIES= graphics www
+MASTER_SITES= http://puchol.com/cpg/software/cthumb/
+
+MAINTAINER= dom@happygiraffe.net
+
+RUN_DEPENDS= ${LOCALBASE}/bin/pnmscale:${PORTSDIR}/graphics/netpbm \
+ ${LOCALBASE}/bin/djpeg:${PORTSDIR}/graphics/jpeg \
+ ${SITE_PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+SITE_PERL_ARCH= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+
+GNU_CONFIGURE= yes
+
+MAN1= cthumb.1
+
+THEMES= blue-steel.theme \
+ classic-clips.theme \
+ classic.theme \
+ crosshair.theme \
+ film.theme \
+ float-medium.theme \
+ float-more.theme \
+ float-thick.theme \
+ float.theme \
+ neat-round.theme \
+ neat-square.theme \
+ postcard.theme \
+ shiny-tube.theme \
+ simpleframe.theme \
+ slides-big.theme \
+ slides-clean.theme \
+ slides-huge.theme \
+ slides-small.theme \
+ tv-large.theme \
+ tv.theme
+
+post-configure:
+ @${PERL} -pi \
+ -e 's|${PREFIX}/share/images/cthumb|${DATADIR}|g;' \
+ -e 's|cp -a|cp -R|g;' \
+ ${WRKSRC}/cthumb
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cthumb ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cthumb.1 ${PREFIX}/man/man1
+ ${MKDIR} ${DATADIR}
+.for theme in ${THEMES}
+ ${MKDIR} ${DATADIR}/${theme}
+ ${INSTALL_DATA} ${WRKSRC}/themes/${theme}/* ${DATADIR}/${theme}
+.endfor
+.if !defined(NOPRTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ChangeLog INSTALL README TO-DO VERSION cthumbrc.sample
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>