aboutsummaryrefslogtreecommitdiff
path: root/graphics/cuneiform
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-09-06 08:17:24 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-09-06 08:17:24 +0000
commit68615e4f950ad59cea698ca27561f38eda9f22ce (patch)
treece87c45e108e3bbd9ff161457d0db18a9c230d6b /graphics/cuneiform
parent6aca8cd34da62d016e885e1479dd8c6c2f394e2b (diff)
downloadports-68615e4f950ad59cea698ca27561f38eda9f22ce.tar.gz
ports-68615e4f950ad59cea698ca27561f38eda9f22ce.zip
Notes
Diffstat (limited to 'graphics/cuneiform')
-rw-r--r--graphics/cuneiform/Makefile4
-rw-r--r--graphics/cuneiform/distinfo6
-rw-r--r--graphics/cuneiform/files/patch-upstream213
3 files changed, 5 insertions, 218 deletions
diff --git a/graphics/cuneiform/Makefile b/graphics/cuneiform/Makefile
index 2c378fa20650..7ffe033ee425 100644
--- a/graphics/cuneiform/Makefile
+++ b/graphics/cuneiform/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= cuneiform
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4.0
CATEGORIES= graphics
MASTER_SITES= https://launchpad.net/cuneiform-linux/${PORTVERSION:R}/${PORTVERSION:R}/+download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
MAINTAINER= samm@os2.kiev.ua
COMMENT= OCR system developed and open sourced by Cognitive technologies
@@ -39,7 +40,6 @@ post-extract:
${MKDIR} ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e 's|lib64|lib|' ${WRKSRC}/../CMakeLists.txt
.if !defined(WITH_IMAGEMAGICK)
@${REINPLACE_CMD} -e '/pkg_check_modules.*ImageMagick/ d' \
${WRKSRC}/../cuneiform_src/Kern/CMakeLists.txt
diff --git a/graphics/cuneiform/distinfo b/graphics/cuneiform/distinfo
index 4ceda334befb..2ec783c1bc2f 100644
--- a/graphics/cuneiform/distinfo
+++ b/graphics/cuneiform/distinfo
@@ -1,3 +1,3 @@
-MD5 (cuneiform-0.3.1.tar.bz2) = 4b819517200764a5423329dc45033c16
-SHA256 (cuneiform-0.3.1.tar.bz2) = 9a48da92489b44d86db06e3aa273afb2375d19161e94e293d74341dbdab92971
-SIZE (cuneiform-0.3.1.tar.bz2) = 30110799
+MD5 (cuneiform-0.4.tar.bz2) = 08b93d50db47b31a86b1f79a3f4e9ad8
+SHA256 (cuneiform-0.4.tar.bz2) = a3e024f144cdc8d16e776096a72e73928fbd454def6b48e0c4e0d4b7eed220f0
+SIZE (cuneiform-0.4.tar.bz2) = 30671830
diff --git a/graphics/cuneiform/files/patch-upstream b/graphics/cuneiform/files/patch-upstream
deleted file mode 100644
index 898df95c00d1..000000000000
--- a/graphics/cuneiform/files/patch-upstream
+++ /dev/null
@@ -1,213 +0,0 @@
-=== modified file 'cuneiform_src/Kern/ccom/src/ccom_loc.c'
---- cuneiform_src/Kern/ccom/src/ccom_loc.c 2008-07-29 09:38:01 +0000
-+++ cuneiform_src/Kern/ccom/src/ccom_loc.c 2008-08-22 08:22:46 +0000
-@@ -87,7 +87,7 @@
-
- if (bChangeSize) // one should change a size of raster
- {
-- for(line=linerep,wmax=len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((int)line+line->lth))
-+ for(line=linerep,wmax=len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((intptr_t)line+line->lth))
- {
- for(inter = (CCOM_interval*)(line+1), i=0; i<line->h; i++, inter++)
- {
-@@ -106,7 +106,7 @@
- }
- else //bChangeSize==false one should not change a size of raster
- {
-- for(line=linerep,wmax=len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((int)line+line->lth))
-+ for(line=linerep,wmax=len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((intptr_t)line+line->lth))
- {
- for(inter = (CCOM_interval*)(line+1), i=0; i<line->h; i++, inter++)
- {
-@@ -133,7 +133,7 @@
- return FALSE;
- ww = REC_GW_WORD8(rec->lnPixWidth);
-
--for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((int)line+line->lth))
-+for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((intptr_t)line+line->lth))
- {
- for(inter = (CCOM_interval*)(line+1), i=0; i<line->h; i++, inter++)
- {
-@@ -175,7 +175,7 @@
- return FALSE;
- ww = REC_GW_WORD8(rec->lnPixWidth);
-
--for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((int)line+line->lth))
-+for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((intptr_t)line+line->lth))
- {
- for(inter = (CCOM_interval*)(line+1), i=0; i<line->h; i++, inter++)
- {
-
-=== modified file 'cuneiform_src/Kern/cuneiform-cli.cpp'
---- cuneiform_src/Kern/cuneiform-cli.cpp 2008-08-05 09:29:31 +0000
-+++ cuneiform_src/Kern/cuneiform-cli.cpp 2008-08-22 13:58:24 +0000
-@@ -41,8 +41,7 @@
- const char *name;
- };
-
--/* Language codes according to ISO 639-2. Most of these don't seem to have
-- * corresponding data files. A bug?
-+/* Language codes according to ISO 639-2.
- */
- static const langlist langs[] = {
- {PUMA_LANG_ENGLISH, "eng"},
-@@ -60,10 +59,10 @@
- {PUMA_LANG_DANISH, "dan"},
- {PUMA_LANG_PORTUGUESE,"por"},
- {PUMA_LANG_DUTCH, "dut"},
-- {PUMA_LANG_DIG, "dig"}, // What is this language?
-- {PUMA_LANG_UZBEK, "uzb"},
-- {PUMA_LANG_KAZ, "kaz"},
-- {PUMA_LANG_KAZ_ENG, "kazeng"},
-+// {PUMA_LANG_DIG, "dig"}, // These four languages don't seem to have data files.
-+// {PUMA_LANG_UZBEK, "uzb"}, // Thus they are disabled.
-+// {PUMA_LANG_KAZ, "kaz"},
-+// {PUMA_LANG_KAZ_ENG, "kazeng"},
- {PUMA_LANG_CZECH, "cze"},
- {PUMA_LANG_ROMAN, "rum"},
- {PUMA_LANG_HUNGAR, "hun"},
-@@ -160,6 +159,8 @@
- char *dib;
- const char *infilename = NULL;
- Word32 langcode = PUMA_LANG_ENGLISH; // By default recognize plain english text.
-+ Bool32 dotmatrix = FALSE;
-+ Bool32 fax = FALSE;
- const char *defaulttextname = "cuneiform-out.txt";
- const char *defaulthtmlname = "cuneiform-out.html";
- const char *outfilename = NULL;
-@@ -170,6 +171,7 @@
- for(int i=1; i<argc; i++) {
- /* Changing language. */
- if(strcmp(argv[i], "-l") == 0) {
-+ langcode = -1;
- if(++i >= argc) {
- print_supported_languages();
- return 1;
-@@ -193,6 +195,10 @@
- outfilename = argv[i];
- } else if(strcmp(argv[i], "--html") == 0) {
- outputformat = PUMA_TOHTML;
-+ } else if(strcmp(argv[i], "--dotmatrix") == 0) {
-+ dotmatrix = TRUE;
-+ } else if(strcmp(argv[i], "--fax") == 0) {
-+ fax = TRUE;
- } else {
- /* No switches, so set input file. */
- infilename = argv[i];
-@@ -208,7 +214,7 @@
- }
-
- if(infilename == NULL) {
-- printf("Usage: %s [-l languagename --html -o result_file] imagefile\n", argv[0]);
-+ printf("Usage: %s [-l languagename --html --dotmatrix --fax -o result_file] imagefile\n", argv[0]);
- return 0;
- }
-
-@@ -224,6 +230,8 @@
-
- // Set the language.
- PUMA_SetImportData(PUMA_Word32_Language, &langcode);
-+ PUMA_SetImportData(PUMA_Bool32_DotMatrix, &dotmatrix);
-+ PUMA_SetImportData(PUMA_Bool32_Fax100, &fax);
-
- if(!PUMA_XOpen(dib, "none.txt")) {
- printf("PUMA_Xopen failed.\n");
-
-=== modified file 'cuneiform_src/Kern/rblock/sources/h/pic_n_table.h'
---- cuneiform_src/Kern/rblock/sources/h/pic_n_table.h 2008-07-29 09:38:01 +0000
-+++ cuneiform_src/Kern/rblock/sources/h/pic_n_table.h 2008-08-22 08:22:46 +0000
-@@ -58,4 +58,4 @@
- Bool32 DeleteRootsFromTables (void);
- Bool32 DeleteRootsFromPictures (void);
- Bool32 CarefulPicturesAllotment(Int32);
--Bool32 SearchPicturesSecond (Int32 hCCOM, Bool32 BLOCKS, CCOM_comp * comp);
-+Bool32 SearchPicturesSecond (Handle hCCOM, Bool32 BLOCKS, CCOM_comp * comp);
-
-=== modified file 'cuneiform_src/Kern/rblock/sources/new_c/_loadroots.c'
---- cuneiform_src/Kern/rblock/sources/new_c/_loadroots.c 2008-07-29 09:38:01 +0000
-+++ cuneiform_src/Kern/rblock/sources/new_c/_loadroots.c 2008-08-22 08:22:46 +0000
-@@ -223,7 +223,7 @@
- ////////////////////////////////////////////////////////////////////////////////
-
- ////////////////////////////////////////////////////////////////////////////////
--Bool32 PicturesSecondStage(Int32 hCCOM,Handle hCPAGE)
-+Bool32 PicturesSecondStage(Handle hCCOM,Handle hCPAGE)
- {
- /************** final union all crossed and included pictures ******************/
-
-@@ -527,9 +527,9 @@
- return TRUE;
- }
-
--Bool32 FillBigLetters (Int32 hCCOM,Handle hCPAGE)
-+Bool32 FillBigLetters (Handle hCCOM,Handle hCPAGE)
- {
-- Word32 BlockType;
-+ Handle BlockType;
- Handle pBlock;
- RPIC_Comp_Rect CompRect; // типичный Rect16
-
-@@ -557,7 +557,7 @@
- }
-
-
--Bool32 FillPicsInTables (Int32 hCCOM,Handle hCPAGE)
-+Bool32 FillPicsInTables (Handle hCCOM,Handle hCPAGE)
- {
- //CCOM_comp common;
- POLY_ block;
-@@ -622,7 +622,7 @@
-
- /************************************************************************/
-
--Bool32 ReadRoots(Int32 hCCOM, Bool32 BLOCKS)
-+Bool32 ReadRoots(Handle hCCOM, Bool32 BLOCKS)
- {
- CCOM_comp * comp = NULL;
- Handle pPage;
-
-=== modified file 'cuneiform_src/Kern/rblock/sources/new_c/_pic_n_table.c'
---- cuneiform_src/Kern/rblock/sources/new_c/_pic_n_table.c 2008-07-29 09:38:01 +0000
-+++ cuneiform_src/Kern/rblock/sources/new_c/_pic_n_table.c 2008-08-22 08:22:46 +0000
-@@ -202,7 +202,7 @@
- return TRUE;
- }
-
--Bool32 SearchPicturesSecond (Int32 hCCOM, Bool32 BLOCKS, CCOM_comp * comp)
-+Bool32 SearchPicturesSecond (Handle hCCOM, Bool32 BLOCKS, CCOM_comp * comp)
- {
- return TRUE;
- }
-
-=== modified file 'cuneiform_src/Kern/rstr/src/p2_bold.c'
---- cuneiform_src/Kern/rstr/src/p2_bold.c 2008-07-29 09:38:01 +0000
-+++ cuneiform_src/Kern/rstr/src/p2_bold.c 2008-08-22 08:22:46 +0000
-@@ -230,7 +230,7 @@
- CCOM_interval * inter;
- int len,i,j;
-
-- for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((int)line+line->lth))
-+ for(line=linerep,len=0; len<size && line->lth; len+=line->lth,line=(CCOM_lnhead *)((intptr_t)line+line->lth))
- {
- // начало линии (line->row) - нам не важно
- for(inter = (CCOM_interval*)(line+1), i=0; i<line->h; i++, inter++)
-
-=== modified file 'readme.txt'
---- readme.txt 2008-08-21 12:09:05 +0000
-+++ readme.txt 2008-08-22 13:01:28 +0000
-@@ -54,7 +54,7 @@
-
- After install you simply run.
-
--cuneiform [-l language -o result_file --html] <image_file>
-+cuneiform [-l language -o result_file --html --dotmatrix --fax] <image_file>
-
- Output is written to pumaout.txt. Cuneiform assumes that your image contains
- only a single column of text.
-@@ -74,4 +74,4 @@
- Contact information
-
- Project home page: https://launchpad.net/cuneiform-linux
--Email: jpakkane at gmail
-+Mailing list: https://launchpad.net/~cuneiform
-