aboutsummaryrefslogtreecommitdiff
path: root/graphics/darknock
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-20 15:45:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-20 15:45:07 +0000
commit1a2f0d274ee19ebe7e06a88dd6a062db8094f04a (patch)
tree265c42dd83fa2e31599109ce05dec81c9ce2205b /graphics/darknock
parent2efde2aeb9720118571404d34284c7c12dd58c91 (diff)
downloadports-1a2f0d274ee19ebe7e06a88dd6a062db8094f04a.tar.gz
ports-1a2f0d274ee19ebe7e06a88dd6a062db8094f04a.zip
Notes
Diffstat (limited to 'graphics/darknock')
-rw-r--r--graphics/darknock/Makefile59
-rw-r--r--graphics/darknock/distinfo3
-rw-r--r--graphics/darknock/pkg-descr5
-rw-r--r--graphics/darknock/pkg-plist9
4 files changed, 76 insertions, 0 deletions
diff --git a/graphics/darknock/Makefile b/graphics/darknock/Makefile
new file mode 100644
index 000000000000..3ea291b83566
--- /dev/null
+++ b/graphics/darknock/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: darknock
+# Date created: 5 August 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= darknock
+DISTVERSION= 0.2.7
+CATEGORIES= graphics kde
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A program that can detect edges in images
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build linguist_build gui
+WRKSRC= ${WRKDIR}/${PORTNAME}
+LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
+
+PORTDOCS= changelog copyright
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+DESKTOP_ENTRIES= "${PORTNAME}" \
+ "${COMMENT}" \
+ "${PORTNAME}" \
+ "${PORTNAME}" \
+ "Qt;KDE;Graphics;" \
+ "false"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/darknock|${DATADIR}|g' \
+ ${WRKSRC}/src/main.cpp
+
+pre-build:
+ @${LRELEASE} ${BUILD_WRKSRC}/${PORTNAME}.pro
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${PREFIX}/share/pixmaps
+.if !defined(WITHOUT_NLS)
+ @${MKDIR} ${DATADIR}/locale
+ @${INSTALL_DATA} ${WRKSRC}/locale/*.qm ${DATADIR}/locale
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/darknock/distinfo b/graphics/darknock/distinfo
new file mode 100644
index 000000000000..4a0e630fa08b
--- /dev/null
+++ b/graphics/darknock/distinfo
@@ -0,0 +1,3 @@
+MD5 (darknock-0.2.7-src.tar.gz) = 98c2b4df4bc807807a93c1a0665d18fd
+SHA256 (darknock-0.2.7-src.tar.gz) = 9a0fd9a2fec413cbf88ec108732a55a5af6a8cd9c7991bd7f97280cf2970355e
+SIZE (darknock-0.2.7-src.tar.gz) = 117465
diff --git a/graphics/darknock/pkg-descr b/graphics/darknock/pkg-descr
new file mode 100644
index 000000000000..ebfafb57d6da
--- /dev/null
+++ b/graphics/darknock/pkg-descr
@@ -0,0 +1,5 @@
+darknocK detects edges in images, better than any other program. It will be
+using Artificial Neural Networks to enchance the results of standard algorithms.
+It's a part of My work for My Master degree.
+
+WWW: http://sourceforge.net/projects/darknock/
diff --git a/graphics/darknock/pkg-plist b/graphics/darknock/pkg-plist
new file mode 100644
index 000000000000..7abc6d7fb22d
--- /dev/null
+++ b/graphics/darknock/pkg-plist
@@ -0,0 +1,9 @@
+bin/darknock
+%%NLS%%%%DATADIR%%/locale/darknock_it.qm
+%%NLS%%%%DATADIR%%/locale/darknock_pl.qm
+%%NLS%%%%DATADIR%%/locale/darknock_ro.qm
+%%NLS%%%%DATADIR%%/locale/darknock_sv.qm
+%%NLS%%%%DATADIR%%/locale/darknock_tr.qm
+share/pixmaps/darknock.png
+%%NLS%%@dirrm %%DATADIR%%/locale
+%%NLS%%@dirrm %%DATADIR%%