aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-04 09:23:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-04 09:23:41 +0000
commitc9ffe24284996d5b467dc2b7e97ac80400d425a1 (patch)
treed2fd2882411341a323514173ba7a9a4823715fe0 /graphics/darktable/Makefile
parentb223ec018107bd3c5c7d65c774529d81a9fde79a (diff)
downloadports-c9ffe24284996d5b467dc2b7e97ac80400d425a1.tar.gz
ports-c9ffe24284996d5b467dc2b7e97ac80400d425a1.zip
Notes
Diffstat (limited to 'graphics/darktable/Makefile')
-rw-r--r--graphics/darktable/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 10af7ea15c42..bf328cd4b306 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -32,6 +32,7 @@ MAN1= ${PORTNAME}.1
OPTIONS= GCONF "Enable GConf backend" off \
GPHOTO "Enable camera support via libgphoto2" on \
FLICKR "Enable Flickr support via flickcurl" off \
+ RAWSPEED "Compile with rawspeed backend" on \
SLIDESHOW "Build OpenGL/SDL slideshow viewer" off \
KWALLET "Enable KWallet support (requires dbus-glib)" off \
GKEYRING "Enable GNOME Keyring support" off \
@@ -68,6 +69,10 @@ PLIST_FILES+= lib/darktable/plugins/imageio/storage/libflickr.so
CMAKE_ARGS+= -DUSE_FLICKR:BOOL=OFF
.endif
+.if !defined(WITH_RAWSPEED)
+CMAKE_ARGS+= -DDONT_USE_RAWSPEED:BOOL=ON
+.endif
+
.if defined(WITH_SLIDESHOW)
USE_GL= gl
USE_SDL= sdl
@@ -111,6 +116,9 @@ post-patch:
${WRKSRC}/doc/CMakeLists.txt
post-install:
+.if !defined(WITH_RAWSPEED)
+ @${REINPLACE_CMD} -e '/rawspeed/d' ${TMPPLIST}
+.endif
.if !defined(WITH_NLS)
@${REINPLACE_CMD} -e '/LC_MESSAGES/d' ${TMPPLIST}
.endif