aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-27 08:32:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-27 08:32:52 +0000
commitd12ba95837a685a1e251cc499cb22a66860bda0a (patch)
tree64ec5101f3328bf08fcafa907be149ec25fc96ca /graphics/darktable/Makefile
parent9460a949660e403ac20261020a45171ff99411d4 (diff)
downloadports-d12ba95837a685a1e251cc499cb22a66860bda0a.tar.gz
ports-d12ba95837a685a1e251cc499cb22a66860bda0a.zip
Notes
Diffstat (limited to 'graphics/darktable/Makefile')
-rw-r--r--graphics/darktable/Makefile51
1 files changed, 30 insertions, 21 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 0680be4b3c43..c7ea6823671d 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -27,17 +27,23 @@ CMAKE_VERBOSE= yes
USE_GETTEXT= yes
USE_GNOME= librsvg2
USE_SQLITE= yes
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
OPTIONS= GCONF "Enable GConf backend" off \
GPHOTO "Enable camera support via libgphoto2" on \
FLICKR "Enable Flickr support via flickcurl" off \
+ SLIDESHOW "Build OpenGL/SDL slideshow viewer" off \
KWALLET "Enable KWallet support (requires dbus-glib)" off \
- GKEYRING "Enable GNOME Keyring support" off
+ GKEYRING "Enable GNOME Keyring support" off \
+ NLS "Enable Native Language Support" off
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= does not compile on sparc64: invokes i386 assembler
+.endif
.if defined(WITH_GCONF)
USE_GNOME+= gconf2
@@ -60,14 +66,32 @@ CMAKE_ARGS+= -DUSE_CAMERA_SUPPORT:BOOL=OFF
.if defined(WITH_FLICKR)
LIB_DEPENDS+= flickcurl.0:${PORTSDIR}/www/flickcurl
PLIST_FILES+= lib/darktable/plugins/imageio/storage/libflickr.so
+.else
+CMAKE_ARGS+= -DUSE_FLICKR:BOOL=OFF
+.endif
+
+.if defined(WITH_SLIDESHOW)
+USE_GL= gl
+USE_SDL= sdl
+PLIST_FILES+= bin/darktable-viewer
+.else
+CMAKE_ARGS+= -DBUILD_SLIDESHOW:BOOL=OFF
.endif
.if defined(WITH_KWALLET)
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.else
+CMAKE_ARGS+= -DUSE_KWALLET:BOOL=OFF
.endif
.if defined(WITH_GKEYRING)
LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
+.else
+CMAKE_ARGS+= -DUSE_GNOME_KEYRING:BOOL=OFF
+.endif
+
+.if defined(WITHOUT_NLS)
+CMAKE_ARGS+= -DUSE_NLS:BOOL=OFF
.endif
post-patch:
@@ -88,25 +112,10 @@ post-patch:
# Adjust manpages path
@${REINPLACE_CMD} -e 's,share/man/man1,man/man1,' \
${WRKSRC}/doc/CMakeLists.txt
-# Comment out optional components to prevent unregistered dependencies if
-# they are not explicitly selected via OPTIONS (make config)
-.if !defined(WITH_FLICKR)
- @${REINPLACE_CMD} -e '/FLICKCURL/s,^find_package,#&,' \
- ${WRKSRC}/src/CMakeLists.txt
-.endif
-.if !defined(WITH_KWALLET)
- @${REINPLACE_CMD} -e '/DBUSGLIB/s,^find_package,#&,' \
- ${WRKSRC}/src/CMakeLists.txt
-.endif
-.if !defined(WITH_GKEYRING)
- @${REINPLACE_CMD} -e '/GnomeKeyring/s,^find_package,#&,' \
- ${WRKSRC}/src/CMakeLists.txt
-.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: invokes i386 assembler
+post-install:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e '/LC_MESSAGES/d' ${TMPPLIST}
.endif
.include <bsd.port.post.mk>