aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-08-26 17:04:12 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-08-26 17:04:12 +0000
commit8aab4c539eccd5020ee5bc0aefb7a34fa77beb28 (patch)
tree29103a68c136084175ff200bcb27e793ed54c06c /graphics/darktable
parent6e7d674ac16b3d65852bf7ecb728d87bcbb2c7a4 (diff)
downloadports-8aab4c539eccd5020ee5bc0aefb7a34fa77beb28.tar.gz
ports-8aab4c539eccd5020ee5bc0aefb7a34fa77beb28.zip
Notes
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/files/patch-data_CMakeLists.txt38
-rw-r--r--graphics/darktable/files/patch-doc_CMakeLists.txt11
2 files changed, 49 insertions, 0 deletions
diff --git a/graphics/darktable/files/patch-data_CMakeLists.txt b/graphics/darktable/files/patch-data_CMakeLists.txt
new file mode 100644
index 000000000000..0e652732752c
--- /dev/null
+++ b/graphics/darktable/files/patch-data_CMakeLists.txt
@@ -0,0 +1,38 @@
+--- data/CMakeLists.txt.orig 2015-07-26 11:47:47 UTC
++++ data/CMakeLists.txt
+@@ -39,21 +39,21 @@ if(USE_LUA)
+ #
+ # lua system scripts
+ #
+-install(DIRECTORY "lua" DESTINATION ${SHARE_INSTALL}/darktable/)
+-install(FILES luarc DESTINATION ${SHARE_INSTALL}/darktable/)
++install(DIRECTORY "lua" DESTINATION ${SHARE_INSTALL}/darktable)
++install(FILES luarc DESTINATION ${SHARE_INSTALL}/darktable)
+ endif(USE_LUA)
+ #
+ # Install (and generate when necessary) other system shares
+ #
+ file(GLOB PO_FILES "${CMAKE_CURRENT_SOURCE_DIR}/../po/*.po")
+ add_custom_command(
+- OUTPUT darktable.desktop
+- SOURCE darktable.desktop.in
++ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/darktable.desktop
++ SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/darktable.desktop.in
+ COMMAND ${intltool_merge_BIN} -d ${CMAKE_CURRENT_SOURCE_DIR}/../po ${CMAKE_CURRENT_SOURCE_DIR}/darktable.desktop.in ${CMAKE_CURRENT_BINARY_DIR}/darktable.desktop
+ MAIN_DEPENDENCY ${CMAKE_CURRENT_SOURCE_DIR}/darktable.desktop.in
+ DEPENDS ${PO_FILES}
+ )
+-add_custom_target(darktable.desktop ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktable.desktop)
++add_custom_target(darktable.desktop_file ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktable.desktop)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/darktable.desktop DESTINATION ./share/applications)
+ install(FILES darktable.appdata.xml DESTINATION ./share/appdata)
+
+@@ -116,7 +116,7 @@ else(NOT ${Xsltproc_BIN} STREQUAL "Xsltp
+ endif(NOT ${Saxon_BIN} STREQUAL "Saxon_BIN-NOTFOUND")
+ endif(NOT ${Xsltproc_BIN} STREQUAL "Xsltproc_BIN-NOTFOUND")
+
+-add_custom_target(darktablerc ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktablerc)
++add_custom_target(darktablerc_file ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktablerc)
+
+ # first of all install darktablerc file into share as template
+ # postinst script should copy this into users homedirectory
diff --git a/graphics/darktable/files/patch-doc_CMakeLists.txt b/graphics/darktable/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..059cde305adb
--- /dev/null
+++ b/graphics/darktable/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- doc/CMakeLists.txt.orig 2015-07-26 11:47:47 UTC
++++ doc/CMakeLists.txt
+@@ -58,7 +58,7 @@ else(NOT ${Xsltproc_BIN} STREQUAL "Xsltp
+ endif(NOT ${Saxon_BIN} STREQUAL "Saxon_BIN-NOTFOUND")
+ endif(NOT ${Xsltproc_BIN} STREQUAL "Xsltproc_BIN-NOTFOUND")
+
+-add_custom_target(darktablerc.html ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktablerc.html)
++add_custom_target(darktablerc.html_file ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/darktablerc.html)
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/darktablerc.html DESTINATION ${SHARE_INSTALL}/doc/darktable/)
+