aboutsummaryrefslogtreecommitdiff
path: root/graphics/dataplot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/dataplot
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'graphics/dataplot')
-rw-r--r--graphics/dataplot/Makefile2
-rw-r--r--graphics/dataplot/files/Makefile.tmpl16
2 files changed, 9 insertions, 9 deletions
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index 30a51e86de83..485d41e757bb 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -44,7 +44,7 @@ GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
post-extract:
@${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's;%%LOCALBASE%%;${LOCALBASE};g ; \
- s;%%X11BASE%%;${X11BASE};g' \
+ s;%%LOCALBASE%%;${LOCALBASE};g' \
${WRKSRC}/Makefile
@${MV} ${WRKSRC}/gl_src.c ${WRKSRC}/gl_src.c.bogus
diff --git a/graphics/dataplot/files/Makefile.tmpl b/graphics/dataplot/files/Makefile.tmpl
index 9f5a979dd355..7080252bff7c 100644
--- a/graphics/dataplot/files/Makefile.tmpl
+++ b/graphics/dataplot/files/Makefile.tmpl
@@ -1,13 +1,13 @@
-CFLAGS += -I%%LOCALBASE%%/include -I%%X11BASE%%/include
+CFLAGS += -I%%LOCALBASE%%/include
DEST = ${PREFIX}/bin
-EXTHDRS = %%X11BASE%%/include/X11/X.h \
- %%X11BASE%%/include/X11/Xfuncproto.h \
- %%X11BASE%%/include/X11/Xlib.h \
- %%X11BASE%%/include/X11/Xmd.h \
- %%X11BASE%%/include/X11/Xosdefs.h \
- %%X11BASE%%/include/X11/Xutil.h \
+EXTHDRS = %%LOCALBASE%%/include/X11/X.h \
+ %%LOCALBASE%%/include/X11/Xfuncproto.h \
+ %%LOCALBASE%%/include/X11/Xlib.h \
+ %%LOCALBASE%%/include/X11/Xmd.h \
+ %%LOCALBASE%%/include/X11/Xosdefs.h \
+ %%LOCALBASE%%/include/X11/Xutil.h \
%%LOCALBASE%%/include/gd/gd.h \
%%LOCALBASE%%/include/gd/gd_io.h
@@ -17,7 +17,7 @@ INSTALL = install
LD = $(CC)
-LDFLAGS = -L%%LOCALBASE%%/lib -L%%X11BASE%%/lib %%GCCLIBDIR%%
+LDFLAGS = -L%%LOCALBASE%%/lib %%GCCLIBDIR%%
LIBS = -lgd -lpng -ljpeg -lX11 -lz %%FORTRANLIBS%% -lm