aboutsummaryrefslogtreecommitdiff
path: root/graphics/dataplot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 13:36:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 13:36:52 +0000
commit10a5536525312072c344b6caeff9c3e77471abb2 (patch)
tree67184d700ad88c85b82a5190313222c0aed864d6 /graphics/dataplot
parent5e189e8edd4ddd161877610c355b787ca2e59825 (diff)
downloadports-10a5536525312072c344b6caeff9c3e77471abb2.tar.gz
ports-10a5536525312072c344b6caeff9c3e77471abb2.zip
Notes
Diffstat (limited to 'graphics/dataplot')
-rw-r--r--graphics/dataplot/Makefile17
-rw-r--r--graphics/dataplot/distinfo6
-rw-r--r--graphics/dataplot/files/Makefile.tmpl4
-rw-r--r--graphics/dataplot/pkg-plist2
4 files changed, 18 insertions, 11 deletions
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index 849a660f2f78..398b944fdb03 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= dataplot
-PORTVERSION= 20070224
+PORTVERSION= 20080225
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.nist.gov/pub/dataplot/unix/:source \
LOCAL/beech:source \
http://www.itl.nist.gov/div898/software/dataplot.html/:doc \
LOCAL/beech:doc
-DISTFILES= dpsrc.02_24_2007${EXTRACT_SUFX}:source \
+DISTFILES= dpsrc.02_25_2008${EXTRACT_SUFX}:source \
dpsnapsh.pdf:doc
DIST_SUBDIR= dataplot
-EXTRACT_ONLY= dpsrc.02_24_2007${EXTRACT_SUFX}
+EXTRACT_ONLY= dpsrc.02_25_2008${EXTRACT_SUFX}
MAINTAINER= beech@FreeBSD.org
COMMENT= A free software system for statistical visualization
@@ -28,7 +28,7 @@ USE_FORTRAN= yes
FFLAGS+= -fno-range-check
USE_XORG= x11 xi
NO_WRKSUBDIR= yes
-MAXOBV?= 100000 # Change if you need more observations/variable
+MAXOBV?= 1000000 # Change if you need more observations/variable
.include <bsd.port.pre.mk>
@@ -37,11 +37,16 @@ post-extract:
@${REINPLACE_CMD} -e 's;%%LOCALBASE%%;${LOCALBASE};g ; \
s;%%LOCALBASE%%;${LOCALBASE};g' \
${WRKSRC}/Makefile
- @${MV} ${WRKSRC}/gl_src.c ${WRKSRC}/gl_src.c.bogus
+ @${MV} ${WRKSRC}/aqua_src.c ${WRKSRC}/aqua_src.c.nop
+ @${MV} ${WRKSRC}/gl_src.c ${WRKSRC}/gl_src.c.nop
pre-patch:
- @${REINPLACE_CMD} -e 's/MAXOBV=100000/MAXOBV=${MAXOBV}/' \
+ @${REINPLACE_CMD} -e 's/MAXOBV=1000000/MAXOBV=${MAXOBV}/' \
${WRKSRC}/DPCOPA.INC
+.if ((${ARCH}=="amd64") || (${ARCH}=="sparc64") || (${ARCH}=="ia64"))
+ @${REINPLACE_CMD} -e 's;dp1_linux;dp1_linux_dp;g' \
+ ${WRKSRC}/Makefile
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/dataplot/distinfo b/graphics/dataplot/distinfo
index 72b8f6576192..b2afb260afef 100644
--- a/graphics/dataplot/distinfo
+++ b/graphics/dataplot/distinfo
@@ -1,6 +1,6 @@
-MD5 (dataplot/dpsrc.02_24_2007.tar.gz) = 5e8018c142930e8c69a6e8595822d936
-SHA256 (dataplot/dpsrc.02_24_2007.tar.gz) = dce39fb484c191f96d8776dcfeb7f1a257cfd04cb0ab2da2255bff816517efa9
-SIZE (dataplot/dpsrc.02_24_2007.tar.gz) = 6154582
+MD5 (dataplot/dpsrc.02_25_2008.tar.gz) = dfbc53609c1fd0b9785af5eb876663b4
+SHA256 (dataplot/dpsrc.02_25_2008.tar.gz) = 794bedcc48cf444c5813f864f4bacb158474d450337279edaf7fba1055c552c6
+SIZE (dataplot/dpsrc.02_25_2008.tar.gz) = 6399167
MD5 (dataplot/dpsnapsh.pdf) = 88ca193586405a71387abbeba9be9f0e
SHA256 (dataplot/dpsnapsh.pdf) = 4854cdab00ce10df87686eb025a80f57575fea1b362a22b49f202e10348f0e4b
SIZE (dataplot/dpsnapsh.pdf) = 62085
diff --git a/graphics/dataplot/files/Makefile.tmpl b/graphics/dataplot/files/Makefile.tmpl
index 0462e8b5592f..0251ecb148f8 100644
--- a/graphics/dataplot/files/Makefile.tmpl
+++ b/graphics/dataplot/files/Makefile.tmpl
@@ -80,6 +80,7 @@ OBJS = dp1_linux.o \
edwrst.o \
fit3b.o \
gl_src.o \
+ aqua_src.o \
starpac.o \
tcdriv_nopc.o \
gd_src.o \
@@ -88,7 +89,7 @@ OBJS = dp1_linux.o \
PRINT = pr
-PROGRAM = dp
+PROGRAM = dataplot
SHELL = /bin/sh
@@ -149,6 +150,7 @@ SRCS = dp1_linux.f \
edwrst.f \
fit3b.f \
gl_src.f \
+ aqua_src.f \
starpac.f \
tcdriv_nopc.f \
gd_src.c \
diff --git a/graphics/dataplot/pkg-plist b/graphics/dataplot/pkg-plist
index d0b3e3fd18b8..5ffcd8bf6588 100644
--- a/graphics/dataplot/pkg-plist
+++ b/graphics/dataplot/pkg-plist
@@ -1,3 +1,3 @@
-bin/dp
+bin/dataplot
%%PORTDOCS%%%%DOCSDIR%%/dpsnapsh.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%