aboutsummaryrefslogtreecommitdiff
path: root/graphics/dcp2icc/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 10:52:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 10:52:59 +0000
commitae92b351fb808d0b190efe34ad61364bc63439bd (patch)
tree0d9c83b50c66d9790e12a1907b0eeb394b20ad55 /graphics/dcp2icc/Makefile
parentfc111cf1ceb849a8caa80f449e88fc0f6a4584bf (diff)
downloadports-ae92b351fb808d0b190efe34ad61364bc63439bd.tar.gz
ports-ae92b351fb808d0b190efe34ad61364bc63439bd.zip
Notes
Diffstat (limited to 'graphics/dcp2icc/Makefile')
-rw-r--r--graphics/dcp2icc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/dcp2icc/Makefile b/graphics/dcp2icc/Makefile
index 52778e9b197a..fbf207862b93 100644
--- a/graphics/dcp2icc/Makefile
+++ b/graphics/dcp2icc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dcp2icc
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= graphics converters
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Version%20${PORTVERSION}
@@ -25,10 +26,14 @@ post-extract:
@${UNZIP_NATIVE_CMD} -qo ${WRKSRC}/dng_sdk_1_2.zip -d ${WRKSRC}
post-patch:
- @${RM} -f ${WRKSRC}/fixes/XMP-Toolkit/XMPFiles.hpp \
- ${WRKSRC}/fixes/XMP-Toolkit/LargeFileAccess.hpp
+ @${MV} -f ${WRKSRC}/fixes/XMP-Toolkit/XMPFiles.hpp \
+ ${WRKSRC}/XMP-Toolkit-SDK-4.4.2/source/XMPFiles
+ @${MV} -f ${WRKSRC}/fixes/XMP-Toolkit/LargeFileAccess.hpp \
+ ${WRKSRC}/XMP-Toolkit-SDK-4.4.2/source/common
@${MV} -f ${WRKSRC}/fixes/dng_sdk/dng_hue_sat_map.h \
${WRKSRC}/dng_sdk_1_2/dng_sdk/source
+ @${REINPLACE_CMD} -e '/mimetype/s,delete,&[],' \
+ ${WRKSRC}/XMP-Toolkit-SDK-4.4.2/source/XMPFiles/FileHandlers/UCF_Handler.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin