aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wcs
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-15 03:38:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-15 03:38:10 +0000
commit4656494a6a9f43737de4abaff7aea1135a0fb24b (patch)
tree69a0d764edbc4f57318a32c19e2422a2f7d61dd1 /graphics/deegree-wcs
parent01ea96429585fa814ef3d490926dd4e31f445487 (diff)
downloadports-4656494a6a9f43737de4abaff7aea1135a0fb24b.tar.gz
ports-4656494a6a9f43737de4abaff7aea1135a0fb24b.zip
Notes
Diffstat (limited to 'graphics/deegree-wcs')
-rw-r--r--graphics/deegree-wcs/Makefile17
-rw-r--r--graphics/deegree-wcs/pkg-plist2
2 files changed, 6 insertions, 13 deletions
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index 8b88ae771c20..6eb81b72d260 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -21,16 +21,13 @@ APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= README.txt deegree_wcs_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-wcs
-PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||} WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
SUB_LIST= TCPORT=${TCPORT}
OPTIONS_SINGLE= AS
OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -55,13 +52,9 @@ post-extract:
do-install:
cd ${WRKDIR} && \
- ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
- @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/deegree-wcs/pkg-plist b/graphics/deegree-wcs/pkg-plist
index 0388e6a6050f..1208e309d7ba 100644
--- a/graphics/deegree-wcs/pkg-plist
+++ b/graphics/deegree-wcs/pkg-plist
@@ -1,3 +1,4 @@
+@exec chown %%WWWOWN%%:%%WWWGRP%% %D/%%TOMCATDIR%%/webapps/deegree-wcs
%%TOMCATDIR%%/webapps/deegree-wcs/META-INF/MANIFEST.MF
%%TOMCATDIR%%/webapps/deegree-wcs/WEB-INF/classes/log4j.properties
%%TOMCATDIR%%/webapps/deegree-wcs/WEB-INF/conf/wcs/wcs_configuration.xml
@@ -2170,4 +2171,3 @@
@dirrm %%TOMCATDIR%%/webapps/deegree-wcs/WEB-INF
@dirrm %%TOMCATDIR%%/webapps/deegree-wcs/META-INF
@dirrm %%TOMCATDIR%%/webapps/deegree-wcs
-@dirrm %%TOMCATDIR%%/webapps