aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wfs/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:20:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:20:31 +0000
commit5915b00d97b817ee161c3b548a991fda2ac8d4c5 (patch)
tree99210397833917fe8b530459faa1c670fd6cc37b /graphics/deegree-wfs/Makefile
parent9780f18e7f2324c2172ca352710e00c7e81ba224 (diff)
downloadports-5915b00d97b817ee161c3b548a991fda2ac8d4c5.tar.gz
ports-5915b00d97b817ee161c3b548a991fda2ac8d4c5.zip
Notes
Diffstat (limited to 'graphics/deegree-wfs/Makefile')
-rw-r--r--graphics/deegree-wfs/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
new file mode 100644
index 000000000000..5e4636b7bf34
--- /dev/null
+++ b/graphics/deegree-wfs/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-wfs
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= wfs
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Deegree Web Feature Service(WFS)
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-wfs
+PLIST_FILES= ${TOMCATVER}/webapps/deegree-wfs.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 deegree-wfs.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_WFS.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_wfs_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>