aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wfs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:20:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:20:31 +0000
commit5915b00d97b817ee161c3b548a991fda2ac8d4c5 (patch)
tree99210397833917fe8b530459faa1c670fd6cc37b /graphics/deegree-wfs
parent9780f18e7f2324c2172ca352710e00c7e81ba224 (diff)
downloadports-5915b00d97b817ee161c3b548a991fda2ac8d4c5.tar.gz
ports-5915b00d97b817ee161c3b548a991fda2ac8d4c5.zip
Notes
Diffstat (limited to 'graphics/deegree-wfs')
-rw-r--r--graphics/deegree-wfs/Makefile46
-rw-r--r--graphics/deegree-wfs/distinfo3
-rw-r--r--graphics/deegree-wfs/pkg-descr5
-rw-r--r--graphics/deegree-wfs/pkg-message10
4 files changed, 64 insertions, 0 deletions
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
new file mode 100644
index 000000000000..5e4636b7bf34
--- /dev/null
+++ b/graphics/deegree-wfs/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-wfs
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= wfs
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Deegree Web Feature Service(WFS)
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-wfs
+PLIST_FILES= ${TOMCATVER}/webapps/deegree-wfs.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 deegree-wfs.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_WFS.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_wfs_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/deegree-wfs/distinfo b/graphics/deegree-wfs/distinfo
new file mode 100644
index 000000000000..d83a6c132622
--- /dev/null
+++ b/graphics/deegree-wfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (deegree-wfs_v2_2.zip) = db012aad4fb970ab559af289fc66b0f2
+SHA256 (deegree-wfs_v2_2.zip) = f42b48d3b98fcd9fbf155f47afd81ad82e6300a6aa800c316c419182598e36be
+SIZE (deegree-wfs_v2_2.zip) = 18385899
diff --git a/graphics/deegree-wfs/pkg-descr b/graphics/deegree-wfs/pkg-descr
new file mode 100644
index 000000000000..0e1b1aa81e88
--- /dev/null
+++ b/graphics/deegree-wfs/pkg-descr
@@ -0,0 +1,5 @@
+Deegree's WFS is able to serve vector and attribute data from different
+data sources (backends) and deliver it to any client that is able to
+perform WFS compliant HTTP-GET or POST requests.
+
+WWW: http://www.deegree.org/
diff --git a/graphics/deegree-wfs/pkg-message b/graphics/deegree-wfs/pkg-message
new file mode 100644
index 000000000000..13df82f03621
--- /dev/null
+++ b/graphics/deegree-wfs/pkg-message
@@ -0,0 +1,10 @@
+==========================================================================
+To start DeeGree correctly, please set the variable JAVA_OPTS with:
+
+setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
+
+Now you should start your Tomcat server and browse with:
+ http://your-server:8180/deegree-wcs
+
+Enjoy it !
+==========================================================================