aboutsummaryrefslogtreecommitdiff
path: root/graphics/dia/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-12 12:05:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-12 12:05:25 +0000
commit006b931300723b014d3494f00990d6d063454579 (patch)
tree9770bac971dac2abaaab731ab6b690f501360df1 /graphics/dia/files
parentc4c9fbc301f94dbdd60abd678b9973480de2eb11 (diff)
Notes
Diffstat (limited to 'graphics/dia/files')
-rw-r--r--graphics/dia/files/patch-ab36
-rw-r--r--graphics/dia/files/patch-ad42
-rw-r--r--graphics/dia/files/patch-objects::GRAFCET::boolequation.c23
-rw-r--r--graphics/dia/files/patch-po::Makefile.in.in7
4 files changed, 27 insertions, 81 deletions
diff --git a/graphics/dia/files/patch-ab b/graphics/dia/files/patch-ab
deleted file mode 100644
index 7f3e78cb3539..000000000000
--- a/graphics/dia/files/patch-ab
+++ /dev/null
@@ -1,36 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Tue May 14 02:45:54 2002
-+++ Makefile.in Tue May 14 02:47:55 2002
-@@ -159,7 +159,8 @@
- pixmapdir = $(gnomedatadir)/pixmaps
- pixmap_DATA = dia_gnome_icon.png dia-diagram.png
-
--Applicationsdir = $(gnomedatadir)/gnome/apps/Applications
-+ifdef HAVE_GNOME
-+Applicationsdir = $(gnomedatadir)/apps/Applications
- applications_in_files = dia.desktop.in
- Applications_DATA = $(applications_in_files:.desktop.in=.desktop)
-
-@@ -167,6 +168,7 @@
-
- mimedir = $(gnomedatadir)/mime-info
- mime_DATA = dia.mime dia.keys
-+endif
-
- EXTRA_DIST = dia.xpm dia_gnome_icon.png dia_gnome_menu_icon.png dia.desktop.in dia.spec KNOWN_BUGS $(pkgdata_DATA) $(man_MANS) dia-diagram.png dia.mime dia.keys.in core-translation-report po-checktrans.py po-checktrans intltool-extract.in intltool-merge.in intltool-update.in RELEASE-PROCESS
-
-@@ -511,8 +513,12 @@
- install-exec-am:
- install-exec: install-exec-recursive
-
-+ifdef HAVE_GNOME
- install-data-am: install-man install-ApplicationsDATA install-mimeDATA \
- install-pixmapDATA install-pkgdataDATA
-+else
-+install-data-am: install-man install-pkgdataDATA
-+endif
- install-data: install-data-recursive
-
- install-am: all-am
diff --git a/graphics/dia/files/patch-ad b/graphics/dia/files/patch-ad
index b7161d4b6567..d6c279a24ab4 100644
--- a/graphics/dia/files/patch-ad
+++ b/graphics/dia/files/patch-ad
@@ -1,34 +1,9 @@
$FreeBSD$
---- configure.orig Mon Jun 3 00:34:03 2002
-+++ configure Mon Jun 3 00:34:24 2002
-@@ -3651,8 +3651,23 @@
- done
-
-
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-
--
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
- # Only perform the check for file, if the check method requires it
- case $deplibs_check_method in
-@@ -7118,12 +7133,14 @@
+--- configure.orig Sat Jun 1 10:40:13 2002
++++ configure Fri Jul 12 13:52:26 2002
+@@ -7118,6 +7118,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -36,16 +11,7 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-
--# Prevent multiple expansion
--
-+# Redirect the config.log output again, so that the ltconfig log is not
-+# clobbered by the next message.
-+exec 5>>./config.log
-
-
- echo "$as_me:$LINENO: checking whether build environment is sane" >&5
-@@ -7911,7 +7928,7 @@
+@@ -7911,7 +7912,7 @@
OLDCPPFLAGS=$CPPFLAGS
diff --git a/graphics/dia/files/patch-objects::GRAFCET::boolequation.c b/graphics/dia/files/patch-objects::GRAFCET::boolequation.c
new file mode 100644
index 000000000000..6cccd75ed6d9
--- /dev/null
+++ b/graphics/dia/files/patch-objects::GRAFCET::boolequation.c
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- objects/GRAFCET/boolequation.c 2002/07/12 11:18:01 1.1
++++ objects/GRAFCET/boolequation.c 2002/07/12 11:24:38
+@@ -64,7 +64,7 @@
+
+
+ /* utility */
+-inline static gboolean isspecial(unichar c)
++inline static gboolean dia_isspecial(unichar c)
+ {
+ switch (c) {
+ case '!':
+@@ -141,7 +141,7 @@
+ c = g_utf8_get_char(*str);
+ p1 = g_utf8_next_char(*str);
+ #endif
+- if (isspecial(c)) break;
++ if (dia_isspecial(c)) break;
+ *str = p1;
+ }
+
diff --git a/graphics/dia/files/patch-po::Makefile.in.in b/graphics/dia/files/patch-po::Makefile.in.in
deleted file mode 100644
index e803022425f7..000000000000
--- a/graphics/dia/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- po/Makefile.in.in.orig Fri May 18 21:28:07 2001
-+++ po/Makefile.in.in Sun May 20 17:35:29 2001
-@@ -22,3 +22,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po