aboutsummaryrefslogtreecommitdiff
path: root/graphics/dia
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-06-03 11:30:43 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-06-03 11:30:43 +0000
commita71748ab3ef0da54dc9890a522b1b3e8798672cd (patch)
treee7a2f319a581277d69b18c55444b4f66a9da8809 /graphics/dia
parentd002ec96fde51e0becb7b4c0d7efc7a9e587a5da (diff)
downloadports-a71748ab3ef0da54dc9890a522b1b3e8798672cd.tar.gz
ports-a71748ab3ef0da54dc9890a522b1b3e8798672cd.zip
Notes
Diffstat (limited to 'graphics/dia')
-rw-r--r--graphics/dia/Makefile3
-rw-r--r--graphics/dia/distinfo2
-rw-r--r--graphics/dia/files/patch-ab31
-rw-r--r--graphics/dia/files/patch-ad35
-rw-r--r--graphics/dia/files/patch-af57
-rw-r--r--graphics/dia/files/patch-lib::charconv.c15
-rw-r--r--graphics/dia/files/patch-lib::font.c15
-rw-r--r--graphics/dia/pkg-plist123
8 files changed, 192 insertions, 89 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 4675a036a728..a013da98e28b 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dia
-PORTVERSION= 0.88.1
-PORTREVISION= 1
+PORTVERSION= 0.90
CATEGORIES+= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/dia
diff --git a/graphics/dia/distinfo b/graphics/dia/distinfo
index 73c5990d9a42..3d1705d507f6 100644
--- a/graphics/dia/distinfo
+++ b/graphics/dia/distinfo
@@ -1 +1 @@
-MD5 (dia-0.88.1.tar.gz) = 66a8017a9a93efe08c658f0a29838724
+MD5 (dia-0.90.tar.gz) = 62c80b2492e2b7d92bfbe360f46c157a
diff --git a/graphics/dia/files/patch-ab b/graphics/dia/files/patch-ab
index bdf4e05a4547..7f3e78cb3539 100644
--- a/graphics/dia/files/patch-ab
+++ b/graphics/dia/files/patch-ab
@@ -1,21 +1,36 @@
---- Makefile.in.orig Fri May 11 05:04:49 2001
-+++ Makefile.in Thu May 17 14:28:56 2001
-@@ -154,3 +154,4 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Tue May 14 02:45:54 2002
++++ Makefile.in Tue May 14 02:47:55 2002
+@@ -159,7 +159,8 @@
+ pixmapdir = $(gnomedatadir)/pixmaps
+ pixmap_DATA = dia_gnome_icon.png dia-diagram.png
-Applicationsdir = $(gnomedatadir)/gnome/apps/Applications
+ifdef HAVE_GNOME
+Applicationsdir = $(gnomedatadir)/apps/Applications
- Applications_DATA = dia.desktop
-@@ -159,2 +160,3 @@
+ applications_in_files = dia.desktop.in
+ Applications_DATA = $(applications_in_files:.desktop.in=.desktop)
+
+@@ -167,6 +168,7 @@
+
+ mimedir = $(gnomedatadir)/mime-info
mime_DATA = dia.mime dia.keys
+endif
-@@ -556,4 +558,8 @@
+ EXTRA_DIST = dia.xpm dia_gnome_icon.png dia_gnome_menu_icon.png dia.desktop.in dia.spec KNOWN_BUGS $(pkgdata_DATA) $(man_MANS) dia-diagram.png dia.mime dia.keys.in core-translation-report po-checktrans.py po-checktrans intltool-extract.in intltool-merge.in intltool-update.in RELEASE-PROCESS
+
+@@ -511,8 +513,12 @@
+ install-exec-am:
+ install-exec: install-exec-recursive
+ifdef HAVE_GNOME
- install-data-am: install-ApplicationsDATA install-man install-mimeDATA \
- install-pixmapDATA install-pkgdataDATA
+ install-data-am: install-man install-ApplicationsDATA install-mimeDATA \
+ install-pixmapDATA install-pkgdataDATA
+else
+install-data-am: install-man install-pkgdataDATA
+endif
+ install-data: install-data-recursive
+ install-am: all-am
diff --git a/graphics/dia/files/patch-ad b/graphics/dia/files/patch-ad
index 5dbe20742fc4..b7161d4b6567 100644
--- a/graphics/dia/files/patch-ad
+++ b/graphics/dia/files/patch-ad
@@ -1,9 +1,12 @@
---- configure.orig Fri May 11 04:08:46 2001
-+++ configure Thu May 17 15:59:22 2001
-@@ -5296,4 +5296,19 @@
+
+$FreeBSD$
+
+--- configure.orig Mon Jun 3 00:34:03 2002
++++ configure Mon Jun 3 00:34:24 2002
+@@ -3651,8 +3651,23 @@
+ done
+
--
--
+# Actually configure libtool. ac_aux_dir is where install-sh is found.
+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
@@ -12,7 +15,8 @@
+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
+
+-
+# Reload cache, that may have been modified by ltconfig
+if test -r "$cache_file"; then
+ echo "loading cache $cache_file"
@@ -22,7 +26,16 @@
+ > $cache_file
+fi
-@@ -5306,4 +5321,5 @@
+ # Only perform the check for file, if the check method requires it
+ case $deplibs_check_method in
+@@ -7118,12 +7133,14 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-# Prevent multiple expansion
-
@@ -30,8 +43,14 @@
+# clobbered by the next message.
+exec 5>>./config.log
-@@ -6197,3 +6213,3 @@
+
+ echo "$as_me:$LINENO: checking whether build environment is sane" >&5
+@@ -7911,7 +7928,7 @@
+
+
OLDCPPFLAGS=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS `glib-config --cflags`"
+CPPFLAGS="$CPPFLAGS `$GLIB_CONFIG --cflags`"
+
+ echo "$as_me:$LINENO: checking for nl_langinfo and CODESET" >&5
diff --git a/graphics/dia/files/patch-af b/graphics/dia/files/patch-af
index d80742a8c04f..6f70ae98769e 100644
--- a/graphics/dia/files/patch-af
+++ b/graphics/dia/files/patch-af
@@ -1,30 +1,53 @@
---- app/Makefile.in.orig Sat May 19 01:04:11 2001
-+++ app/Makefile.in Sun May 20 18:55:59 2001
-@@ -177,4 +177,2 @@
+
+$FreeBSD$
+
+--- app/Makefile.in.orig Tue May 14 02:48:53 2002
++++ app/Makefile.in Tue May 14 02:51:06 2002
+@@ -164,8 +164,6 @@
+ @HAVE_BONOBO_TRUE@dia_oafinfo = GNOME_Dia.oaf
+ @HAVE_BONOBO_FALSE@dia_oafinfo =
-bin_PROGRAMS = dia $(dia_embedd)
-
oafinfodir = $(datadir)/oaf
-@@ -336,4 +334,4 @@
- CONFIG_CLEAN_FILES =
--@HAVE_BONOBO_TRUE@bin_PROGRAMS = dia$(EXEEXT) dia-embedd$(EXEEXT)
--@HAVE_BONOBO_FALSE@bin_PROGRAMS = dia$(EXEEXT)
-+@HAVE_BONOBO_TRUE@bin_PROGRAMS = dia-bin$(EXEEXT) dia-embedd$(EXEEXT)
-+@HAVE_BONOBO_FALSE@bin_PROGRAMS = dia-bin$(EXEEXT)
- noinst_PROGRAMS = run_dia.sh
-@@ -553,2 +551,5 @@
+ oafinfo_DATA = $(dia_oafinfo)
+
+@@ -199,8 +197,8 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
+-@HAVE_BONOBO_TRUE@bin_PROGRAMS = dia$(EXEEXT) dia-embedd$(EXEEXT)
+-@HAVE_BONOBO_FALSE@bin_PROGRAMS = dia$(EXEEXT)
++@HAVE_BONOBO_TRUE@bin_PROGRAMS = dia-bin$(EXEEXT) dia-embedd$(EXEEXT)
++@HAVE_BONOBO_FALSE@bin_PROGRAMS = dia-bin$(EXEEXT)
+ noinst_PROGRAMS = run_dia.sh run_diaconv.sh diaconv$(EXEEXT)
+ PROGRAMS = $(bin_PROGRAMS) $(noinst_PROGRAMS)
+
+@@ -532,6 +530,9 @@
+ @rm -f dia$(EXEEXT)
+ $(LINK) $(dia_LDFLAGS) $(dia_OBJECTS) $(dia_LDADD) $(LIBS)
+dia-bin$(EXEEXT): dia$(EXEEXT)
+ cp dia$(EXEEXT) dia-bin$(EXEEXT)
+
dia-embedd$(EXEEXT): $(dia_embedd_OBJECTS) $(dia_embedd_DEPENDENCIES)
-@@ -707,3 +708,3 @@
- installdirs:
-- $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(oafinfodir)
-+ $(mkinstalldirs) $(DESTDIR)$(bindir)
-
-@@ -753,3 +754,3 @@
+ @rm -f dia-embedd$(EXEEXT)
+ $(LINK) $(dia_embedd_LDFLAGS) $(dia_embedd_OBJECTS) $(dia_embedd_LDADD) $(LIBS)
+@@ -1137,7 +1138,7 @@
+ install-exec-am: install-binPROGRAMS
+ install-exec: install-exec-am
-install-data-am: install-oafinfoDATA
+install-data-am:
+ install-data: install-data-am
+
+ install-am: all-am
+@@ -1150,7 +1151,7 @@
+ install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
+ installdirs:
+- $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(oafinfodir)
++ $(mkinstalldirs) $(DESTDIR)$(bindir)
+
+ mostlyclean-generic:
diff --git a/graphics/dia/files/patch-lib::charconv.c b/graphics/dia/files/patch-lib::charconv.c
new file mode 100644
index 000000000000..ee085c256d35
--- /dev/null
+++ b/graphics/dia/files/patch-lib::charconv.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- lib/charconv.c 2002/06/03 07:54:31 1.1
++++ lib/charconv.c 2002/06/03 08:10:29
+@@ -98,7 +98,8 @@
+
+ if ((*charset == NULL) ||
+ (0==strcmp(*charset,"US-ASCII")) ||
+- (0==strcmp(*charset,"ANSI_X3.4-1968"))) {
++ (0==strcmp(*charset,"ANSI_X3.4-1968")) ||
++ (**charset == '\0')) {
+ /* we got basic stupid ASCII here. We use its sane
+ superset instead. Especially since libxml2 doesn't like
+ the pedantic name of ASCII. */
diff --git a/graphics/dia/files/patch-lib::font.c b/graphics/dia/files/patch-lib::font.c
new file mode 100644
index 000000000000..f6f9ec7ce9a7
--- /dev/null
+++ b/graphics/dia/files/patch-lib::font.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- lib/font.c 2002/06/03 08:27:47 1.1
++++ lib/font.c 2002/06/03 08:34:08
+@@ -467,7 +467,8 @@
+
+ char *last_resort_fonts[] = {
+ "-adobe-courier-medium-r-normal-*-%d-*-*-*-*-*-*-*",
+-#ifndef G_OS_WIN32
++ "-*-courier-medium-r-normal-*-%d-*-*-*-*-*-*-*",
++#ifdef G_OS_WIN32
+ "system" /* Must be last. This is guaranteed to exist on a MS-Windows
+ system. */
+ #else
diff --git a/graphics/dia/pkg-plist b/graphics/dia/pkg-plist
index 93976dcf778f..96c8eea41faf 100644
--- a/graphics/dia/pkg-plist
+++ b/graphics/dia/pkg-plist
@@ -4,23 +4,22 @@ lib/dia/libcgm_filter.so
lib/dia/libchronogram_objects.so
lib/dia/libcustom_objects.so
lib/dia/libdxf_filter.so
-lib/dia/libeml_objects.so
lib/dia/liber_objects.so
lib/dia/libflowchart_objects.so
lib/dia/libfs_objects.so
lib/dia/libgrafcet_objects.so
lib/dia/libhpgl_filter.so
+lib/dia/libmetapost_filter.so
lib/dia/libnetwork_objects.so
lib/dia/libpstricks_filter.so
lib/dia/libsadt_objects.so
lib/dia/libshape_filter.so
lib/dia/libstandard_objects.so
lib/dia/libsvg_filter.so
-lib/dia/libsybase_objects.so
lib/dia/libuml_objects.so
lib/dia/libwpg_filter.so
lib/dia/libxfig_filter.so
-%%GNOME:%%share/gnome/apps/Applications/dia.desktop
+share/gnome/apps/Applications/dia.desktop
share/gnome/dia/dia_logo.png
share/gnome/dia/shapes/Circuit/ground.shape
share/gnome/dia/shapes/Circuit/ground.xpm
@@ -47,6 +46,8 @@ share/gnome/dia/shapes/Circuit/hzener.shape
share/gnome/dia/shapes/Circuit/hzener.xpm
share/gnome/dia/shapes/Circuit/lamp_de.shape
share/gnome/dia/shapes/Circuit/lamp_de.xpm
+share/gnome/dia/shapes/Circuit/microphone_de.shape
+share/gnome/dia/shapes/Circuit/microphone_de.xpm
share/gnome/dia/shapes/Circuit/nmos_de.shape
share/gnome/dia/shapes/Circuit/nmos_de.xpm
share/gnome/dia/shapes/Circuit/npn.shape
@@ -257,12 +258,34 @@ share/gnome/dia/shapes/MSE/small_extension_node.shape
share/gnome/dia/shapes/MSE/small_extension_node.xpm
share/gnome/dia/shapes/MSE/tacsat.shape
share/gnome/dia/shapes/MSE/tacsat.xpm
+share/gnome/dia/shapes/Misc/file.png
+share/gnome/dia/shapes/Misc/file.shape
+share/gnome/dia/shapes/Misc/folder.png
+share/gnome/dia/shapes/Misc/folder.shape
+share/gnome/dia/shapes/Network/antenna.shape
+share/gnome/dia/shapes/Network/antenna.xpm
+share/gnome/dia/shapes/Network/computer.shape
+share/gnome/dia/shapes/Network/computer.xpm
share/gnome/dia/shapes/Network/dat_external.shape
share/gnome/dia/shapes/Network/dat_external.xpm
+share/gnome/dia/shapes/Network/disc.shape
+share/gnome/dia/shapes/Network/disc.xpm
share/gnome/dia/shapes/Network/diskette.shape
share/gnome/dia/shapes/Network/diskette.xpm
+share/gnome/dia/shapes/Network/firewall.shape
+share/gnome/dia/shapes/Network/firewall.xpm
+share/gnome/dia/shapes/Network/flash.shape
+share/gnome/dia/shapes/Network/flash.xpm
+share/gnome/dia/shapes/Network/genmonitor.shape
+share/gnome/dia/shapes/Network/genmonitor.xpm
+share/gnome/dia/shapes/Network/hub.shape
+share/gnome/dia/shapes/Network/hub.xpm
share/gnome/dia/shapes/Network/mobile_phone.shape
share/gnome/dia/shapes/Network/mobile_phone.xpm
+share/gnome/dia/shapes/Network/modem.shape
+share/gnome/dia/shapes/Network/modem.xpm
+share/gnome/dia/shapes/Network/modularswitch.shape
+share/gnome/dia/shapes/Network/modularswitch.xpm
share/gnome/dia/shapes/Network/monitor.shape
share/gnome/dia/shapes/Network/monitor.xpm
share/gnome/dia/shapes/Network/nwcloud.shape
@@ -275,8 +298,14 @@ share/gnome/dia/shapes/Network/pc_miditower.shape
share/gnome/dia/shapes/Network/pc_miditower.xpm
share/gnome/dia/shapes/Network/pc_minitower.shape
share/gnome/dia/shapes/Network/pc_minitower.xpm
+share/gnome/dia/shapes/Network/printer.shape
+share/gnome/dia/shapes/Network/printer.xpm
+share/gnome/dia/shapes/Network/rj45plug.shape
+share/gnome/dia/shapes/Network/rj45plug.xpm
share/gnome/dia/shapes/Network/router-symbol.shape
share/gnome/dia/shapes/Network/router-symbol.xpm
+share/gnome/dia/shapes/Network/sceadplug.shape
+share/gnome/dia/shapes/Network/sceadplug.xpm
share/gnome/dia/shapes/Network/speaker.shape
share/gnome/dia/shapes/Network/speaker.xpm
share/gnome/dia/shapes/Network/speaker_amp.shape
@@ -285,6 +314,8 @@ share/gnome/dia/shapes/Network/switch-atm-symbol.shape
share/gnome/dia/shapes/Network/switch-atm-symbol.xpm
share/gnome/dia/shapes/Network/switch-symbol.shape
share/gnome/dia/shapes/Network/switch-symbol.xpm
+share/gnome/dia/shapes/Network/telephone.png
+share/gnome/dia/shapes/Network/telephone.shape
share/gnome/dia/shapes/Network/workstation.shape
share/gnome/dia/shapes/Network/workstation.xpm
share/gnome/dia/shapes/Network/zip-disk.shape
@@ -303,6 +334,8 @@ share/gnome/dia/shapes/Pneumatic/compilh.shape
share/gnome/dia/shapes/Pneumatic/compilh.xpm
share/gnome/dia/shapes/Pneumatic/compilp.shape
share/gnome/dia/shapes/Pneumatic/compilp.xpm
+share/gnome/dia/shapes/Pneumatic/compush.shape
+share/gnome/dia/shapes/Pneumatic/compush.xpm
share/gnome/dia/shapes/Pneumatic/comspr.shape
share/gnome/dia/shapes/Pneumatic/comspr.xpm
share/gnome/dia/shapes/Pneumatic/dejack.shape
@@ -393,6 +426,18 @@ share/gnome/dia/shapes/jigsaw/part_oooi.shape
share/gnome/dia/shapes/jigsaw/part_oooi.xpm
share/gnome/dia/shapes/jigsaw/part_oooo.shape
share/gnome/dia/shapes/jigsaw/part_oooo.xpm
+share/gnome/dia/shapes/sybase/client.shape
+share/gnome/dia/shapes/sybase/client.xpm
+share/gnome/dia/shapes/sybase/dataserver.shape
+share/gnome/dia/shapes/sybase/dataserver.xpm
+share/gnome/dia/shapes/sybase/ltm.shape
+share/gnome/dia/shapes/sybase/ltm.xpm
+share/gnome/dia/shapes/sybase/repserver.shape
+share/gnome/dia/shapes/sybase/repserver.xpm
+share/gnome/dia/shapes/sybase/rsm.shape
+share/gnome/dia/shapes/sybase/rsm.xpm
+share/gnome/dia/shapes/sybase/stableq.shape
+share/gnome/dia/shapes/sybase/stableq.xpm
share/gnome/dia/sheets/Circuit.sheet
share/gnome/dia/sheets/Contact.sheet
share/gnome/dia/sheets/EML.sheet
@@ -410,6 +455,7 @@ share/gnome/dia/sheets/GRAFCET/etapesp.xpm
share/gnome/dia/sheets/GRAFCET/vergent_and.xpm
share/gnome/dia/sheets/Logic.sheet
share/gnome/dia/sheets/MSE.sheet
+share/gnome/dia/sheets/Misc.sheet
share/gnome/dia/sheets/Pneumatic.sheet
share/gnome/dia/sheets/SADT.sheet
share/gnome/dia/sheets/SDL.sheet
@@ -421,56 +467,20 @@ share/gnome/dia/sheets/civil.sheet
share/gnome/dia/sheets/jigsaw.sheet
share/gnome/dia/sheets/network.sheet
share/gnome/dia/sheets/sybase.sheet
-share/gnome/%%DIAHELP%%/C
-share/gnome/%%DIAHELP%%/en/background-color.html
-share/gnome/%%DIAHELP%%/en/canvas-chapter.html
-share/gnome/%%DIAHELP%%/en/colors.html
-share/gnome/%%DIAHELP%%/en/creating-canvas.html
-share/gnome/%%DIAHELP%%/en/docbook.css
-share/gnome/%%DIAHELP%%/en/graphics/greendots.png
-share/gnome/%%DIAHELP%%/en/graphics/home_network.png
-share/gnome/%%DIAHELP%%/en/graphics/line_props.png
-share/gnome/%%DIAHELP%%/en/gridlines.html
-share/gnome/%%DIAHELP%%/en/index.html
-share/gnome/%%DIAHELP%%/en/ln9.html
-share/gnome/%%DIAHELP%%/en/making-diagram.html
-share/gnome/%%DIAHELP%%/en/object-properties.html
-share/gnome/%%DIAHELP%%/en/objects-chapter.html
-share/gnome/%%DIAHELP%%/en/quickstart-chapter.html
-share/gnome/%%DIAHELP%%/en/quickstart-intro.html
-share/gnome/%%DIAHELP%%/en/rulers.html
-share/gnome/%%DIAHELP%%/en/save-print-diagram.html
-share/gnome/%%DIAHELP%%/en/starting-dia.html
-share/gnome/%%DIAHELP%%/en/stylesheet-images/caution.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/home.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/important.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/next.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/note.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/prev.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/tip.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/toc-blank.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/toc-minus.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/toc-plus.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/up.gif
-share/gnome/%%DIAHELP%%/en/stylesheet-images/warning.gif
-share/gnome/%%DIAHELP%%/en/topic.dat
-share/gnome/%%DIAHELP%%/en/using-objects.html
-share/gnome/%%DIAHELP%%/en/who-appeal-too.html
-share/gnome/%%DIAHELP%%/en/zooming.html
-%%GNOME:%%share/gnome/mime-info/dia.keys
-%%GNOME:%%share/gnome/mime-info/dia.mime
-%%GNOME:%%share/gnome/pixmaps/dia-diagram.png
-%%GNOME:%%share/gnome/pixmaps/dia_gnome_icon.png
-share/locale/az/LC_MESSAGES/dia.mo
-share/locale/es/LC_MESSAGES/dia.mo
-share/locale/nl/LC_MESSAGES/dia.mo
-share/locale/pt_BR/LC_MESSAGES/dia.mo
-share/locale/zh_CN.GB2312/LC_MESSAGES/dia.mo
+share/gnome/help/dia/C
+share/gnome/help/dia/en/topic.dat
+share/gnome/help/dia/pl/topic.dat
+share/gnome/mime-info/dia.keys
+share/gnome/mime-info/dia.mime
+share/gnome/pixmaps/dia-diagram.png
+share/gnome/pixmaps/dia_gnome_icon.png
+share/locale/az/LC_MESSAGES/dia.mo
share/locale/ca/LC_MESSAGES/dia.mo
share/locale/da/LC_MESSAGES/dia.mo
share/locale/de/LC_MESSAGES/dia.mo
share/locale/el/LC_MESSAGES/dia.mo
share/locale/en_GB/LC_MESSAGES/dia.mo
+share/locale/es/LC_MESSAGES/dia.mo
share/locale/fi/LC_MESSAGES/dia.mo
share/locale/fr/LC_MESSAGES/dia.mo
share/locale/ga/LC_MESSAGES/dia.mo
@@ -478,27 +488,34 @@ share/locale/hu/LC_MESSAGES/dia.mo
share/locale/it/LC_MESSAGES/dia.mo
share/locale/ja/LC_MESSAGES/dia.mo
share/locale/ko/LC_MESSAGES/dia.mo
+share/locale/nl/LC_MESSAGES/dia.mo
+share/locale/nn/LC_MESSAGES/dia.mo
share/locale/no/LC_MESSAGES/dia.mo
share/locale/pl/LC_MESSAGES/dia.mo
share/locale/pt/LC_MESSAGES/dia.mo
+share/locale/pt_BR/LC_MESSAGES/dia.mo
share/locale/ru/LC_MESSAGES/dia.mo
+share/locale/sk/LC_MESSAGES/dia.mo
share/locale/sl/LC_MESSAGES/dia.mo
share/locale/sv/LC_MESSAGES/dia.mo
share/locale/tr/LC_MESSAGES/dia.mo
share/locale/uk/LC_MESSAGES/dia.mo
-share/locale/zh_TW.Big5/LC_MESSAGES/dia.mo
-@dirrm share/gnome/%%DIAHELP%%/en/stylesheet-images
-@dirrm share/gnome/%%DIAHELP%%/en/graphics
-@dirrm share/gnome/%%DIAHELP%%/en
-@dirrm share/gnome/%%DIAHELP%%
+share/locale/vi/LC_MESSAGES/dia.mo
+share/locale/zh_CN/LC_MESSAGES/dia.mo
+share/locale/zh_TW/LC_MESSAGES/dia.mo
+@dirrm share/gnome/help/dia/pl
+@dirrm share/gnome/help/dia/en
+@dirrm share/gnome/help/dia
@dirrm share/gnome/dia/sheets/UML
@dirrm share/gnome/dia/sheets/GRAFCET
@dirrm share/gnome/dia/sheets/ER
@dirrm share/gnome/dia/sheets
+@dirrm share/gnome/dia/shapes/sybase
@dirrm share/gnome/dia/shapes/jigsaw
@dirrm share/gnome/dia/shapes/SDL
@dirrm share/gnome/dia/shapes/Pneumatic
@dirrm share/gnome/dia/shapes/Network
+@dirrm share/gnome/dia/shapes/Misc
@dirrm share/gnome/dia/shapes/MSE
@dirrm share/gnome/dia/shapes/Logic
@dirrm share/gnome/dia/shapes/Flowchart