aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam-kde4/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-06-15 18:07:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-06-15 18:07:12 +0000
commitfa8ec88c6470bdea6faa7f15ace100ae28fcee02 (patch)
treebd0240254468c75b474bb433592d4f005528efe3 /graphics/digikam-kde4/Makefile
parentafbf09cc33941f6e8015ea2a99665add0df3b03a (diff)
Notes
Diffstat (limited to 'graphics/digikam-kde4/Makefile')
-rw-r--r--graphics/digikam-kde4/Makefile46
1 files changed, 41 insertions, 5 deletions
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 3408c8bf5397..65db0f6c38e8 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= digikam
PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics kde
MASTER_SITES= SFE
@@ -16,7 +16,6 @@ MAINTAINER= datahead4@gmail.com
COMMENT= An advanced digital photo management application for KDE4
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
lcms.1:${PORTSDIR}/graphics/lcms \
png.5:${PORTSDIR}/graphics/png \
jasper.4:${PORTSDIR}/graphics/jasper \
@@ -25,13 +24,50 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
LATEST_LINK= ${PORTNAME}-kde4
USE_BZIP2= yes
-USE_KDE4= automoc4 kdehier kdeprefix kdelibs pimlibs
+USE_KDE4= automoc4 kdehier kdeprefix kdelibs
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui sql qmake_build moc_build rcc_build uic_build
+QT_COMPONENTS= gui dbus network qt3support sql svg xml \
+ qmake_build moc_build rcc_build uic_build
+USE_GNOME= pkgconfig
USE_CMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
MAN1= digitaglinktree.1
-.include <bsd.port.mk>
+OPTIONS= GPHOTO2 "Compile with gphoto2 support" on \
+ LENSFUN "Compile lens auto-correction image editor plugin" off \
+ MARBLE "Geolocation support (requires misc/kdeedu4)" off \
+ PIMLIBS "Address book support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GPHOTO2)
+CMAKE_ARGS+= -DENABLE_GPHOTO2:BOOL=OFF
+.else
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+.endif
+
+.if defined(WITH_LENSFUN)
+LIB_DEPENDS+= lensfun.0:${PORTSDIR}/graphics/lensfun
+.else
+CMAKE_ARGS+= -DWITH_LensFun:BOOL=OFF
+.endif
+
+.if defined(WITH_MARBLE)
+LIB_DEPENDS+= marblewidget.5:${PORTSDIR}/misc/kdeedu4
+.else
+CMAKE_ARGS+= -DWITH_MarbleWidget:BOOL=OFF
+.endif
+
+.if defined(WITHOUT_PIMLIBS)
+CMAKE_ARGS+= -DWITH_KdepimLibs:BOOL=OFF
+.else
+USE_KDE4+= pimlibs
+.endif
+
+post-patch:
+ ${GREP} -H -r "#include <q" ${WRKSRC} | ${CUT} -d: -f1 | uniq | \
+ ${XARGS} ${REINPLACE_CMD} -f ${FILESDIR}/qt3to4headers.txt
+
+.include <bsd.port.post.mk>