aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam-kde4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-27 20:16:00 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-27 20:16:00 +0000
commit6abebde49f7143e6e05996683edfeb8d05c01a65 (patch)
tree3849f2bc5cd04ee5a75c564dd693ac52a0bbb621 /graphics/digikam-kde4
parenta489cb61bb59e6e4faea94147e667482f8cbeba2 (diff)
downloadports-6abebde49f7143e6e05996683edfeb8d05c01a65.tar.gz
ports-6abebde49f7143e6e05996683edfeb8d05c01a65.zip
Notes
Diffstat (limited to 'graphics/digikam-kde4')
-rw-r--r--graphics/digikam-kde4/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/digikam-kde4/files/patch-CMakeLists.txt b/graphics/digikam-kde4/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..34fd64f54371
--- /dev/null
+++ b/graphics/digikam-kde4/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+Make sure liblqr-1.so's full path is passed to the linker.
+--- CMakeLists.txt.orig 2016-06-16 18:45:54 UTC
++++ CMakeLists.txt
+@@ -557,6 +557,7 @@ if(DIGIKAM_CAN_BE_COMPILED)
+ if(LQR-1_FOUND)
+ include_directories(${LQR-1_INCLUDE_DIRS})
+ set(liblqr_LIBS ${LQR-1_LIBRARIES})
++ link_directories(${LQR-1_LIBDIR})
+ endif()
+
+ # Lensfun library rules