aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-01-10 09:12:46 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-01-10 09:12:46 +0000
commit7a782b5d4b7e583fb7fe8159436a72b95d2e4c5b (patch)
treeb4b277374dc44b1bfb34e696a99b2d70e4176ac5 /graphics/digikam
parent92d0d120eb3eded8c7bafc068f3f08de5fd5ca6a (diff)
downloadports-7a782b5d4b7e583fb7fe8159436a72b95d2e4c5b.tar.gz
ports-7a782b5d4b7e583fb7fe8159436a72b95d2e4c5b.zip
Notes
Diffstat (limited to 'graphics/digikam')
-rw-r--r--graphics/digikam/Makefile4
-rw-r--r--graphics/digikam/files/patch-externc64
2 files changed, 64 insertions, 4 deletions
diff --git a/graphics/digikam/Makefile b/graphics/digikam/Makefile
index 90acfa07fd2a..175ddc115bbc 100644
--- a/graphics/digikam/Makefile
+++ b/graphics/digikam/Makefile
@@ -30,10 +30,6 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/graphics/digikam/files/patch-externc b/graphics/digikam/files/patch-externc
new file mode 100644
index 000000000000..bc364216b82b
--- /dev/null
+++ b/graphics/digikam/files/patch-externc
@@ -0,0 +1,64 @@
+--- digikam/digikam/digikamfirstrun.cpp.orig Wed Jan 5 10:40:08 2005
++++ digikam/digikam/digikamfirstrun.cpp Wed Jan 5 10:40:39 2005
+@@ -20,15 +20,6 @@
+ *
+ * ============================================================ */
+
+-// C Ansi includes.
+-
+-extern "C"
+-{
+-#include <sys/types.h>
+-#include <sys/stat.h>
+-#include <unistd.h>
+-}
+-
+ // C++ Includes.
+
+ #include <iostream>
+@@ -65,6 +56,15 @@
+ #include "firstrunUI.h"
+
+ #include <iostream>
++// C Ansi includes.
++
++extern "C"
++{
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
++}
++
+ using namespace std;
+
+ DigikamFirstRun::DigikamFirstRun( KConfig* config,
+--- digikam/utilities/imageeditor/imlibinterface.cpp.orig Wed Jan 5 10:45:12 2005
++++ digikam/utilities/imageeditor/imlibinterface.cpp Wed Jan 5 10:45:29 2005
+@@ -22,13 +22,6 @@
+
+ #define PI 3.14159265
+
+-// Lib Tiff includes.
+-
+-extern "C"
+-{
+-#include <tiffio.h>
+-}
+-
+ // C++ includes.
+
+ #include <cmath>
+@@ -59,6 +52,13 @@
+ #include "albumsettings.h"
+ #include "imlibinterface.h"
+
++// Lib Tiff includes.
++
++extern "C"
++{
++#include <tiffio.h>
++}
++
+ namespace Digikam
+ {
+