aboutsummaryrefslogtreecommitdiff
path: root/graphics/djvulibre/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-04-29 19:39:33 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-04-29 19:39:33 +0000
commit982470156836a53a3c042d53a33e3390fc53cbde (patch)
tree68855bcec083658e241644e63b148234a3bad06e /graphics/djvulibre/Makefile
parent3350aea7c5938db18d73db83163353a65f5e3d83 (diff)
downloadports-982470156836a53a3c042d53a33e3390fc53cbde.tar.gz
ports-982470156836a53a3c042d53a33e3390fc53cbde.zip
Notes
Diffstat (limited to 'graphics/djvulibre/Makefile')
-rw-r--r--graphics/djvulibre/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 1d364c51bcbc..fba6b1c55c59 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= djvulibre
-PORTVERSION= 3.5.13
+PORTVERSION= 3.5.14
CATEGORIES= graphics www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= djvu
@@ -25,7 +25,8 @@ LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
USE_ICONV= yes
USE_PERL5_BUILD=yes
-HAS_CONFIGURE= yes
+USE_AUTOCONF_VER=259
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/djvu
CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
@@ -39,7 +40,6 @@ CONFIGURE_ENV+= CXX=${CXX} \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
QTLIBS="-L${X11BASE}/lib -lqt-mt"
-CONFIGURE_ARGS+=--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
.else
CONFIGURE_ARGS+=--disable-djview
.endif
@@ -56,6 +56,9 @@ pre-configure:
-type f -print0 | ${XARGS} -0 ${GREP} -Fl --mmap /usr/local`
.endif
+patch-autotools:
+ @cd ${PATCH_WRKSRC}; ${LIBTOOLIZE} -f >/dev/null
+
.if !defined(WITH_OPTIMIZED_CFLAGS)
post-configure:
${PERL5} -pi -e 's,-O3,,;' -e 's,-mcpu=i386,,; ' \