aboutsummaryrefslogtreecommitdiff
path: root/graphics/djvulibre
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-04-29 19:39:33 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-04-29 19:39:33 +0000
commit982470156836a53a3c042d53a33e3390fc53cbde (patch)
tree68855bcec083658e241644e63b148234a3bad06e /graphics/djvulibre
parent3350aea7c5938db18d73db83163353a65f5e3d83 (diff)
downloadports-982470156836a53a3c042d53a33e3390fc53cbde.tar.gz
ports-982470156836a53a3c042d53a33e3390fc53cbde.zip
Notes
Diffstat (limited to 'graphics/djvulibre')
-rw-r--r--graphics/djvulibre/Makefile9
-rw-r--r--graphics/djvulibre/distinfo4
-rw-r--r--graphics/djvulibre/files/patch-gui_nsdejavu_Makefile.in9
-rw-r--r--graphics/djvulibre/files/patch-libdjvu_Arrays.h52
-rw-r--r--graphics/djvulibre/files/patch-libdjvu_GContainer.h59
-rw-r--r--graphics/djvulibre/files/patch-libdjvu_GString.cpp20
-rw-r--r--graphics/djvulibre/files/patch-libdjvu_GString.h11
-rw-r--r--graphics/djvulibre/files/patch-libdjvu_MMX.cpp11
-rw-r--r--graphics/djvulibre/pkg-plist4
9 files changed, 11 insertions, 168 deletions
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 1d364c51bcbc..fba6b1c55c59 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= djvulibre
-PORTVERSION= 3.5.13
+PORTVERSION= 3.5.14
CATEGORIES= graphics www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= djvu
@@ -25,7 +25,8 @@ LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
USE_ICONV= yes
USE_PERL5_BUILD=yes
-HAS_CONFIGURE= yes
+USE_AUTOCONF_VER=259
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/djvu
CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
@@ -39,7 +40,6 @@ CONFIGURE_ENV+= CXX=${CXX} \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
QTLIBS="-L${X11BASE}/lib -lqt-mt"
-CONFIGURE_ARGS+=--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
.else
CONFIGURE_ARGS+=--disable-djview
.endif
@@ -56,6 +56,9 @@ pre-configure:
-type f -print0 | ${XARGS} -0 ${GREP} -Fl --mmap /usr/local`
.endif
+patch-autotools:
+ @cd ${PATCH_WRKSRC}; ${LIBTOOLIZE} -f >/dev/null
+
.if !defined(WITH_OPTIMIZED_CFLAGS)
post-configure:
${PERL5} -pi -e 's,-O3,,;' -e 's,-mcpu=i386,,; ' \
diff --git a/graphics/djvulibre/distinfo b/graphics/djvulibre/distinfo
index 250c5afadc7c..4094e6b4e066 100644
--- a/graphics/djvulibre/distinfo
+++ b/graphics/djvulibre/distinfo
@@ -1,2 +1,2 @@
-MD5 (djvulibre-3.5.13.tar.gz) = 5df02ba314ce32b95f4ee18e4b863441
-SIZE (djvulibre-3.5.13.tar.gz) = 1452616
+MD5 (djvulibre-3.5.14.tar.gz) = a9b60d0c47d6b98e321100d329c7f3b3
+SIZE (djvulibre-3.5.14.tar.gz) = 1742428
diff --git a/graphics/djvulibre/files/patch-gui_nsdejavu_Makefile.in b/graphics/djvulibre/files/patch-gui_nsdejavu_Makefile.in
index 3f864ec98f2a..da5e24f1c159 100644
--- a/graphics/djvulibre/files/patch-gui_nsdejavu_Makefile.in
+++ b/graphics/djvulibre/files/patch-gui_nsdejavu_Makefile.in
@@ -10,12 +10,3 @@ diff -ur gui/nsdejavu/Makefile.in.ori gui/nsdejavu/Makefile.in
CC = @CC@
CXX = @CXX@
-@@ -40,7 +40,7 @@
- OPTS = @OPTS@
- NSDEJAVU = @NSDEJAVU@
- NSDEJAVU_FLAGS = @NSDEJAVU_FLAGS@
--NSDEJAVU_LIBS = @NSDEJAVU_LIBS@
-+NSDEJAVU_LIBS = @NSDEJAVU_LIBS@ -lXt
- NSDEJAVU_LINK = @NSDEJAVU_LINK@
-
- INCS = \
diff --git a/graphics/djvulibre/files/patch-libdjvu_Arrays.h b/graphics/djvulibre/files/patch-libdjvu_Arrays.h
deleted file mode 100644
index 74cedc3f505e..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu_Arrays.h
+++ /dev/null
@@ -1,52 +0,0 @@
---- libdjvu/Arrays.h.orig Sat Nov 8 04:08:20 2003
-+++ libdjvu/Arrays.h Mon Sep 20 21:01:27 2004
-@@ -708,21 +708,21 @@
- template <class TYPE>
- TArray<TYPE>::TArray ()
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, init2, insert));
- }
-
- template <class TYPE>
- TArray<TYPE>::TArray(int hi)
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, init2, insert, hi));
- }
-
- template <class TYPE>
- TArray<TYPE>::TArray(int lo, int hi)
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, init2, insert, lo, hi));
- }
-
-@@ -854,21 +854,21 @@
- template <class TYPE> inline
- DArray<TYPE>::DArray ()
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, copy, insert));
- }
-
- template <class TYPE> inline
- DArray<TYPE>::DArray(const int hi)
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, copy, insert, hi));
- }
-
- template <class TYPE> inline
- DArray<TYPE>::DArray(const int lo, const int hi)
- {
-- assign(new ArrayRep(sizeof(TYPE), destroy, init1,
-+ this->assign(new ArrayRep(sizeof(TYPE), destroy, init1,
- init2, copy, insert, lo, hi));
- }
-
diff --git a/graphics/djvulibre/files/patch-libdjvu_GContainer.h b/graphics/djvulibre/files/patch-libdjvu_GContainer.h
deleted file mode 100644
index 567b22145c08..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu_GContainer.h
+++ /dev/null
@@ -1,59 +0,0 @@
---- libdjvu/GContainer.h.orig Sat Nov 8 04:08:21 2003
-+++ libdjvu/GContainer.h Fri Oct 1 13:45:26 2004
-@@ -786,9 +786,9 @@
- template<class TI> int
- GListImpl<TI>::operator==(const GListImpl<TI> &l2) const
- {
-- Node *p, *q;
-+ ListNode<TI> *p, *q;
- for (p=head.next, q=l2.head.next; p && q; p=p->next, q=q->next )
-- if (p->data != q->data)
-+ if (p->val != q->val)
- return 0;
- return p==0 && q==0;
- }
-@@ -817,7 +817,7 @@
- // -- ACCESS
- /** Returns the number of elements in the list. */
- int size() const
-- { return nelem; }
-+ { return this->nelem; }
- /** Returns the first position in the list. See \Ref{GPosition}. */
- GPosition firstpos() const
- { return GListImpl<TI>::firstpos(); }
-@@ -846,7 +846,7 @@
- /** Tests whether a list is empty.
- Returns a non zero value if the list contains no elements. */
- int isempty() const
-- { return nelem==0; }
-+ { return this->nelem==0; }
- /** Compares two lists. Returns a non zero value if and only if both lists
- contain the same elements (as tested by #TYPE::operator==(const TYPE&)#
- in the same order. */
-@@ -1149,7 +1149,7 @@
- public:
- /** Returns the number of elements in the map. */
- int size() const
-- { return nelems; }
-+ { return this->nelems; }
- /** Returns the first position in the map. */
- GPosition firstpos() const
- { return GMapImpl<KTYPE,TI>::firstpos(); }
-@@ -1159,7 +1159,7 @@
- /** Tests whether the associative map is empty.
- Returns a non zero value if and only if the map contains zero entries. */
- int isempty() const
-- { return nelems==0; }
-+ { return this->nelems==0; }
- /** Searches an entry for key #key#. If the map contains an entry whose key
- is equal to #key# according to #KTYPE::operator==(const KTYPE&)#, this
- function returns its position. Otherwise it returns an invalid
-@@ -1215,7 +1215,7 @@
- /* Old iterators. Do not use. */
- #if GCONTAINER_OLD_ITERATORS
- void first(GPosition &pos) const { pos = firstpos(); }
-- void last(GPosition &pos) const { pos = lastpos(); }
-+ void last(GPosition &pos) const { pos = this->lastpos(); }
- const VTYPE *next(GPosition &pos) const
- { if (!pos) return 0; const VTYPE *x=&((*this)[pos]); ++pos; return x; }
- VTYPE *next(GPosition &pos)
diff --git a/graphics/djvulibre/files/patch-libdjvu_GString.cpp b/graphics/djvulibre/files/patch-libdjvu_GString.cpp
deleted file mode 100644
index 96d4c1f0fca4..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu_GString.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- libdjvu/GString.cpp.orig Tue Dec 2 04:57:39 2003
-+++ libdjvu/GString.cpp Fri Oct 1 14:05:22 2004
-@@ -2666,7 +2666,7 @@
- { init(GStringRep::UTF8::create(&dat,0,1)); }
-
- GUTF8String::GUTF8String(const GUTF8String &fmt, va_list &args)
--{ init(fmt.ptr?fmt->vformat(args):fmt); }
-+{ init(fmt.ptr?fmt->vformat(args):(GUTF8String &)fmt); }
-
- GUTF8String::GUTF8String(const char *str)
- { init(GStringRep::UTF8::create(str)); }
-@@ -2712,7 +2712,7 @@
- GNativeString::operator+(const GUTF8String &s2) const
- {
- return GStringRep::UTF8::create(
-- ptr?(*this)->toUTF8(true):(*this),s2);
-+ ptr?(*this)->toUTF8(true):(GP<GStringRep>)(*this),s2);
- }
- #endif
-
diff --git a/graphics/djvulibre/files/patch-libdjvu_GString.h b/graphics/djvulibre/files/patch-libdjvu_GString.h
deleted file mode 100644
index 9cbc820f188d..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu_GString.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- libdjvu/GString.h.orig Tue Dec 2 04:57:40 2003
-+++ libdjvu/GString.h Fri Oct 1 13:52:39 2004
-@@ -1558,7 +1558,7 @@
- inline
- GNativeString::GNativeString(const GNativeString &fmt, va_list &args)
- {
-- init(fmt.ptr?fmt->vformat(args):fmt);
-+ init(fmt.ptr?fmt->vformat(args):(GNativeString &)fmt);
- }
-
- inline GNativeString
diff --git a/graphics/djvulibre/files/patch-libdjvu_MMX.cpp b/graphics/djvulibre/files/patch-libdjvu_MMX.cpp
deleted file mode 100644
index 909f14e5ba90..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu_MMX.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libdjvu/MMX.cpp.orig Fri Oct 1 14:42:33 2004
-+++ libdjvu/MMX.cpp Sat Nov 8 04:08:22 2003
-@@ -161,7 +161,7 @@
- "1:\tpopl %%ebx\n\t"
- "movl %%edx, %0"
- : "=m" (cpuflags) :
-- : "eax","ebx","ecx","edx");
-+ : "eax","ecx","edx");
- #endif
- #if defined(MMX) && defined(_MSC_VER) && defined(_M_IX86)
- // Detection of MMX for MSVC
diff --git a/graphics/djvulibre/pkg-plist b/graphics/djvulibre/pkg-plist
index a84550014fab..f21692e493c2 100644
--- a/graphics/djvulibre/pkg-plist
+++ b/graphics/djvulibre/pkg-plist
@@ -17,8 +17,10 @@ bin/djvuserve
bin/djvutoxml
bin/djvutxt
bin/djvuxmlparser
+include/libdjvu/ddjvuapi.h
%%X11%%lib/browser_plugins/nsdejavu.so
-lib/libdjvulibre-3.5.13.so
+lib/libdjvulibre.so
+lib/libdjvulibre.so.14
share/djvu/languages.xml
%%X11%%share/djvu/osi/de/djview.qm
share/djvu/osi/de/libdjvu++.xml