aboutsummaryrefslogtreecommitdiff
path: root/graphics/djvulibre
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-06-13 19:19:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-06-13 19:19:04 +0000
commit89e8ef9e97cee5a35412ece2de0e25b0fa85840e (patch)
treebe697b74ed5cbb5c3f2b3f3b01b9a59fea016cd1 /graphics/djvulibre
parent6a860fddbd658a62ac6a1d0b221de8ab8ae96762 (diff)
downloadports-89e8ef9e97cee5a35412ece2de0e25b0fa85840e.tar.gz
ports-89e8ef9e97cee5a35412ece2de0e25b0fa85840e.zip
Notes
Diffstat (limited to 'graphics/djvulibre')
-rw-r--r--graphics/djvulibre/Makefile45
-rw-r--r--graphics/djvulibre/distinfo4
-rw-r--r--graphics/djvulibre/files/patch-desktopfiles_Makefile.in37
-rw-r--r--graphics/djvulibre/files/patch-libdjvu__miniexp.cpp11
-rw-r--r--graphics/djvulibre/files/patch-tools_Makefile.in11
-rw-r--r--graphics/djvulibre/files/patch-tools_any2djvu90
-rw-r--r--graphics/djvulibre/pkg-plist26
7 files changed, 37 insertions, 187 deletions
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 801e8fff237b..3e7548ea0263 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= djvulibre
-PORTVERSION= 3.5.25.3
-PORTREVISION= 3
+PORTVERSION= 3.5.27
CATEGORIES= graphics www
-MASTER_SITES= SF/djvu/DjVuLibre/${PORTVERSION:R}
+MASTER_SITES= SF/djvu/DjVuLibre/${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT= DjVu base libraries and utilities
@@ -13,21 +12,24 @@ COMMENT= DjVu base libraries and utilities
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= rsvg-convert:graphics/librsvg2
LIB_DEPENDS= libtiff.so:graphics/tiff
+INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
JPEG_LIBS="-L${LOCALBASE}/lib -ljpeg" \
TIFF_CFLAGS="-I${LOCALBASE}/include" \
TIFF_LIBS="-L${LOCALBASE}/lib -ltiff"
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-USES= cpe iconv jpeg libtool pathfix
+USES= cpe gmake iconv jpeg libtool shared-mime-info
CPE_VENDOR= djvulibre_project
USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
CONFLICTS= djvulibre-nox11-3*
-WRKSRC= ${WRKDIR}/${DISTNAME:R}
-PORTDOCS= djvu2spec.djvu djvu3spec.djvu djvuchanges.txt lizard2002.djvu lizard2007.djvu
+PORTDOCS= *.djvu *.pdf *.txt
OPTIONS_DEFINE= DOCS ANY2DJVU
OPTIONS_SUB= yes
@@ -35,27 +37,22 @@ OPTIONS_SUB= yes
ANY2DJVU_DESC= Install any2djvu script (requires curl)
ANY2DJVU_RUN_DEPENDS= curl:ftp/curl
-.include <bsd.port.options.mk>
-
post-patch:
- @${REINPLACE_CMD} -e \
- '/-[Og]\*)/d ; \
- s|$$OPTS -O[[:digit:]]*|$$OPTS|g ; \
- s|$$OPTS $$opt|$$OPTS|g' \
+# Remove custom optimization compiler flags
+ @${REINPLACE_CMD} -e '/-[Og]\*)/d ; \
+ /^ opt=/s|-O[[:digit:]]*||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|$${FLAGS}|| ; \
- s|@CPPFLAGS@|$${FLAGS} &|' \
- ${WRKSRC}/tools/jb2cmp/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|_PROGRAM} -m 0755|_SCRIPT}|' \
+# Convert bash to sh script, which uses fetch instead of wget
+ @${REINPLACE_CMD} -e '/^#!/s|bash -f|sh| ; \
+ s|^function || ; s| == | = |g ; \
+ s|wget $$wgetopts -O|${FETCH_BINARY} $$wgetopts -o|' \
+ ${WRKSRC}/tools/any2djvu
+
+post-patch-ANY2DJVU-off:
+ @${REINPLACE_CMD} -e 's/any2djvu // ; s/any2djvu\.1 //' \
${WRKSRC}/tools/Makefile.in
-.if empty(PORT_OPTIONS:MANY2DJVU)
- @${REINPLACE_CMD} -e 's,any2djvu,,' ${WRKSRC}/tools/Makefile.in
-.endif
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/graphics/djvulibre/distinfo b/graphics/djvulibre/distinfo
index 0f7812ba82c3..b2925696c4ed 100644
--- a/graphics/djvulibre/distinfo
+++ b/graphics/djvulibre/distinfo
@@ -1,2 +1,2 @@
-SHA256 (djvulibre-3.5.25.3.tar.gz) = 898d7ed6dd2fa311a521baa95407a91b20a872d80c45e8245442d64f142cb1e0
-SIZE (djvulibre-3.5.25.3.tar.gz) = 2543949
+SHA256 (djvulibre-3.5.27.tar.gz) = e69668252565603875fb88500cde02bf93d12d48a3884e472696c896e81f505f
+SIZE (djvulibre-3.5.27.tar.gz) = 3648522
diff --git a/graphics/djvulibre/files/patch-desktopfiles_Makefile.in b/graphics/djvulibre/files/patch-desktopfiles_Makefile.in
deleted file mode 100644
index bff3d33aebcd..000000000000
--- a/graphics/djvulibre/files/patch-desktopfiles_Makefile.in
+++ /dev/null
@@ -1,37 +0,0 @@
---- desktopfiles/Makefile.in.orig 2012-06-13 09:31:40.000000000 -0400
-+++ desktopfiles/Makefile.in 2012-06-13 09:34:37.000000000 -0400
-@@ -30,6 +30,7 @@
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_SCRIPT = @INSTALL_SCRIPT@
- INSTALL_DATA = @INSTALL_DATA@
- CONVERT = @CONVERT@
- INKSCAPE = @INKSCAPE@
-@@ -53,15 +54,10 @@
- icons: ${PNGICONS} hi-djvu.svgz
-
- ${PNGICONS}: djvu.svg
-- s=`echo $@ | sed -e 's/[a-z]*\([0-9]*\).*/\1/'`; \
-- ${RSVG} -w $${s} -h $${s} -o $@ $< \
-- || ${CONVERT} -geometry $${s}x$${s} -depth 8 -background none $< $@ \
-- || ${INKSCAPE} --without-gui --export-width=$${s} \
-- --export-height=$${s} --export-png=$@ $< \
-- || cp ${srcdir}/prebuilt-$@ $@
-+ if test -f ${srcdir}/prebuilt-$@ ; then cp ${srcdir}/prebuilt-$@ $@ ; fi
-
- hi-djvu.svgz: djvu.svg
-- cat $< | gzip >$@
-+ cat ${.ALLSRC} | gzip >$@
-
- register-djvu-mime: register-djvu-mime.in
- sed < ${srcdir}/register-djvu-mime.in > register-djvu-mime \
-@@ -80,7 +76,7 @@
-
- install-djvu-files: FORCE
- ${INSTALL} -d ${DESTDIR}${datadir_djvu}
-- ${INSTALL_PROGRAM} register-djvu-mime ${DESTDIR}${datadir_djvu}
-+ ${INSTALL_SCRIPT} register-djvu-mime ${DESTDIR}${datadir_djvu}
- ${INSTALL_DATA} *djvu.png ${DESTDIR}${datadir_djvu}
- ${INSTALL_DATA} *djvu.svgz ${DESTDIR}${datadir_djvu}
- ${INSTALL_DATA} ${srcdir}/*mime.xml ${DESTDIR}${datadir_djvu}
diff --git a/graphics/djvulibre/files/patch-libdjvu__miniexp.cpp b/graphics/djvulibre/files/patch-libdjvu__miniexp.cpp
deleted file mode 100644
index 87c57b2b5e7f..000000000000
--- a/graphics/djvulibre/files/patch-libdjvu__miniexp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libdjvu/miniexp.cpp.orig 2012-05-07 22:56:53.000000000 -0400
-+++ libdjvu/miniexp.cpp 2012-06-12 07:23:54.000000000 -0400
-@@ -1008,7 +1008,7 @@
- if (io == &miniexp_io && !CompatCounter::count)
- return (*minilisp_getc)(); /* compatibility hack */
- FILE *f = (io->data[0]) ? (FILE*)(io->data[0]) : stdin;
-- return ::getc(f);
-+ return getc(f);
- }
-
- static int
diff --git a/graphics/djvulibre/files/patch-tools_Makefile.in b/graphics/djvulibre/files/patch-tools_Makefile.in
deleted file mode 100644
index b3c494dd8eb8..000000000000
--- a/graphics/djvulibre/files/patch-tools_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/Makefile.in.orig 2009-07-07 17:04:26.000000000 +0200
-+++ tools/Makefile.in 2009-07-07 17:11:00.000000000 +0200
-@@ -83,7 +83,7 @@
- install-scripts: FORCE
- ${INSTALL} -d ${DESTDIR}${bindir}
- for n in ${SCRIPTS} ; do \
-- ${INSTALL_PROGRAM} -m 0755 ${srcdir}/$$n ${DESTDIR}${bindir} \
-+ ${INSTALL} -m 0755 ${srcdir}/$$n ${DESTDIR}${bindir} \
- || exit ; done
-
- install-man: FORCE
diff --git a/graphics/djvulibre/files/patch-tools_any2djvu b/graphics/djvulibre/files/patch-tools_any2djvu
deleted file mode 100644
index 1b86edc3e213..000000000000
--- a/graphics/djvulibre/files/patch-tools_any2djvu
+++ /dev/null
@@ -1,90 +0,0 @@
---- tools/any2djvu.orig 2011-03-31 00:54:11.000000000 -0700
-+++ tools/any2djvu 2011-03-31 00:56:54.000000000 -0700
-@@ -1,6 +1,6 @@
--#! /bin/bash -f
-+#!/bin/sh
-
--function copyright()
-+copyright()
- {
- echo "Copyright (C) 2002 David Kreil <D.Kreil@IEEE.Org>"
- echo "Modified by Barak A. Pearlmutter <bap@debian.org>"
-@@ -8,7 +8,7 @@
- echo "Released under the GNU GPL v2, 21-Oct-2002."
- }
-
--function warranty()
-+warranty()
- {
- echo "This program is distributed in the hope that it will be useful,"
- echo "but WITHOUT ANY WARRANTY; without even the implied warranty of"
-@@ -16,7 +16,7 @@
- echo "GNU General Public License for more details."
- }
-
--function disclaimer()
-+disclaimer()
- {
- echo "By using this tool you accept the following disclaimer:"
- echo " Because the any2djvu service is free of charge, there is no"
-@@ -34,7 +34,7 @@
- ocr=1
- docformat=2
-
--function warn()
-+warn()
- {
- echo "Notes:"
- echo " - Internet connection is required."
-@@ -47,7 +47,7 @@
- echo " - This software comes with NO WARRANTY."
- }
-
--function format_help()
-+format_help()
- {
- echo "Codes for the formats of the input documents to use with -f"
- echo " 1 - DjVu Document (for verification or OCR)"
-@@ -61,7 +61,7 @@
- echo " 9 - Scanned Document - Color/Mixed - >400 dpi"
- }
-
--function usage()
-+usage()
- {
- echo "Convert files from .ps/.ps.gz/.pdf to .djvu"
- echo "Usage: $0 [options] [url] {filename(s)}"
-@@ -117,13 +117,13 @@
- fi
-
- # check OCR option
--if [ ! "x$ocr" == x0 ] && [ ! "x$ocr" == x1 ]; then
-+if [ ! "x$ocr" = x0 ] && [ ! "x$ocr" = x1 ]; then
- echo 'error: -o OCR must be 0 or 1'
- exit 2
- fi
-
- # if help is requested or docformat is not specified right - show help
--if [ "x$docformat" == x'help' ]; then
-+if [ "x$docformat" = x'help' ]; then
- format_help
- exit 0
- fi
-@@ -209,7 +209,7 @@
- -F ocr=$ocr -F legal=1 "$rurl/$rcgi" \
- | eval tee "'$log'" $shellopts
- else
-- wget $wgetopts -O - "$rurl/$rcgi?urlupload=$lurl/$in$cgiopts" \
-+ /usr/bin/fetch $wgetopts -o - "$rurl/$rcgi?urlupload=$lurl/$in$cgiopts" \
- | eval tee "'$log'" $shellopts
- fi
- l=`egrep 'href=djvu/.*\.djvu' "$log"`
-@@ -219,7 +219,7 @@
- echo "error: something got wrong. check log file"
- exit 1
- fi
-- wget $wgetopts -O "$b.djvu" "$rurl/$l"
-+ /usr/bin/fetch $wgetopts -o "$b.djvu" "$rurl/$l"
-
- [ -z "$doclean" ] || rm "$log"
- [ -z $silent ] && ls -l "$b.djvu"
diff --git a/graphics/djvulibre/pkg-plist b/graphics/djvulibre/pkg-plist
index 6ce98212b560..bc97615b5033 100644
--- a/graphics/djvulibre/pkg-plist
+++ b/graphics/djvulibre/pkg-plist
@@ -21,7 +21,7 @@ include/libdjvu/ddjvuapi.h
include/libdjvu/miniexp.h
lib/libdjvulibre.so
lib/libdjvulibre.so.21
-lib/libdjvulibre.so.21.4.0
+lib/libdjvulibre.so.21.6.0
libdata/pkgconfig/ddjvuapi.pc
%%ANY2DJVU%%man/man1/any2djvu.1.gz
man/man1/bzz.1.gz
@@ -47,17 +47,6 @@ man/man1/djvuxmlparser.1.gz
share/djvu/osi/cs/messages.xml
share/djvu/osi/de/libdjvu++.xml
share/djvu/osi/de/messages.xml
-share/djvu/osi/desktop/djvulibre-mime.xml
-share/djvu/osi/desktop/hi-djvu.svgz
-share/djvu/osi/desktop/hi22-djvu.png
-share/djvu/osi/desktop/hi32-djvu.png
-share/djvu/osi/desktop/hi48-djvu.png
-share/djvu/osi/desktop/hi64-djvu.png
-share/djvu/osi/desktop/prebuilt-hi22-djvu.png
-share/djvu/osi/desktop/prebuilt-hi32-djvu.png
-share/djvu/osi/desktop/prebuilt-hi48-djvu.png
-share/djvu/osi/desktop/prebuilt-hi64-djvu.png
-share/djvu/osi/desktop/register-djvu-mime
share/djvu/osi/en/djvutools-reference.xml
share/djvu/osi/en/libdjvu++.xml
share/djvu/osi/en/messages.xml
@@ -71,3 +60,16 @@ share/djvu/osi/zh/messages.xml
share/djvu/pubtext/DjVuMessages.dtd
share/djvu/pubtext/DjVuOCR.dtd
share/djvu/pubtext/DjVuXML-s.dtd
+share/icons/hicolor/16x16/mimetypes/djvu.png
+share/icons/hicolor/20x20/mimetypes/djvu.png
+share/icons/hicolor/22x22/mimetypes/djvu.png
+share/icons/hicolor/24x24/mimetypes/djvu.png
+share/icons/hicolor/32x32/mimetypes/djvu.png
+share/icons/hicolor/48x48/mimetypes/djvu.png
+share/icons/hicolor/64x64/mimetypes/djvu.png
+share/icons/hicolor/72x72/mimetypes/djvu.png
+share/icons/hicolor/96x96/mimetypes/djvu.png
+share/icons/hicolor/128x128/mimetypes/djvu.png
+share/icons/hicolor/256x256/mimetypes/djvu.png
+share/icons/hicolor/scalable/mimetypes/djvu.svgz
+share/mime/packages/djvulibre-mime.xml