aboutsummaryrefslogtreecommitdiff
path: root/graphics/djvulibre
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-23 15:23:12 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-23 15:23:12 +0000
commitfd0623f3bb777f690b8c5d46c35845592acd69eb (patch)
tree7337cbcff981c19f9d3031851123e0affeeffa9e /graphics/djvulibre
parent6f0ef9f511ec5b92c9444853118d0144f5c198d9 (diff)
downloadports-fd0623f3bb777f690b8c5d46c35845592acd69eb.tar.gz
ports-fd0623f3bb777f690b8c5d46c35845592acd69eb.zip
Notes
Diffstat (limited to 'graphics/djvulibre')
-rw-r--r--graphics/djvulibre/Makefile26
-rw-r--r--graphics/djvulibre/distinfo2
-rw-r--r--graphics/djvulibre/files/patch-aa7
-rw-r--r--graphics/djvulibre/files/patch-ac5
-rw-r--r--graphics/djvulibre/pkg-plist220
5 files changed, 131 insertions, 129 deletions
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 61a97f1068c8..16c94ba6e2d5 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -6,34 +6,36 @@
#
PORTNAME= libdjvu++
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= graphics
-MASTER_SITES= http://www.djvu.com/open/
+MASTER_SITES= http://djvu.research.att.com/open/
MAINTAINER= mi@aldan.algebra.com
INSTALLS_SHLIB= yes
-IS_INTERACTIVE= yes
+IS_INTERACTIVE= some think, the AT&T license needs to be acked by the user
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= CXX=${CXX}
CONFIGURE_ARGS= --with-cxxflag="${CXXFLAGS}"
-MAKE_ARGS= OPT=""
+MAKE_ARGS= OPT="" -j 2
-post-extract:
+pre-patch:
${SH} ${WRKSRC}/RunMe
do-install:
-.for prog in djvuinfo c44 d44 djvutopnm djvumake djvuextract ppmcoco bzz
- ${INSTALL_PROGRAM} ${WRKSRC}/${prog} ${PREFIX}/bin
-.endfor
-.for lib in libdjvu++.a libdjvu++.so.2
- ${INSTALL_DATA} ${WRKSRC}/${lib} ${PREFIX}/lib
-.endfor
- ${LN} -sf libdjvu++.so.2 ${PREFIX}/lib/libdjvu++.so
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} c44 d44 djvutopnm djvumake \
+ djvuextract ppmcoco bzz djvuinfo ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libdjvu++.a ${WRKSRC}/libdjvu++.so.2* \
+ ${PREFIX}/lib
+ ${LN} -sf libdjvu++.so.2* ${PREFIX}/lib/libdjvu++.so
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/djvu
${INSTALL_DATA} ${WRKSRC}/@Doc/* ${PREFIX}/share/doc/djvu
+
+PLIST_SUB+= DOC=''
+.else
+PLIST_SUB+= DOC='@comment '
.endif
.include <bsd.port.mk>
diff --git a/graphics/djvulibre/distinfo b/graphics/djvulibre/distinfo
index 83a93eee79c9..4e7888d75912 100644
--- a/graphics/djvulibre/distinfo
+++ b/graphics/djvulibre/distinfo
@@ -1 +1 @@
-MD5 (libdjvu++-2.1.tar.gz) = b218b0ac7bffc6771c6c455f97fcb4eb
+MD5 (libdjvu++-2.1.1.tar.gz) = 7fe3287e218fd4f24ea9959d58a7df39
diff --git a/graphics/djvulibre/files/patch-aa b/graphics/djvulibre/files/patch-aa
deleted file mode 100644
index 213b2b6f2177..000000000000
--- a/graphics/djvulibre/files/patch-aa
+++ /dev/null
@@ -1,7 +0,0 @@
---- DjVuImage.cpp.orig Wed Mar 17 14:24:56 1999
-+++ DjVuImage.cpp Tue Jul 20 14:32:03 1999
-@@ -125,3 +125,3 @@
- GCriticalSectionLock lock(&mutex);
-- bs.writall((const void*)raw, raw.length());
-+ bs.writall((const char*)raw, raw.length());
- }
diff --git a/graphics/djvulibre/files/patch-ac b/graphics/djvulibre/files/patch-ac
index 4479876a3178..444b5236f853 100644
--- a/graphics/djvulibre/files/patch-ac
+++ b/graphics/djvulibre/files/patch-ac
@@ -10,7 +10,10 @@
- $(RANLIB) $(LIB)
+$(LIB): ${LIBOBJS:.o=.cpp}
+ ${MAKE} -f bsd.lib.mk CXX="${CXX}" OBJS="${LIBOBJS}" LIB=djvu++ \
-+ SHLIB_MAJOR=${VER:R} SHLIB_MINOR=${VER:E}
++ SHLIB_MAJOR=2 SHLIB_MINOR=1
+@@ -68 +67 @@
+-BZZOBJS = bzz.o BSByteStream.o ZPCodec.o ByteStream.o GException.o DjVuGlobal.o
++BZZOBJS = bzz.o
--- @Test/Makefile.in.orig Fri Mar 5 19:42:53 1999
+++ @Test/Makefile.in Tue Jul 20 18:00:24 1999
@@ -17 +17 @@
diff --git a/graphics/djvulibre/pkg-plist b/graphics/djvulibre/pkg-plist
index 2a3a0c5eb8a6..070cf80f2daa 100644
--- a/graphics/djvulibre/pkg-plist
+++ b/graphics/djvulibre/pkg-plist
@@ -8,111 +8,115 @@ bin/ppmcoco
bin/bzz
lib/libdjvu++.a
lib/libdjvu++.so
-lib/libdjvu++.so.2
-share/doc/djvu/ATTLicense.h.html
-share/doc/djvu/ATTLicense.html
-share/doc/djvu/ATTSourceCodeAgreement.html
-share/doc/djvu/BSByteStream.h.html
-share/doc/djvu/BSByteStream.html
-share/doc/djvu/BitContext.html
-share/doc/djvu/ByteStream.h.html
-share/doc/djvu/ByteStream.html
-share/doc/djvu/ClassGraph.class
-share/doc/djvu/ClassGraphPanel.class
-share/doc/djvu/ClassLayout.class
-share/doc/djvu/CompilingtheLibrarySystemsotherthanUnix.html
-share/doc/djvu/CompilingtheLibraryUnix.html
-share/doc/djvu/DJVUVERSION.html
-share/doc/djvu/DJVUVERSION_TOO_NEW.html
-share/doc/djvu/GArray.html
-share/doc/djvu/DJVUVERSION_TOO_OLD.html
-share/doc/djvu/DecodingDjVuContent.html
-share/doc/djvu/DjVuAnno.html
-share/doc/djvu/DjVuFileStructure.html
-share/doc/djvu/DjVuGlobal.h.html
-share/doc/djvu/DjVuImage.h.html
-share/doc/djvu/DjVuImage.html
-share/doc/djvu/DjVuImageFiles.html
-share/doc/djvu/DjVuInfo.html
-share/doc/djvu/DjVuInterface.html
-share/doc/djvu/DjVuMemory.html
-share/doc/djvu/DjVuNames.html
-share/doc/djvu/DjVuProgress.html
-share/doc/djvu/DjVuversionconstants.html
-share/doc/djvu/ExperimentalFeatures..html
-share/doc/djvu/GBitmap.h.html
-share/doc/djvu/GBitmap.html
-share/doc/djvu/GBitmapScaler.html
-share/doc/djvu/GContainer.h.html
-share/doc/djvu/GContainer.html
-share/doc/djvu/GContainerBase.html
-share/doc/djvu/GException.h.html
-share/doc/djvu/GException.html
-share/doc/djvu/GList.html
-share/doc/djvu/GMap.html
-share/doc/djvu/GMonitor.html
-share/doc/djvu/GMonitorLock.html
-share/doc/djvu/GOS.h.html
-share/doc/djvu/GOS.html
-share/doc/djvu/GP.html
-share/doc/djvu/GPBase.html
-share/doc/djvu/GPEnabled.html
-share/doc/djvu/GPixel.html
-share/doc/djvu/GPixmap.h.html
-share/doc/djvu/GPixmap.html
-share/doc/djvu/GPixmapScaler.html
-share/doc/djvu/GPosition.html
-share/doc/djvu/GRect.h.html
-share/doc/djvu/GRect.html
-share/doc/djvu/GSArray.html
-share/doc/djvu/GRectMapper.html
-share/doc/djvu/GScaler.h.html
-share/doc/djvu/GScaler.html
-share/doc/djvu/GSmartPointer.h.html
-share/doc/djvu/GString.h.html
-share/doc/djvu/GString.html
-share/doc/djvu/GThread.html
-share/doc/djvu/GThreads.h.html
-share/doc/djvu/GettingStarted.html
-share/doc/djvu/HIER.html
-share/doc/djvu/HIERjava.html
-share/doc/djvu/Hashfunctions.html
-share/doc/djvu/IFFByteStream.h.html
-share/doc/djvu/IFFByteStream.html
-share/doc/djvu/IW44ImageFiles.html
-share/doc/djvu/IWBitmap.html
-share/doc/djvu/IWEncoderParms.html
-share/doc/djvu/IWImage.h.html
-share/doc/djvu/IWPixmap.html
-share/doc/djvu/aindex.html
-share/doc/djvu/Introduction.html
-share/doc/djvu/JB2Blit.html
-share/doc/djvu/JB2Image.h.html
-share/doc/djvu/JB2Image.html
-share/doc/djvu/JB2Shape.html
-share/doc/djvu/LibraryReference.html
-share/doc/djvu/MemoryByteStream.html
-share/doc/djvu/NavigatorButton.class
-share/doc/djvu/PNMandRLEfileformats.html
-share/doc/djvu/StaticByteStream.html
-share/doc/djvu/StdioByteStream.html
-share/doc/djvu/UtilityPrograms.html
-share/doc/djvu/ZPCodec.h.html
-share/doc/djvu/ZPCodec.html
-share/doc/djvu/ZPCodecExamples.html
-share/doc/djvu/bzz.html
-share/doc/djvu/c44.html
-share/doc/djvu/d44.html
-share/doc/djvu/down.gif
-share/doc/djvu/djvuextract.html
-share/doc/djvu/djvuinfo.2.html
-share/doc/djvu/djvumake.html
-share/doc/djvu/djvutopnm.html
-share/doc/djvu/dxxgifs.tex
-share/doc/djvu/gifs.db
-share/doc/djvu/icon1.gif
-share/doc/djvu/icon2.gif
-share/doc/djvu/index.html
-share/doc/djvu/logo.gif
-share/doc/djvu/ppmcoco.html
-@dirrm share/doc/djvu
+lib/libdjvu++.so.2.1
+%%DOC%%share/doc/djvu/ATTLicense.h.html
+%%DOC%%share/doc/djvu/ATTLicense.html
+%%DOC%%share/doc/djvu/ATTSourceCodeAgreement.html
+%%DOC%%share/doc/djvu/BSByteStream.h.html
+%%DOC%%share/doc/djvu/BSByteStream.html
+%%DOC%%share/doc/djvu/BitContext.html
+%%DOC%%share/doc/djvu/ByteStream.h.html
+%%DOC%%share/doc/djvu/ByteStream.html
+%%DOC%%share/doc/djvu/ClassGraph.class
+%%DOC%%share/doc/djvu/ClassGraphPanel.class
+%%DOC%%share/doc/djvu/ClassLayout.class
+%%DOC%%share/doc/djvu/CompilingtheLibrarySystemsotherthanUnix.html
+%%DOC%%share/doc/djvu/CompilingtheLibraryUnix.html
+%%DOC%%share/doc/djvu/DJVUVERSION.html
+%%DOC%%share/doc/djvu/DJVUVERSION_TOO_NEW.html
+%%DOC%%share/doc/djvu/DJVUVERSION_TOO_OLD.html
+%%DOC%%share/doc/djvu/DecodingDjVuContent.html
+%%DOC%%share/doc/djvu/DjVuAnno.html
+%%DOC%%share/doc/djvu/DjVuFileStructure.html
+%%DOC%%share/doc/djvu/DjVuGlobal.h.html
+%%DOC%%share/doc/djvu/DjVuImage.h.html
+%%DOC%%share/doc/djvu/DjVuImage.html
+%%DOC%%share/doc/djvu/DjVuImageFiles.html
+%%DOC%%share/doc/djvu/DjVuInfo.html
+%%DOC%%share/doc/djvu/DjVuInterface.html
+%%DOC%%share/doc/djvu/DjVuMemory.html
+%%DOC%%share/doc/djvu/DjVuNames.html
+%%DOC%%share/doc/djvu/DjVuProgress.html
+%%DOC%%share/doc/djvu/DjVuversionconstants.html
+%%DOC%%share/doc/djvu/ExperimentalFeatures..html
+%%DOC%%share/doc/djvu/GArray.html
+%%DOC%%share/doc/djvu/GBitmap.h.html
+%%DOC%%share/doc/djvu/GBitmap.html
+%%DOC%%share/doc/djvu/GBitmapScaler.html
+%%DOC%%share/doc/djvu/GContainer.h.html
+%%DOC%%share/doc/djvu/GContainer.html
+%%DOC%%share/doc/djvu/GContainerBase.html
+%%DOC%%share/doc/djvu/GException.h.html
+%%DOC%%share/doc/djvu/GException.html
+%%DOC%%share/doc/djvu/GList.html
+%%DOC%%share/doc/djvu/GMap.html
+%%DOC%%share/doc/djvu/GMonitor.html
+%%DOC%%share/doc/djvu/GMonitorLock.html
+%%DOC%%share/doc/djvu/GOS.h.html
+%%DOC%%share/doc/djvu/GOS.html
+%%DOC%%share/doc/djvu/GP.html
+%%DOC%%share/doc/djvu/GPBase.html
+%%DOC%%share/doc/djvu/GPEnabled.html
+%%DOC%%share/doc/djvu/GPixel.html
+%%DOC%%share/doc/djvu/GPixmap.h.html
+%%DOC%%share/doc/djvu/GPixmap.html
+%%DOC%%share/doc/djvu/GPixmapScaler.html
+%%DOC%%share/doc/djvu/GPosition.html
+%%DOC%%share/doc/djvu/GRect.h.html
+%%DOC%%share/doc/djvu/GRect.html
+%%DOC%%share/doc/djvu/GRectMapper.html
+%%DOC%%share/doc/djvu/GSArray.html
+%%DOC%%share/doc/djvu/GScaler.h.html
+%%DOC%%share/doc/djvu/GScaler.html
+%%DOC%%share/doc/djvu/GSmartPointer.h.html
+%%DOC%%share/doc/djvu/GString.h.html
+%%DOC%%share/doc/djvu/GString.html
+%%DOC%%share/doc/djvu/GThread.html
+%%DOC%%share/doc/djvu/GThreads.h.html
+%%DOC%%share/doc/djvu/General.html
+%%DOC%%share/doc/djvu/GettingStarted.html
+%%DOC%%share/doc/djvu/HIER.html
+%%DOC%%share/doc/djvu/HIERjava.html
+%%DOC%%share/doc/djvu/Hashfunctions.html
+%%DOC%%share/doc/djvu/IFFByteStream.h.html
+%%DOC%%share/doc/djvu/IFFByteStream.html
+%%DOC%%share/doc/djvu/IW44ImageFiles.html
+%%DOC%%share/doc/djvu/IWBitmap.html
+%%DOC%%share/doc/djvu/IWEncoderParms.html
+%%DOC%%share/doc/djvu/IWImage.h.html
+%%DOC%%share/doc/djvu/IWPixmap.html
+%%DOC%%share/doc/djvu/Introduction.html
+%%DOC%%share/doc/djvu/JB2Blit.html
+%%DOC%%share/doc/djvu/JB2Image.h.html
+%%DOC%%share/doc/djvu/JB2Image.html
+%%DOC%%share/doc/djvu/JB2Shape.html
+%%DOC%%share/doc/djvu/LibraryReference.html
+%%DOC%%share/doc/djvu/MemoryByteStream.html
+%%DOC%%share/doc/djvu/NavigatorButton.class
+%%DOC%%share/doc/djvu/PNMandRLEfileformats.html
+%%DOC%%share/doc/djvu/StaticByteStream.html
+%%DOC%%share/doc/djvu/StdioByteStream.html
+%%DOC%%share/doc/djvu/UtilityPrograms.html
+%%DOC%%share/doc/djvu/ZPCodec.h.html
+%%DOC%%share/doc/djvu/ZPCodec.html
+%%DOC%%share/doc/djvu/ZPCodecExamples.html
+%%DOC%%share/doc/djvu/bzz.html
+%%DOC%%share/doc/djvu/c44.html
+%%DOC%%share/doc/djvu/d44.html
+%%DOC%%share/doc/djvu/djvuextract.html
+%%DOC%%share/doc/djvu/djvuinfo.2.html
+%%DOC%%share/doc/djvu/djvumake.html
+%%DOC%%share/doc/djvu/djvutopnm.html
+%%DOC%%share/doc/djvu/down.gif
+%%DOC%%share/doc/djvu/hash.2.html
+%%DOC%%share/doc/djvu/hash.3.html
+%%DOC%%share/doc/djvu/hash.4.html
+%%DOC%%share/doc/djvu/hash.5.html
+%%DOC%%share/doc/djvu/hash.6.html
+%%DOC%%share/doc/djvu/hash.html
+%%DOC%%share/doc/djvu/icon1.gif
+%%DOC%%share/doc/djvu/icon2.gif
+%%DOC%%share/doc/djvu/index.html
+%%DOC%%share/doc/djvu/logo.gif
+%%DOC%%share/doc/djvu/ppmcoco.html
+%%DOC%%@dirrm share/doc/djvu