aboutsummaryrefslogtreecommitdiff
path: root/graphics/dri
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /graphics/dri
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
Notes
Diffstat (limited to 'graphics/dri')
-rw-r--r--graphics/dri/Makefile21
-rw-r--r--graphics/dri/distinfo6
-rw-r--r--graphics/dri/files/patch-945gm43
-rw-r--r--graphics/dri/files/patch-freebsd-dri47
-rw-r--r--graphics/dri/files/patch-glheader.h22
-rw-r--r--graphics/dri/files/patch-mach64_context.h37
-rw-r--r--graphics/dri/files/patch-sis_context.h24
-rw-r--r--graphics/dri/pkg-plist29
8 files changed, 114 insertions, 115 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 58b60c4f741a..62e445c03d36 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dri
-PORTVERSION= 6.4.1
+PORTVERSION= 6.5.3
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -17,7 +17,7 @@ MAINTAINER= anholt@FreeBSD.org
COMMENT= OpenGL hardware acceleration drivers for the DRI
LIB_DEPENDS= drm:${PORTSDIR}/graphics/libdrm
-BUILD_DEPENDS= makedepend:${X_IMAKE_PORT}
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
CONFLICTS= xfree86-dri-* dri-6.2.2005* dri-6.5.2006*
@@ -30,9 +30,7 @@ MAKE_ENV+= FBSDCC="${CC}" FBSDCXX="${CXX}" \
PTHREAD_LIBS=${PTHREAD_LIBS}
USE_GCC= 3.4+
-ONLY_FOR_ARCHS= i386 alpha amd64
-
-DRIMODDIR= ${PREFIX}/lib/modules/dri
+DRIMODDIR= ${PREFIX}/lib/dri
.include <bsd.port.pre.mk>
@@ -44,8 +42,8 @@ do-install:
${MKDIR} ${DRIMODDIR}
.if ${ARCH} == i386
${INSTALL_PROGRAM} ${WRKSRC}/lib/i810_dri.so ${DRIMODDIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/i830_dri.so ${DRIMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/lib/i915_dri.so ${DRIMODDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/i965_dri.so ${DRIMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/lib/unichrome_dri.so ${DRIMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/lib/tdfx_dri.so ${DRIMODDIR}
.elif ${ARCH} == amd64
@@ -62,11 +60,20 @@ do-install:
.if ${OSVERSION} < 500000
pre-patch:
- ${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|g' \
+ @${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|g' \
${WRKSRC}/src/mesa/drivers/dri/mga/mga_xmesa.c \
${WRKSRC}/src/mesa/drivers/dri/mga/mgacontext.h
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC =/d' -e '/^CXX =/d' \
+ -e 's|/usr/local|$$(LOCALBASE)|g' \
+ -e 's|/usr/X11R6|$$(X11BASE)|g' \
+ -e 's|-lpthread|$$(PTHREAD_LIBS)|g' \
+ -e 's|^\(SRC_DIRS =\).*|\1 mesa|' \
+ -e 's|-DHAVE_POSIX_MEMALIGN||' \
+ ${WRKSRC}/configs/freebsd-dri
+
.if ${ARCH} == i386
PLIST_SUB+= I386=""
PLIST_SUB+= I386_AMD64=""
diff --git a/graphics/dri/distinfo b/graphics/dri/distinfo
index 9a6d42ae290c..127cae9262ef 100644
--- a/graphics/dri/distinfo
+++ b/graphics/dri/distinfo
@@ -1,3 +1,3 @@
-MD5 (MesaLib-6.4.1.tar.bz2) = ea148c828ec6f645526451db1b8556f1
-SHA256 (MesaLib-6.4.1.tar.bz2) = 2c1c8784cccab416a52ef9512e3539a0063b88dcc9b0abbcf1a407f9808758cf
-SIZE (MesaLib-6.4.1.tar.bz2) = 2913887
+MD5 (MesaLib-6.5.3.tar.bz2) = 46359457147c469745f24b5074a186f0
+SHA256 (MesaLib-6.5.3.tar.bz2) = f8b09b40b59d6951dcd9889d19a67d1995c5f558bafa1e978f4b0e88035a96b3
+SIZE (MesaLib-6.5.3.tar.bz2) = 3351899
diff --git a/graphics/dri/files/patch-945gm b/graphics/dri/files/patch-945gm
deleted file mode 100644
index f65cdb09ce71..000000000000
--- a/graphics/dri/files/patch-945gm
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/mesa/drivers/dri/i915/intel_screen.c.orig Fri Apr 6 16:49:46 2007
-+++ src/mesa/drivers/dri/i915/intel_screen.c Fri Apr 6 16:50:04 2007
-@@ -340,6 +340,7 @@
- case PCI_CHIP_I915_G:
- case PCI_CHIP_I915_GM:
- case PCI_CHIP_I945_G:
-+ case PCI_CHIP_I945_GM:
- return i915CreateContext( mesaVis, driContextPriv,
- sharedContextPrivate );
-
---- src/mesa/drivers/dri/i915/intel_context.c.orig Fri Apr 6 16:45:51 2007
-+++ src/mesa/drivers/dri/i915/intel_context.c Fri Apr 6 16:46:20 2007
-@@ -118,6 +118,8 @@
- chipset = "Intel(R) 915GM"; break;
- case PCI_CHIP_I945_G:
- chipset = "Intel(R) 945G"; break;
-+ case PCI_CHIP_I945_GM:
-+ chipset = "Intel(R) 945GM"; break;
- default:
- chipset = "Unknown Intel Chipset"; break;
- }
---- src/mesa/drivers/dri/i915/i915_texstate.c.orig Fri Apr 6 16:48:21 2007
-+++ src/mesa/drivers/dri/i915/i915_texstate.c Fri Apr 6 16:48:48 2007
-@@ -496,7 +496,8 @@
- }
-
-
-- if (i915->intel.intelScreen->deviceID == PCI_CHIP_I945_G)
-+ if (i915->intel.intelScreen->deviceID == PCI_CHIP_I945_G ||
-+ i915->intel.intelScreen->deviceID == PCI_CHIP_I945_GM)
- i945LayoutTextureImages( i915, tObj );
- else
- i915LayoutTextureImages( i915, tObj );
---- src/mesa/drivers/dri/i915/intel_context.h.orig Fri Apr 6 16:49:05 2007
-+++ src/mesa/drivers/dri/i915/intel_context.h Fri Apr 6 16:49:31 2007
-@@ -413,6 +413,7 @@
- #define PCI_CHIP_I915_G 0x2582
- #define PCI_CHIP_I915_GM 0x2592
- #define PCI_CHIP_I945_G 0x2772
-+#define PCI_CHIP_I945_GM 0x27A2
-
-
- /* ================================================================
diff --git a/graphics/dri/files/patch-freebsd-dri b/graphics/dri/files/patch-freebsd-dri
deleted file mode 100644
index bd9cdbcb03b9..000000000000
--- a/graphics/dri/files/patch-freebsd-dri
+++ /dev/null
@@ -1,47 +0,0 @@
---- configs/freebsd-dri.orig Tue Oct 25 01:11:57 2005
-+++ configs/freebsd-dri Fri Dec 30 00:58:57 2005
-@@ -6,32 +6,32 @@
- CONFIG_NAME = freebsd-dri
-
- # Compiler and flags
--CC = gcc
--CXX = g++
-+CC = $(FBSDCC)
-+CXX = $(FBSDCXX)
- WARN_FLAGS = -Wall
--OPT_FLAGS = -O
-+OPT_FLAGS = $(FBSDCFLAGS)
-
--EXPAT_INCLUDES = -I/usr/local/include
--X11_INCLUDES = -I/usr/X11R6/include
-+EXPAT_INCLUDES = -I${LOCALBASE}/include
-+X11_INCLUDES = -I${X11BASE}/include -I${X11BASE}/include/X11/extensions
- DEFINES = -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER \
- -DGLX_DIRECT_RENDERING -DHAVE_ALIAS
--CFLAGS = $(DEFINES) -Wmissing-prototypes -g -std=c99 -Wundef -fPIC \
-- -ffast-math $(X11_INCLUDES)
-+CFLAGS = $(FBSDCFLAGS) $(DEFINES) -Wmissing-prototypes -g -std=c99 -Wundef \
-+ -fPIC -ffast-math $(X11_INCLUDES)
- CXXFLAGS = $(DEFINES) -Wall -g -ansi -pedantic -fPIC
-
- ASM_SOURCES =
-
- # Library/program dependencies
- LIBDRM_LIB = `pkg-config --libs libdrm` -ldrm
--DRI_LIB_DEPS = -L/usr/local/lib -lm -lpthread -lexpat $(LIBDRM_LIB)
--GL_LIB_DEPS = -L/usr/X11R6/lib -lX11 -lXext -lm -lpthread $(LIBDRM_LIB)
-+DRI_LIB_DEPS = -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS} -lexpat $(LIBDRM_LIB)
-+GL_LIB_DEPS = -L${X11BASE}/lib -lX11 -lXext -lm ${PTHREAD_LIBS} $(LIBDRM_LIB)
-
--GLUT_LIB_DEPS = -L$(LIB_DIR) -L/usr/X11R6/lib -lGLU -lGL -lX11 -lXmu -lXt -lXi -lm
--GLW_LIB_DEPS = -L$(LIB_DIR) -L/usr/X11R6/lib -lGL -lXt -lXm -lX11
-+GLUT_LIB_DEPS = -L$(LIB_DIR) -L${X11BASE}/lib -lGLU -lGL -lX11 -lXmu -lXt -lXi -lm
-+GLW_LIB_DEPS = -L$(LIB_DIR) -L${X11BASE}/lib -lGL -lXt -lXm -lX11
-
-
- # Directories
--SRC_DIRS = glx/x11 mesa glu glut/glx glw
-+SRC_DIRS = mesa
- DRIVER_DIRS = dri
- PROGRAM_DIRS =
- WINDOW_SYSTEM=dri
diff --git a/graphics/dri/files/patch-glheader.h b/graphics/dri/files/patch-glheader.h
new file mode 100644
index 000000000000..517e46012c02
--- /dev/null
+++ b/graphics/dri/files/patch-glheader.h
@@ -0,0 +1,22 @@
+--- src/mesa/main/glheader.h.orig Thu Apr 13 01:52:32 2006
++++ src/mesa/main/glheader.h Wed Dec 20 15:27:53 2006
+@@ -127,12 +127,15 @@
+ * For now, only used by some DRI hardware drivers for color/texel packing.
+ */
+ #if defined(BYTE_ORDER) && defined(BIG_ENDIAN) && BYTE_ORDER == BIG_ENDIAN
+-#if defined(__linux__)
++#if defined(__FreeBSD__)
++#include <sys/endian.h>
++#define CPU_TO_LE32( x ) bswap32( x )
++#elif defined(__linux__)
+ #include <byteswap.h>
+ #define CPU_TO_LE32( x ) bswap_32( x )
+-#else /*__linux__*/
+-#define CPU_TO_LE32( x ) ( x ) /* fix me for non-Linux big-endian! */
+-#endif /*__linux__*/
++#else
++#error "Add CPU_TO_LE32 macro for this OS."
++#endif
+ #define MESA_BIG_ENDIAN 1
+ #else
+ #define CPU_TO_LE32( x ) ( x )
diff --git a/graphics/dri/files/patch-mach64_context.h b/graphics/dri/files/patch-mach64_context.h
new file mode 100644
index 000000000000..bc17aea756ac
--- /dev/null
+++ b/graphics/dri/files/patch-mach64_context.h
@@ -0,0 +1,37 @@
+--- src/mesa/drivers/dri/mach64/mach64_context.h.orig Mon Nov 28 13:17:16 2005
++++ src/mesa/drivers/dri/mach64/mach64_context.h Wed Dec 20 15:37:34 2006
+@@ -331,25 +331,28 @@
+ /* ================================================================
+ * Byte ordering
+ */
+-#if MESA_LITTLE_ENDIAN == 1
++#if defined(MESA_LITTLE_ENDIAN) && MESA_LITTLE_ENDIAN == 1
+ #define LE32_IN( x ) ( *(GLuint *)(x) )
+ #define LE32_IN_FLOAT( x ) ( *(GLfloat *)(x) )
+ #define LE32_OUT( x, y ) do { *(GLuint *)(x) = (y); } while (0)
+ #define LE32_OUT_FLOAT( x, y ) do { *(GLfloat *)(x) = (y); } while (0)
+ #else
+-#include <byteswap.h>
+-#define LE32_IN( x ) bswap_32( *(GLuint *)(x) )
++#define LE32_IN( x ) CPU_TO_LE32( *(GLuint *)(x) )
+ #define LE32_IN_FLOAT( x ) \
+ ({ \
+- GLuint __tmp = bswap_32( *(GLuint *)(x) ); \
++ GLuint __tmp = CPU_TO_LE32( *(GLuint *)(x) ); \
+ *(GLfloat *)&__tmp; \
+ })
+-#define LE32_OUT( x, y ) do { *(GLuint *)(x) = bswap_32( y ); } while (0)
++#define LE32_OUT( x, y ) do { *(GLuint *)(x) = CPU_TO_LE32( y ); } while (0)
++#define LE32_OUT( x, y ) \
++do { \
++ *(GLuint *)(x) = CPU_TO_LE32( y ); \
++} while (0)
+ #define LE32_OUT_FLOAT( x, y ) \
+ do { \
+ GLuint __tmp; \
+ *(GLfloat *)&__tmp = (y); \
+- *(GLuint *)(x) = bswap_32( __tmp ); \
++ *(GLuint *)(x) = CPU_TO_LE32( __tmp ); \
+ } while (0)
+ #endif
+
diff --git a/graphics/dri/files/patch-sis_context.h b/graphics/dri/files/patch-sis_context.h
new file mode 100644
index 000000000000..1d79d5f32263
--- /dev/null
+++ b/graphics/dri/files/patch-sis_context.h
@@ -0,0 +1,24 @@
+--- src/mesa/drivers/dri/sis/sis_context.h.orig Tue Apr 11 13:41:11 2006
++++ src/mesa/drivers/dri/sis/sis_context.h Wed Dec 20 18:32:46 2006
+@@ -401,8 +401,20 @@
+ #define MMIO_READ(reg) *(volatile GLint *)(smesa->IOBase + (reg))
+ #define MMIO_READf(reg) *(volatile GLfloat *)(smesa->IOBase + (reg))
+
+-#if defined(__i386__) || defined(__amd64__)
++#if defined(__alpha__)
++#define MMIO_WMB() __asm __volatile("wmb" : : : "memory")
++#elif defined(__amd64__) || defined(__i386__)
+ #define MMIO_WMB() __asm __volatile("" : : : "memory")
++#elif defined(__ia64__)
++#define MMIO_WMB() __asm __volatile("mf" : : : "memory")
++#elif defined(__powerpc__)
++#define MMIO_WMB() __asm __volatile("eieio" : : : "memory")
++#elif defined(__sparc64__)
++/*
++ * #StoreStore probably would be sufficient for this driver at the
++ * time of this writing but we use #Sync for safety.
++ */
++#define MMIO_WMB() __asm __volatile("membar #Sync" : : : "memory")
+ #else
+ #error platform needs WMB
+ #endif
diff --git a/graphics/dri/pkg-plist b/graphics/dri/pkg-plist
index 337a52357957..16d886a121d2 100644
--- a/graphics/dri/pkg-plist
+++ b/graphics/dri/pkg-plist
@@ -1,15 +1,14 @@
-%%I386%%lib/modules/dri/i810_dri.so
-%%I386%%lib/modules/dri/i830_dri.so
-%%I386_AMD64%%lib/modules/dri/i915_dri.so
-lib/modules/dri/mach64_dri.so
-lib/modules/dri/mga_dri.so
-lib/modules/dri/r128_dri.so
-lib/modules/dri/r200_dri.so
-lib/modules/dri/r300_dri.so
-lib/modules/dri/radeon_dri.so
-lib/modules/dri/savage_dri.so
-lib/modules/dri/sis_dri.so
-%%I386%%lib/modules/dri/tdfx_dri.so
-%%I386%%lib/modules/dri/unichrome_dri.so
-@dirrm lib/modules/dri
-@dirrmtry lib/modules
+%%I386%%lib/dri/i810_dri.so
+%%I386_AMD64%%lib/dri/i915_dri.so
+%%I386%%lib/dri/i965_dri.so
+lib/dri/mach64_dri.so
+lib/dri/mga_dri.so
+lib/dri/r128_dri.so
+lib/dri/r200_dri.so
+lib/dri/r300_dri.so
+lib/dri/radeon_dri.so
+lib/dri/savage_dri.so
+lib/dri/sis_dri.so
+%%I386%%lib/dri/tdfx_dri.so
+%%I386%%lib/dri/unichrome_dri.so
+@dirrm lib/dri