aboutsummaryrefslogtreecommitdiff
path: root/graphics/dri
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-02-14 07:08:27 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-02-14 07:08:27 +0000
commit6bb073992e2b385b6f8ce91cf6f8d1d786e593ab (patch)
tree0cdcbd9c7aafa3de19ebe51cdd66357623a8d36b /graphics/dri
parent37c9e825b1cec0a7bdb33c248720ea326400bc6e (diff)
downloadports-6bb073992e2b385b6f8ce91cf6f8d1d786e593ab.tar.gz
ports-6bb073992e2b385b6f8ce91cf6f8d1d786e593ab.zip
Notes
Diffstat (limited to 'graphics/dri')
-rw-r--r--graphics/dri/Makefile8
-rw-r--r--graphics/dri/distinfo4
-rw-r--r--graphics/dri/files/patch-xf86drm.h11
3 files changed, 17 insertions, 6 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 62ca4c55414a..52eda6467f3e 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= dri
-PORTVERSION= 6.2
-PORTREVISION= 2
+PORTVERSION= 6.2.1
PORTEPOCH= 2
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~anholt/dri/
MASTER_SITE_SUBDIR= anholt
-DISTFILES= Mesa-6.2-20050109.tar.bz2 \
+DISTFILES= Mesa-6.2.1-20050213.tar.bz2 \
drm-20050109.tar.bz2
MAINTAINER= anholt@FreeBSD.org
diff --git a/graphics/dri/distinfo b/graphics/dri/distinfo
index 6c3b1830a413..28343c8a1c9c 100644
--- a/graphics/dri/distinfo
+++ b/graphics/dri/distinfo
@@ -1,4 +1,4 @@
-MD5 (Mesa-6.2-20050109.tar.bz2) = 70e8d5d08c9b96629cdc21f674d50ba5
-SIZE (Mesa-6.2-20050109.tar.bz2) = 4128962
+MD5 (Mesa-6.2.1-20050213.tar.bz2) = c6904904735489f728d79897c55260cb
+SIZE (Mesa-6.2.1-20050213.tar.bz2) = 4131581
MD5 (drm-20050109.tar.bz2) = c16b1f51a589eb6cad8dc85c4db0e1ce
SIZE (drm-20050109.tar.bz2) = 507130
diff --git a/graphics/dri/files/patch-xf86drm.h b/graphics/dri/files/patch-xf86drm.h
new file mode 100644
index 000000000000..89993ddaaa45
--- /dev/null
+++ b/graphics/dri/files/patch-xf86drm.h
@@ -0,0 +1,11 @@
+--- src/mesa/drivers/dri/dri_client/imports/xf86drm.h.orig Sun Feb 13 22:44:48 2005
++++ src/mesa/drivers/dri/dri_client/imports/xf86drm.h Sun Feb 13 22:44:55 2005
+@@ -285,7 +285,7 @@
+ #define DRM_LOCK_CONT 0x40000000 /**< Hardware lock is contended */
+
+ #if defined(__GNUC__) && (__GNUC__ >= 2)
+-# if defined(__i386) || defined(__AMD64__)
++# if defined(__i386) || defined(__amd64__)
+ /* Reflect changes here to drmP.h */
+ #define DRM_CAS(lock,old,new,__ret) \
+ do { \