aboutsummaryrefslogtreecommitdiff
path: root/graphics/drm-devel-kmod
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-07-14 08:16:55 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-07-14 08:16:55 +0000
commitd4a4adf9c7ab91f7137fd3e918e439106b5f5cda (patch)
tree8c56ebf12924a9b4ba8c2ff760081e6a5399be03 /graphics/drm-devel-kmod
parentb653669e14092f55402ef0f33a5b4ca7e0448ae4 (diff)
downloadports-d4a4adf9c7ab91f7137fd3e918e439106b5f5cda.tar.gz
ports-d4a4adf9c7ab91f7137fd3e918e439106b5f5cda.zip
Add new port: graphics/drm-devel-kmod.
Add new port: graphics/drm-devel-kmod. This is a development version of the drm kmod ports. It is currently on par with Linux version 4.15, which includes amongs others support for AMD Vega. This version is currently only supported on recent versions of FreeBSD CURRENT. Be aware that since this is a development version, there might be bugs and regressions. If you find any issues, please report them to us. Approved by: jmd (maintainer) Obtained from: https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/drm-kmod
Notes
Notes: svn path=/head/; revision=474624
Diffstat (limited to 'graphics/drm-devel-kmod')
-rw-r--r--graphics/drm-devel-kmod/Makefile39
-rw-r--r--graphics/drm-devel-kmod/distinfo3
-rw-r--r--graphics/drm-devel-kmod/pkg-descr5
-rw-r--r--graphics/drm-devel-kmod/pkg-message15
-rw-r--r--graphics/drm-devel-kmod/pkg-plist7
5 files changed, 69 insertions, 0 deletions
diff --git a/graphics/drm-devel-kmod/Makefile b/graphics/drm-devel-kmod/Makefile
new file mode 100644
index 000000000000..cc3adb0b9522
--- /dev/null
+++ b/graphics/drm-devel-kmod/Makefile
@@ -0,0 +1,39 @@
+# Created by: Johannes Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-devel-kmod
+PORTVERSION= 4.15.g20180713
+CATEGORIES= graphics kld
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= DRM modules for the linuxkpi-based KMS components (development version)
+
+LICENSE= BSD2CLAUSE MIT GPLv2
+LICENSE_COMB= multi
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= the new KMS components are only supported on amd64
+
+RUN_DEPENDS= gpu-firmware-kmod>=g20180319:graphics/gpu-firmware-kmod
+
+CONFLICTS_INSTALL= drm-next-kmod drm-stable-kmod
+
+OPTIONS_DEFINE= DEBUG
+
+USES= kmod uidfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= FreeBSDDesktop
+GH_PROJECT= kms-drm
+GH_TAGNAME= 224e101
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200067
+IGNORE= not supported on older CURRENT, no kernel support
+.endif
+.if ${OPSYS} != FreeBSD
+IGNORE= not supported on anything but FreeBSD (missing linuxkpi functionality)
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/drm-devel-kmod/distinfo b/graphics/drm-devel-kmod/distinfo
new file mode 100644
index 000000000000..85e719e97804
--- /dev/null
+++ b/graphics/drm-devel-kmod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531495898
+SHA256 (FreeBSDDesktop-kms-drm-4.15.g20180713-224e101_GH0.tar.gz) = c1f6e0b3fe85adee2693dbd1b5e08bb395aa92289deff86e7b2fb9f2b8af6ef9
+SIZE (FreeBSDDesktop-kms-drm-4.15.g20180713-224e101_GH0.tar.gz) = 13101788
diff --git a/graphics/drm-devel-kmod/pkg-descr b/graphics/drm-devel-kmod/pkg-descr
new file mode 100644
index 000000000000..150a80eca58d
--- /dev/null
+++ b/graphics/drm-devel-kmod/pkg-descr
@@ -0,0 +1,5 @@
+amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components.
+Currently corresponding to Linux 4.15 DRM. This is the development version.
+amdgpu and radeonkms are known to fail with EFI boot.
+
+WWW: https://github.com/FreeBSDDesktop/kms-drm
diff --git a/graphics/drm-devel-kmod/pkg-message b/graphics/drm-devel-kmod/pkg-message
new file mode 100644
index 000000000000..210413ff29c3
--- /dev/null
+++ b/graphics/drm-devel-kmod/pkg-message
@@ -0,0 +1,15 @@
+The experimental drm-next-kmod port can be enabled for amdgpu (for AMD
+GPUs starting with the HD7000 series / Tahiti) or i915kms (for Intel
+APUs starting with HD3000 / Sandy Bridge) through kld_list in
+/etc/rc.conf. radeonkms for older AMD GPUs can be loaded and there are
+some positive reports if EFI boot is NOT enabled (similar to amdgpu).
+
+For amdgpu: kld_list="amdgpu"
+For Intel: kld_list="/boot/modules/i915kms.ko"
+For radeonkms: kld_list="/boot/modules/radeonkms.ko"
+
+Please ensure that all users requiring graphics are members of the
+"video" group.
+
+Older generations are supported by the stable kms modules (radeonkms /
+i915kms) in base.
diff --git a/graphics/drm-devel-kmod/pkg-plist b/graphics/drm-devel-kmod/pkg-plist
new file mode 100644
index 000000000000..8930f98d203a
--- /dev/null
+++ b/graphics/drm-devel-kmod/pkg-plist
@@ -0,0 +1,7 @@
+/%%KMODDIR%%/amdgpu.ko
+/%%KMODDIR%%/amdkfd.ko
+/%%KMODDIR%%/debugfs.ko
+/%%KMODDIR%%/drm.ko
+/%%KMODDIR%%/i915kms.ko
+/%%KMODDIR%%/linuxkpi_gplv2.ko
+/%%KMODDIR%%/radeonkms.ko