aboutsummaryrefslogtreecommitdiff
path: root/graphics/dynamechs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 14:29:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 14:29:28 +0000
commit5c93dd25c8efe643e0b0811cc827f5b790195d22 (patch)
tree6f27faae8d66a80d741ca19ae5da01b7ffb92cc7 /graphics/dynamechs
parent81d0f2b19b64e912890ac54ad10217feb0c8d317 (diff)
downloadports-5c93dd25c8efe643e0b0811cc827f5b790195d22.tar.gz
ports-5c93dd25c8efe643e0b0811cc827f5b790195d22.zip
Notes
Diffstat (limited to 'graphics/dynamechs')
-rw-r--r--graphics/dynamechs/Makefile24
-rw-r--r--graphics/dynamechs/files/make.platform.freebsd2
-rw-r--r--graphics/dynamechs/files/patch-aquarobot::Gait.hpp27
-rw-r--r--graphics/dynamechs/files/patch-aquarobot__MatrixMy.cpp11
-rw-r--r--graphics/dynamechs/files/patch-dm__svd_linpack.cpp13
5 files changed, 57 insertions, 20 deletions
diff --git a/graphics/dynamechs/Makefile b/graphics/dynamechs/Makefile
index 8b46bac9fd58..db97b4fe2347 100644
--- a/graphics/dynamechs/Makefile
+++ b/graphics/dynamechs/Makefile
@@ -10,32 +10,32 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/4.0pre1
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Multibody Dynamic Simulation Library
+COMMENT= Multibody Dynamic Simulation Library
-USES= perl5
USE_BZIP2= yes
+USES= gmake perl5
USE_GL= glut
-USE_GMAKE= yes
USE_PERL5= build
-CXXFLAGS+= ${PTHREAD_CFLAGS}
MAKE_ENV= OPENGLINCDIR="${LOCALBASE}/include" \
OPENGLLIBDIR="${LOCALBASE}/lib"
-LDFLAGS+= ${PTHREAD_LIBS}
ALL_TARGET= freebsd
USE_LDCONFIG= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|.SILENT:||' ${WRKSRC}/Makefile
do-configure:
@${CP} -f ${FILESDIR}/make.platform.freebsd ${WRKSRC}/make/
do-install:
.for dir in dm dmu dmGL
- ${RM} -f ${WRKSRC}/${dir}/*.orig
- @${MKDIR} ${PREFIX}/include/${PORTNAME}/${dir}
- ${INSTALL_DATA} ${WRKSRC}/${dir}/*.h* ${PREFIX}/include/${PORTNAME}/${dir}
- ${INSTALL_DATA} ${WRKSRC}/lib/platform.freebsd/lib${dir}.so ${PREFIX}/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}/${dir}
+ (cd ${WRKSRC}/${dir} && ${FIND} . -name "*.h" -or -name "*.hpp" | \
+ ${XARGS} -J % ${INSTALL_DATA} % \
+ ${STAGEDIR}${PREFIX}/include/${PORTNAME}/${dir})
+ (cd ${WRKSRC}/lib/platform.freebsd && ${INSTALL_LIB} lib${dir}.so \
+ ${STAGEDIR}${PREFIX}/lib)
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/dynamechs/files/make.platform.freebsd b/graphics/dynamechs/files/make.platform.freebsd
index 17c2f959b6b4..0385b3351517 100644
--- a/graphics/dynamechs/files/make.platform.freebsd
+++ b/graphics/dynamechs/files/make.platform.freebsd
@@ -2,7 +2,7 @@ CXXFLAGS += -D_BOOL -c -fPIC -I/$(OPENGLINCDIR)
# -pthreads
DEPENDFLAGS := $(CXXFLAGS)
-LDFLAGS += -fPIC -L/$(OPENGLLIBDIR) -L${LOCALBASE}/lib -lX11 -lm -l$(MESA)GLU -l$(MESA)GL
+LDFLAGS += -pthread -fPIC -L/$(OPENGLLIBDIR) -L${LOCALBASE}/lib -lX11 -lm -l$(MESA)GLU -l$(MESA)GL
LDGLUT := -lglut
# CXX := c++
diff --git a/graphics/dynamechs/files/patch-aquarobot::Gait.hpp b/graphics/dynamechs/files/patch-aquarobot::Gait.hpp
index b66e98a2082a..184c2444adc5 100644
--- a/graphics/dynamechs/files/patch-aquarobot::Gait.hpp
+++ b/graphics/dynamechs/files/patch-aquarobot::Gait.hpp
@@ -1,15 +1,28 @@
---- aquarobot/Gait.hpp.orig Thu Jul 19 08:40:44 2001
-+++ aquarobot/Gait.hpp Sat Dec 21 08:57:01 2002
-@@ -26,10 +26,11 @@
+--- aquarobot/Gait.hpp.orig 2001-07-19 08:40:44.000000000 +0900
++++ aquarobot/Gait.hpp 2014-01-08 21:46:35.000000000 +0900
+@@ -26,24 +26,17 @@
#include <windows.h>
#endif
-#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91))
-+#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91)) || (defined(__GNUC__) && (__GNUC__>=3))
#include <iostream>
#include <iomanip>
#include <fstream>
+-#else
+-#include <iostream.h>
+-#include <iomanip.h>
+-#include <fstream.h>
+-#endif
+using namespace std;
- #else
- #include <iostream.h>
- #include <iomanip.h>
+
+ #include <math.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+
+ // Use the std namespace. To do this we must first guarantee that it exists.
+-#if defined(__sgi) || defined(__WIN32_) || defined(WIN32)
+ namespace std {}
+ using namespace std;
+-#endif
+
+ #endif
diff --git a/graphics/dynamechs/files/patch-aquarobot__MatrixMy.cpp b/graphics/dynamechs/files/patch-aquarobot__MatrixMy.cpp
new file mode 100644
index 000000000000..c568e4ab9c25
--- /dev/null
+++ b/graphics/dynamechs/files/patch-aquarobot__MatrixMy.cpp
@@ -0,0 +1,11 @@
+--- aquarobot/MatrixMy.cpp.orig
++++ aquarobot/MatrixMy.cpp
+@@ -38,7 +38,7 @@
+ // Constructor
+ // **************************************************************************
+ //MatrixMy::MatrixMy(int r = 4, int c = 4)
+-MatrixMy::MatrixMy(int r = 3, int c = 3)
++MatrixMy::MatrixMy(int r, int c)
+ {
+ row = r;
+ column = c;
diff --git a/graphics/dynamechs/files/patch-dm__svd_linpack.cpp b/graphics/dynamechs/files/patch-dm__svd_linpack.cpp
new file mode 100644
index 000000000000..659246f78e7b
--- /dev/null
+++ b/graphics/dynamechs/files/patch-dm__svd_linpack.cpp
@@ -0,0 +1,13 @@
+--- dm/svd_linpack.cpp.orig
++++ dm/svd_linpack.cpp
+@@ -10,7 +10,9 @@
+ #endif
+
+ #include <stdio.h>
+-#include <iomanip.h>
++#include <iostream>
++#include <iomanip>
++using namespace std;
+
+ #ifdef __cplusplus
+ extern "C" {