aboutsummaryrefslogtreecommitdiff
path: root/graphics/dynamechs
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-11-20 04:08:13 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-11-20 04:08:13 +0000
commit8902a20e43b0e2917d2afa4b60514b32d30adccf (patch)
tree9851caf9a412d9fe6ccf14e55fc3f8085598cf08 /graphics/dynamechs
parent4eb86c39dabc12092a566969f9b36972724dd327 (diff)
downloadports-8902a20e43b0e2917d2afa4b60514b32d30adccf.tar.gz
ports-8902a20e43b0e2917d2afa4b60514b32d30adccf.zip
Notes
Diffstat (limited to 'graphics/dynamechs')
-rw-r--r--graphics/dynamechs/Makefile6
-rw-r--r--graphics/dynamechs/distinfo2
-rw-r--r--graphics/dynamechs/files/make.platform.freebsd2
-rw-r--r--graphics/dynamechs/files/patch-dm::dm.h37
-rw-r--r--graphics/dynamechs/files/patch-dmGL::dmGL.h28
-rw-r--r--graphics/dynamechs/pkg-descr22
6 files changed, 73 insertions, 24 deletions
diff --git a/graphics/dynamechs/Makefile b/graphics/dynamechs/Makefile
index 59ec63345c72..e778297243fe 100644
--- a/graphics/dynamechs/Makefile
+++ b/graphics/dynamechs/Makefile
@@ -17,6 +17,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Multibody Dynamic Simulation Library
+USE_BZIP2= yes
USE_MESA= yes
USE_GMAKE= yes
MAKE_ENV= OPENGLINCDIR="${X11BASE}/include" \
@@ -28,14 +29,15 @@ ALL_TARGET= freebsd
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
+BROKEN= "Does not compile (bad C++ code)"
.endif
do-configure:
- @${CP} -f ${FILESDIR}/make.platform.freebsd ${WRKSRC}/make
+ @${CP} -f ${FILESDIR}/make.platform.freebsd ${WRKSRC}/make/
do-install:
.for dir in dm dmu dmGL
+ ${RM} -f ${WRKSRC}/${dir}/*.orig
@${MKDIR} ${PREFIX}/include/${PORTNAME}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/*.h* ${PREFIX}/include/${PORTNAME}/${dir}
${INSTALL_DATA} ${WRKSRC}/lib/platform.freebsd/lib${dir}.so ${PREFIX}/lib
diff --git a/graphics/dynamechs/distinfo b/graphics/dynamechs/distinfo
index 9330ecf008d2..2bf28f906447 100644
--- a/graphics/dynamechs/distinfo
+++ b/graphics/dynamechs/distinfo
@@ -1 +1 @@
-MD5 (dynamechs_4.0pre1.tar.gz) = ca082694968d97b3e41c38fc69ee045b
+MD5 (dynamechs_4.0pre1.tar.bz2) = 08e5b2ce9227c3e5aec4ca0dcab262be
diff --git a/graphics/dynamechs/files/make.platform.freebsd b/graphics/dynamechs/files/make.platform.freebsd
index 5e6913655227..cd55383e7ba4 100644
--- a/graphics/dynamechs/files/make.platform.freebsd
+++ b/graphics/dynamechs/files/make.platform.freebsd
@@ -5,7 +5,7 @@ DEPENDFLAGS := $(CXXFLAGS)
LDFLAGS += -fPIC -L/$(OPENGLLIBDIR) -L${X11BASE}/lib -lX11 -lm -l$(MESA)GLU -l$(MESA)GL
LDGLUT := -lglut
-# CXX := g++
+# CXX := c++
LINKER := $(CXX)
SHLINKER := $(CXX)
diff --git a/graphics/dynamechs/files/patch-dm::dm.h b/graphics/dynamechs/files/patch-dm::dm.h
index 49c25777e1b3..f597410da31a 100644
--- a/graphics/dynamechs/files/patch-dm::dm.h
+++ b/graphics/dynamechs/files/patch-dm::dm.h
@@ -1,15 +1,32 @@
---- dm/dm.h.orig Thu Jul 19 08:40:37 2001
-+++ dm/dm.h Sat Dec 21 08:58:14 2002
-@@ -51,10 +51,11 @@
- // a bunch of hacks to select standard conforming iostream stuff if available
- // on the platform
+--- dm/dm.h.orig Wed Jul 18 18:40:37 2001
++++ dm/dm.h Sat Sep 13 11:00:02 2003
+@@ -48,18 +48,9 @@
+ #include <windows.h>
+ #endif
+-// a bunch of hacks to select standard conforming iostream stuff if available
+-// on the platform
+-
-#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91))
-+#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91)) || (defined(__GNUC__) && (__GNUC__>=3))
#include <iostream>
#include <iomanip>
#include <fstream>
-+using namespace std;
- #else
- #include <iostream.h>
- #include <iomanip.h>
+-#else
+-#include <iostream.h>
+-#include <iomanip.h>
+-#include <fstream.h>
+-#endif
+
+ #include <math.h>
+ #include <stdlib.h>
+@@ -102,10 +93,8 @@
+ };
+
+ // Use the std namespace. To do this we must first guarantee that it exists.
+-#if defined(__sgi) || defined(__WIN32_) || defined(WIN32)
+ namespace std {}
+ using namespace std;
+-#endif
+
+ //----------------------------------------------------------------------------
+ inline void normalizeQuat(Quaternion quat)
diff --git a/graphics/dynamechs/files/patch-dmGL::dmGL.h b/graphics/dynamechs/files/patch-dmGL::dmGL.h
index 9b2f70e75559..6ca4456b07b8 100644
--- a/graphics/dynamechs/files/patch-dmGL::dmGL.h
+++ b/graphics/dynamechs/files/patch-dmGL::dmGL.h
@@ -1,14 +1,26 @@
---- dmGL/dmGL.h.orig Thu Jul 19 08:40:38 2001
-+++ dmGL/dmGL.h Sat Dec 21 08:54:11 2002
-@@ -44,9 +44,10 @@
+--- dmGL/dmGL.h.orig Sun Sep 14 21:05:00 2003
++++ dmGL/dmGL.h Sun Sep 14 21:05:40 2003
+@@ -44,13 +44,8 @@
// a bunch of hacks to select standard conforming iostream stuff if available
// on the platform
-#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91))
-+#if defined(WIN32) || (defined(sgi) && defined(_STANDARD_C_PLUS_PLUS)) || (defined(__GNUC__) && (__GNUC__>=2) && (__GNUC_MINOR__>=91)) || (defined(__GNUC__) && (__GNUC__>=3))
#include <iostream>
#include <iomanip>
-+using namespace std;
- #else
- #include <iostream.h>
- #include <iomanip.h>
+-#else
+-#include <iostream.h>
+-#include <iomanip.h>
+-#endif
+
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+@@ -68,9 +63,7 @@
+ #endif
+
+ // Use the std namespace. To do this we must first guarantee that it exists.
+-#if defined(__sgi) || defined(__WIN32_) || defined(WIN32)
+ namespace std {}
+ using namespace std;
+-#endif
+
+ #endif
diff --git a/graphics/dynamechs/pkg-descr b/graphics/dynamechs/pkg-descr
index 5d15d13f00b8..cc2e53756608 100644
--- a/graphics/dynamechs/pkg-descr
+++ b/graphics/dynamechs/pkg-descr
@@ -1,3 +1,21 @@
-DynaMechs (Dynamics of Mechanisms): A Multibody Dynamic Simulation Library
+ DynaMechs (Dynamics of Mechanisms)
+ A Multibody Dynamics Simulation Library
-WWW: http://dynamechs.sourceforge.net/
+This is a set of cross-platform C++ libraries licensed under the Gnu's GPL
+(see LICENSE) which implements dynamic simulation functionality for multibody
+systems. It currently supports all tree structured mechanism, a class of
+closed chain mechanisms as well. It has provisions for generating both
+single and double precision version, and there is code for simplified
+hydrodynamic simulation.
+
+This work is an extension of my Ph.D. dissertation, "Computational Dynamics
+for Robotic Systems on Land and Underwater," The Ohio State University, 1994,
+and continued at the Naval Postgraduate School.
+
+The closed chain work is derived from Duane Marhefka's Ph.D. dissertation,
+"Fuzzy Control and Dynamic Simulation of a Quadruped Galloping Machine," The
+Ohio State University, 2000.
+
+(c) 1994 - 2001 by Scott McMillan
+
+ WWW: http://dynamechs.sourceforge.net/