aboutsummaryrefslogtreecommitdiff
path: root/graphics/ecg2png
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-04 05:09:41 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-04 05:09:41 +0000
commite9188fa59fd4adca45a40fb2f65417fcdc7e560c (patch)
tree21db87779944d95ff9de444c86b130e49da6d410 /graphics/ecg2png
parent4c7124b3dbe8eee504f84a9266c79acd77f1253c (diff)
downloadports-e9188fa59fd4adca45a40fb2f65417fcdc7e560c.tar.gz
ports-e9188fa59fd4adca45a40fb2f65417fcdc7e560c.zip
Notes
Diffstat (limited to 'graphics/ecg2png')
-rw-r--r--graphics/ecg2png/Makefile24
-rw-r--r--graphics/ecg2png/distinfo1
-rw-r--r--graphics/ecg2png/files/patch-aa10
-rw-r--r--graphics/ecg2png/files/patch-ab10
-rw-r--r--graphics/ecg2png/files/patch-ac11
-rw-r--r--graphics/ecg2png/pkg-comment1
-rw-r--r--graphics/ecg2png/pkg-descr19
-rw-r--r--graphics/ecg2png/pkg-plist1
8 files changed, 77 insertions, 0 deletions
diff --git a/graphics/ecg2png/Makefile b/graphics/ecg2png/Makefile
new file mode 100644
index 000000000000..6e2ef7cc49e6
--- /dev/null
+++ b/graphics/ecg2png/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ecg2png
+# Date created: Sun 2 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecg2png
+PORTVERSION= 0.30
+CATEGORIES= graphics
+MASTER_SITES= ftp://www.cardiothink.com/pub/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
+
+USE_QT2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/qt2 -I${LOCALBASE}/include/gd" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/ecg2png/distinfo b/graphics/ecg2png/distinfo
new file mode 100644
index 000000000000..8844a0a54545
--- /dev/null
+++ b/graphics/ecg2png/distinfo
@@ -0,0 +1 @@
+MD5 (ecg2png-0.30.tar.gz) = af0012583786d6ab9124847358ddfd5e
diff --git a/graphics/ecg2png/files/patch-aa b/graphics/ecg2png/files/patch-aa
new file mode 100644
index 000000000000..370b8ae5f867
--- /dev/null
+++ b/graphics/ecg2png/files/patch-aa
@@ -0,0 +1,10 @@
+--- ecg2png/imageio.cpp Sun Oct 17 20:29:21 1999
++++ ecg2png/imageio.cpp.new Tue Jul 4 00:51:57 2000
+@@ -19,7 +19,6 @@
+ #include <stdio.h>
+ #include "my_imageio.h"
+ #include <qimage.h>
+-#include <qimageio.h>
+ #include <qpixmap.h>
+ #include <qpngio.h>
+
diff --git a/graphics/ecg2png/files/patch-ab b/graphics/ecg2png/files/patch-ab
new file mode 100644
index 000000000000..c6c1b9f245d4
--- /dev/null
+++ b/graphics/ecg2png/files/patch-ab
@@ -0,0 +1,10 @@
+--- ecg2png/smooth_image.cpp Sun Oct 17 12:00:50 1999
++++ ecg2png/smooth_image.cpp.new Tue Jul 4 00:52:14 2000
+@@ -18,7 +18,6 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <qimage.h>
+-#include <qimageio.h>
+ #include "my_imageio.h"
+
+ extern QImageIO iio;
diff --git a/graphics/ecg2png/files/patch-ac b/graphics/ecg2png/files/patch-ac
new file mode 100644
index 000000000000..9e3801082cd0
--- /dev/null
+++ b/graphics/ecg2png/files/patch-ac
@@ -0,0 +1,11 @@
+--- ecg2png/Makefile.in Sun Oct 17 20:32:52 1999
++++ ecg2png/Makefile.in.new Tue Jul 4 00:55:18 2000
+@@ -70,7 +70,7 @@
+ ####### kdevelop will overwrite this part!!! (end)############
+ bin_PROGRAMS = ecg2png
+ ecg2png_SOURCES = smooth_image.cpp imageio.cpp main.cpp
+-ecg2png_LDADD = -lpng -lgd -lqt
++ecg2png_LDADD = -lpng -lgd -lqt2
+
+ SUBDIRS = docs
+
diff --git a/graphics/ecg2png/pkg-comment b/graphics/ecg2png/pkg-comment
new file mode 100644
index 000000000000..3474c2b5139f
--- /dev/null
+++ b/graphics/ecg2png/pkg-comment
@@ -0,0 +1 @@
+Converts scanned 12-lead electrocardiograms into PNGs
diff --git a/graphics/ecg2png/pkg-descr b/graphics/ecg2png/pkg-descr
new file mode 100644
index 000000000000..d7432dbda191
--- /dev/null
+++ b/graphics/ecg2png/pkg-descr
@@ -0,0 +1,19 @@
+This program is designed to convert scanned 12-lead
+electrocardiograms into PNG format and a web-friendly
+image size. It assumes that the electrocardiogram (ECG)
+is printed with a black line on white paper with a red grid.
+
+The problems this program is designed to solve are (1) an
+ECG scanned at relatively high resolution (300 to 600 dots
+per inch) imposes a substantial load on the web browser
+because it contains about 6 million pixels which may require
+18 to 24 MB of RAM to store for display. Also, (2) typical
+scanners convert a clean paper ECG into a multitude of colors,
+include green and blue. The resulting file cannot be compressed
+efficiently because it does not contain as much redundancy, and
+thus takes more time to transmit over low-speed network connections.
+
+WWW: http://www.cardiothink.com/downloads/ecg2png/
+Author: Lawrence Widman <widman@cardiothink.com>
+
+- Will <andrews@technologist.com>
diff --git a/graphics/ecg2png/pkg-plist b/graphics/ecg2png/pkg-plist
new file mode 100644
index 000000000000..8737fa851fcd
--- /dev/null
+++ b/graphics/ecg2png/pkg-plist
@@ -0,0 +1 @@
+bin/ecg2png